Subject: [PWE3] Query regarding VCCV Ping

From: Suresh Babu Gajapathy <[email-masked]>
Date: Thu, 7 Aug 2008 15:36:15 +0530

Hi everyone,

I have few queries on VCCV Ping.

1. What is the reverse path taken for VCCV Ping .
    i.e., Assuming VCCV Channel as Type -1 When LSP Ping Echo Request are sent then it has 2 labels ( Tunnel Label, VC Label ) and Control Word with payload as LSP Ping Request. What will the reverse path taken. Will it be Tunnel Label, VC Label and Control word with LSP Ping Reply payload or will it be IP Path ?

Thanks
suresh

________________________________
"DISCLAIMER: This message is proprietary to Aricent and is intended solely for the use of the individual to whom it is addressed. It may contain privileged or confidential information and should not be circulated or used for any purpose other than for what it is intended. If you have received this message in error,please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly prohibited from using, copying, altering, or disclosing the contents of this message. Aricent accepts no responsibility forloss or damage arising from the use of the information transmitted by this email including damage from virus."
_______________________________________________
pwe3 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pwe3

---

From: "Phaniraj Vattem" <[email-masked]>
Date: Thu, 7 Aug 2008 16:37:33 +0530

Suresh,

I think LSP Ping Echo reply can travel via IP path or MPLS Path. It depends
on the "Reply Mode" set in the MPLS Echo request.
But in the case of VCCV using LSP Ping the reply mode should be set to 4
(Reply via application level control channel"), so that the ping replier
will push the reply on to the MPLS Path using the proper label stack.

Thanks
Phaniraj.

On Thu, Aug 7, 2008 at 3:36 PM, Suresh Babu Gajapathy <
[email-masked]> wrote:

>     i.e., Assuming VCCV Channel as Type -1 When LSP Ping Echo Request are
> sent then it has 2 labels ( Tunnel Label, VC Label ) and Control Word with
> payload as LSP Ping Request. What will the reverse path taken. Will it
> be Tunnel Label, VC Label and Control word with LSP Ping Reply payload or
> will it be IP Path ?
>
>
> Thanks
> suresh
>
>
>
>
>
> ------------------------------
> "DISCLAIMER: This message is proprietary to Aricent and is intended solely
> for the use of the individual to whom it is addressed. It may contain
> privileged or confidential information and should not be circulated or used
> for any purpose other than for what it is intended. If you have received
> this message in error,please notify the originator immediately. If you are
> not the intended recipient, you are notified that you are strictly
> prohibited from using, copying, altering, or disclosing the contents of this
> message. Aricent accepts no responsibility forloss or damage arising from
> the use of the information transmitted by this email including damage from
> virus."
>

---

From: "AISSAOUI Mustapha" <[email-masked]>
Date: Thu, 7 Aug 2008 12:48:00 -0500

Suresh and Phaniraj,
both reply modes are supported. 
 
The reply over the IP path may be the only way in some cases. In MS-PW,
the replier may not know how many hops away is the sender of the echo
request message when the sender is not the T-PE. 
 
Mustapha.

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of Phaniraj Vattem
	Sent: Thursday, August 07, 2008 7:08 AM
	To: Suresh Babu Gajapathy
	Cc: [email-masked]
	Subject: Re: [PWE3] Query regarding VCCV Ping

	Suresh,
	
	I think LSP Ping Echo reply can travel via IP path or MPLS Path.
It depends on the "Reply Mode" set in the MPLS Echo request.
	But in the case of VCCV using LSP Ping the reply mode should be
set to 4 (Reply via application level control channel"), so that the
ping replier will push the reply on to the MPLS Path using the proper
label stack. 
	
	Thanks
	Phaniraj.

	On Thu, Aug 7, 2008 at 3:36 PM, Suresh Babu Gajapathy
<[email-masked]> wrote:

		Hi everyone,

		1. What is the reverse path taken for VCCV Ping . 
		    i.e., Assuming VCCV Channel as Type -1 When LSP Ping
Echo Request are sent then it has 2 labels ( Tunnel Label, VC Label )
and Control Word with payload as LSP Ping Request. What will the reverse
path taken. Will it be Tunnel Label, VC Label and Control word with LSP
Ping Reply payload or will it be IP Path ?

		Thanks
		suresh

		"DISCLAIMER: This message is proprietary to Aricent and
is intended solely for the use of the individual to whom it is
addressed. It may contain privileged or confidential information and
should not be circulated or used for any purpose other than for what it
is intended. If you have received this message in error,please notify
the originator immediately. If you are not the intended recipient, you
are notified that you are strictly prohibited from using, copying,
altering, or disclosing the contents of this message. Aricent accepts no
responsibility forloss or damage arising from the use of the information
transmitted by this email including damage from virus."