Subject: [PWE3] BFD path not forwarding code point needed ?

From: Luca Martini <[email-masked]>
Date: Thu, 18 Sep 2008 15:06:30 -0600

Hello!

When the authors of the OAM MSG map draft , and I where reviewing the 
BFD/VCCV status code points that should be used when the PW control 
plane is not used, I noticed that we are missing a "Path not forwarding" 
code point in BFD. The current code that can be used, are :

   0 - No diagnostic:
   1 - Control detection time expired
   7 - Administratively Down
   6 -- Concatenated Path Down
   8 -- Reverse Concatenated Path Down

Note that code 7 applies to the BFD session , and not to the path.

I suggest that we ask for a new code to be allocated ( I would  suggest 
9 )  with a definition of "path down" or something similar. the state 
for this code would be  3 -- Up .

This would match the code point of   0x00000001 - Pseudowire Not 
Forwarding   in RFC4447.

Any comments ?

Thanks.
Luca

_______________________________________________
pwe3 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pwe3

---

From: Alexander Vainshtein <[email-masked]>
Date: Thu, 25 Sep 2008 16:55:02 +0300

Luca,
If I understand you correctly, we're speaking about BFD in VCCV.
And if the PW path is not forwarding, BFD in VCCV will not be delivered either.
So it looks as if the new code point would never be received.
Did I miss something?

Regards,
        Sasha
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Luca Martini
> Sent: Friday, September 19, 2008 12:07 AM
> To: PWE3 WG (E-mail)
> Cc: [email-masked]
> Subject: [PWE3] BFD path not forwarding code point needed ?
>
> Hello!
>

---

From: "Vishwas Manral" <[email-masked]>
Date: Fri, 26 Sep 2008 12:25:46 +0530

Hi Sasha,

The diagnostics code is used for the local session diagnostics too and
not just for inclusion in the diag field of the BFD packet. Is there
something I am missing here?

Thanks,
Vishwas