Subject: [PWE3] flow label format in draft-ietf-fat-pw-01

From: lucy yong <[email-masked]>
Date: Tue, 03 Nov 2009 15:57:03 +0800

Hi Steward,

Section 4.1 state:

The structure of the flow label TLV is shown in Figure 3.
 
    0                   1                   2                   3
    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   | FL            |    Length     |F|       must be zero          |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
 
                         Figure 3: Multiple VC TLV
 
   Where:
 
   o  FL is the flow label TLV identifier assigned by IANA.
 
   o  Length is the length of the TLV in octets and is 4.
 
   o  When F=1 a flow label will be pushed.  When F=0 a flow label will
      not be pushed.

Two questions: 1) why bits from 17~31 has to be zero? Is any place use these
bits? If not, it should be defined as reserved bits.
2)      Is F bit useful? When label TLV is inserted, PE does not insert a
flow label and any P can not change the label value. Is this a useful case
in network? 
 
Regards,
Lucy

---

From: Stewart Bryant <[email-masked]>
Date: Tue, 03 Nov 2009 09:12:59 +0000

Lucy

I recently published draft-ietf-pwe3-fat-pw-02, which has some important
changes in the signaling procedure.
> Two questions: 1) why bits from 17~31 has to be zero? Is any place use these bits? If not, it should be defined as reserved bits.
OK, they could usefully be marked Reserved (MBZ on TX, ignored on RX)
> 2)      Is F bit useful? When label TLV is inserted, PE does not insert a flow label and any P can not change the label value. Is this a useful case in network? 
Please look at the -02 procedure (section 4).

The presence of the TLV indicates that the PE can understand FL. The 
state of the,
F flag say that one will be present in the packet.

Without the F bit, the receiving PE will not know whether to expect an 
FL or not.

- Stewart