Subject: [PWE3] Questions on draft-martini-pwe3-static-pw-status-02.txt

From: Linda Dunbar <[email-masked]>
Date: Wed, 02 Dec 2009 11:00:19 -0600

The "draft-martini-pwe3-static-pw-status-02.txt" stated using ACH for
exchange PW OAM status. Is PW's ACH same as PW's VCCV? 

The RFC 4447 described PW Status to be exchanged via LDP notification which
is over TCP. I am just curious why the static PW can't use the PW Status via
notification defined by RFC 4447?  

Thank you very much. 

Linda Dunbar

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Stewart Bryant
Sent: Friday, November 20, 2009 2:17 PM
To: [email-masked]
Cc: pwe3
Subject: Re: [PWE3] draft-martini-pwe3-static-pw-status-02.txt now WG draft

I have seen a large number of accepts and no objections.

Please will the authors resubmit this as a WG document.

As discussed at the WG, will the authors please remove the reference to 
MPLS-TP. This work is useful in it's own right, and any applicability to 
MPLS-TP should be decided by the MPLS-TP project.

- Stewart

Stewart Bryant wrote:
> This is a poll to see if
>
> http://tools.ietf.org/id/draft-martini-pwe3-static-pw-status-02.txt
>
> should be accepted as a PWE3 WG draft.
>
> Please reply "accept" or "do not accept" to this thread.
>
> Please start a new thread on for technical discussions on the draft.
>
> In view of the timing of IETF, I will close the poll Sunday 22nd 
> November.
>
> - Stewart
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pwe3
>

_______________________________________________
pwe3 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pwe3

---

From: Stewart Bryant <[email-masked]>
Date: Wed, 02 Dec 2009 17:10:20 +0000

Linda:

It is explained in the introduction:

The default control plane for Pseudowire (PW) technology, as defined in 
[RFC4447], is based on LDP. However that document also describes a 
static provisioning mode without control plane. When a static PW is used 
, there is no method to transmit the status of the PW, or attachment 
circuit (AC) between the two PEs at each end of the PW.

I.e. when there is no LDP there is no current method of exchanging 
status, so a new method is needed, and that is described in this document.
.
- Stewart

---

From: Linda Dunbar <[email-masked]>
Date: Wed, 02 Dec 2009 16:00:14 -0600

With PW OAM message defined for static PW, can PW established by LDP also
use this OAM message instead of the LDP notification message? 

Linda 

-----Original Message-----
From: Stewart Bryant [mailto:[email-masked]] 
Sent: Wednesday, December 02, 2009 11:10 AM
To: Linda Dunbar
Cc: 'pwe3'
Subject: Re: [PWE3] Questions on draft-martini-pwe3-static-pw-status-02.txt

Linda:

---

From: Luca Martini <[email-masked]>
Date: Thu, 03 Dec 2009 09:04:55 -0700

> use this OAM message instead of the LDP notification message? 
No.
This has been the case for the past 10 years, as defined in rfc4447.
The control plane is in control of the PW. So you cannot use a special 
channel to bypass the control plane.
Even the bypass message that is defined in this draft today does not 
work as mentioned. I believe we will be dropping that feature as it 
cannot be made to work without changing the basic design.
( we are missing the information about the origin on the message ).

I hope this helps.
Luca

>> The RFC 4447 described PW Status to be exchanged via LDP notification
>>     
> which
>   
>> is over TCP. I am just curious why the static PW can't use the PW Status
>>     
> via
>   
>> Subject: Re: [PWE3] draft-martini-pwe3-static-pw-status-02.txt now WG
>>     
> draft
>

---

From: Luca Martini <[email-masked]>
Date: Thu, 03 Dec 2009 09:04:43 -0700

No.

I hope this helps.
Luca