Subject: [PWE3] Comment on < draft-ietf-pwe3-redundancy-bit-02.txt>

From: Veer Gorla <[email-masked]>
Date: Wed, 9 Dec 2009 17:54:22 -0500

Hi,
The draft says
 Sec  4.1 & 4.2 . Standby State...
"If the PW is a spoke in H-VPLS, any MAC addresses learned via the PW should be flushed when it transitions to Standby state. "

This statement seems like implying that   MAC flush must be sent into the mesh by PE-rs node ( optionally)  inaddition to MTU-s node based on configuration.
I think  it is better for MAC flush to be triggered by newly active PE-rs node when it is transition to Active State. This could cover the case when the old-active
 node goes down and it is unable to send out the flush.

Regards
Veer

---

From: "AISSAOUI Mustapha" <[email-masked]>
Date: Tue, 29 Dec 2009 21:19:34 -0600

Hi Veer,
sorry for the late reply.
 
Both behaviours are actually possible. 
 
The case described in the draft is when the PE-rs nodes are configured
to not forward the MAC flush message received from the MTU node over the
newly active PW. In this case, it is up to the PE-rs node which had its
PW transition to Standby state to generate a MAC flush to have the nodes
in the VPLS mesh clear FIB entries they learned from this node.
 
The case you describe is when the PE-rs nodes are configured to forward
the MAC flush message received from the MTU node over the newly active
PW. In this case, the PE-rs node which had its PW transition to Active
state must forward the MAC flush message to have the nodes in the VPLS
mesh clear all FIB entries except those they learn from this node.

Let me know if you agree with this and I will add this in the next
revision of the draft.
 
Regards,
Mustapha.

________________________________

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of Veer Gorla
	Sent: Wednesday, December 09, 2009 5:54 PM
	To: [email-masked]
	Subject: [PWE3] Comment on <
draft-ietf-pwe3-redundancy-bit-02.txt>

	Hi,
	The draft says
	Sec  4.1 & 4.2 . Standby State...  
	"If the PW is a spoke in H-VPLS, any MAC addresses learned via
the PW should be flushed when it transitions to Standby state. "
	 
	This statement seems like implying that   MAC flush must be sent
into the mesh by PE-rs node ( optionally)  inaddition to MTU-s node
based on configuration. 
	I think  it is better for MAC flush to be triggered by newly
active PE-rs node when it is transition to Active State. This could
cover the case when the old-active
	node goes down and it is unable to send out the flush.

	Regards
	Veer