Subject: [PWE3] Comment on draft-ietf-pwe3-redundancy-bit-02

From: Olen Stokes <[email-masked]>
Date: Mon, 11 Jan 2010 07:30:49 -0800

>From the Introduction of the subject draft:

   This document specifies a new PW status bit to indicate the
   preferential forwarding status of the PW for the purpose of notifying
   the remote PE of the active/standby state of each PW in the
   redundancy set.

The PwOperStatusTC in RFC5542 does not contain a standby state.  From an off-line discussion with Tom Nadeau, it appears that it is not possible to add a new standby state for pwOperStatus at this time (Tom, thanks for the assistance).

One possibility that was suggested is to amend RFC5542's description of PwOperStatusTC and one of its states.  To me, the description of the dormant state seems to be applicable to a PW in the standby state.  From RFC5542:

        - dormant(4):        The PW is not in a condition to pass
                             packets but is in a 'pending' state,
                             waiting for some external event.

I would like to suggest that a statement be added to draft-ietf-pwe3-redundancy-bit-02 that a PW in a standby state use a pwOperStatus of dormant.

If this approach is agreeable, I would be happy to produce any additional drafts required to formally amend RFC5542.

Cheers,
Olen

---

From: Thomas Nadeau <[email-masked]>
Date: Mon, 11 Jan 2010 07:52:36 -0500

This is a question for the AD. I wonder if we could add an errata to
RFC5542 to indicate this modification as well so that it is repaired when
the MIBs are taken to the proposed standard state in the future?

    --Tom

On 1/11/10 10:30 AM, "Olen Stokes" <[email-masked]> wrote:

> The PwOperStatusTC in RFC5542 does not contain a standby state.  From an
> off-line discussion with Tom Nadeau, it appears that it is not possible to add
> a new standby state for pwOperStatus at this time (Tom, thanks for the
> assistance).
>  
> One possibility that was suggested is to amend RFC5542¹s description of
> PwOperStatusTC and one of its states.  To me, the description of the dormant
> state seems to be applicable to a PW in the standby state.  From RFC5542:
>  
> I would like to suggest that a statement be added to
> draft-ietf-pwe3-redundancy-bit-02 that a PW in a standby state use a
> pwOperStatus of dormant.
>  
> If this approach is agreeable, I would be happy to produce any additional
> drafts required to formally amend RFC5542.
>  
> Cheers,
> Olen
>  
>  
>  
>  
>  
> 
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pwe3