Subject: [PWE3] comments for draft-ietf-pwe3-redundancy-bit-02

From: [email-masked]
Date: Mon, 4 Jan 2010 16:41:03 +0800

Hi authors:
I have following comments about this draft:
1. section 4.1, standby state defintion. The statement dose not mention 
the relationship between PW status and standby state. I don't think PW is 
still in standby state when PW is DOWN. Same defintion ambiguity for 
section 4.2.
2. section 5.2.1, PW state transition state table. From my understanding, 
all the "receive" operation is only applicable for slave node, because 
master node will ignore any status bit information from slave node. So it 
is necessary to make the description more clear.
3. section 5.3.1, paragraph e. Why does the updated status notification 
need to include all the PW status in the redundancy set. If one of the PW 
status is not changed, it is not necessary to be updated. Same comment for 
section 5.3.2, paragraph a.

Thank you.

Best Regards
Lizhong Jin

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: "AISSAOUI Mustapha" <[email-masked]>
Date: Tue, 5 Jan 2010 15:30:46 -0600

Hi Lizhong,
thank you for the comments. See below for some elements of response.
 
Mustapha.

________________________________

	From: [email-masked] [mailto:[email-masked]] 
	Sent: Monday, January 04, 2010 3:41 AM
	To: MULEY Praveen; AISSAOUI Mustapha; BOCCI Matthew;
[email-masked]; LASSERRE MARC; [email-masked];
[email-masked]; [email-masked]; [email-masked];
[email-masked]
	Cc: [email-masked]
	Subject: [PWE3]comments for draft-ietf-pwe3-redundancy-bit-02

	Hi authors: 
	I have following comments about this draft: 
	1. section 4.1, standby state defintion. The statement dose not
mention the relationship between PW status and standby state. I don't
think PW is still in standby state when PW is DOWN. Same defintion
ambiguity for section 4.2.  
	MA> When the PW is operationally down, you must signal "PW down"
status bits. Whether you also signal "standby" status or not does not
make a difference to the remote node as the "PW down" status will take
precedence.
	 
	2. section 5.2.1, PW state transition state table. From my
understanding, all the "receive" operation is only applicable for slave
node, because master node will ignore any status bit information from
slave node. So it is necessary to make the description more clear.  
	MA> You are correct but for the case where the state changes
from Active-to-Standby or vice-versa:
	
	STATE         EVENT                                   NEW STATE

	ACTIVE        Receive PW preferential forwarding      STANDBY
	
	              bit set (slave)
	
	              Action: Stop forwarding over PW

	STANDBY       Receive PW preferential forwarding      ACTIVE
	
	              bit clear  (slave)
	 
	               Action: Activate PW
	
	The other cases do not cause a state change and thus do not
require the recieve node to be the "slave" node.
	 
	3. section 5.3.1, paragraph e. Why does the updated status
notification need to include all the PW status in the redundancy set. If
one of the PW status is not changed, it is not necessary to be updated.
Same comment for section 5.3.2, paragraph a. 
	MA>  You are correct, only the PWs for which the operation
resulted in a change of the status bits will have to send an update. I
will correct the text in both paragraphs and also in 5.3.1.g.
	 
	Thank you. 
	
	Best Regards 
	Lizhong Jin 

	--------------------------------------------------------
	ZTE Information Security Notice: The information contained in
this mail is solely property of the sender's organization. This mail
communication is confidential. Recipients named above are obligated to
maintain secrecy and are not permitted to disclose the contents of this
communication to others.
	This email and any files transmitted with it are confidential
and intended solely for the use of the individual or entity to whom they
are addressed. If you have received this email in error please notify
the originator of the message. Any views expressed in this message are
those of the individual sender.
	This message has been scanned for viruses and Spam by ZTE
Anti-Spam system.