Subject: [PWE3] draft-ietf-pwe3-dynamic-ms-pw-10.txt

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Tue, 15 Jun 2010 18:53:25 +0200

Luca,

What is the reason we did not include the RD in the NLRI Field ? With other MP-BGP solutions this allows for optimal resilience. On top it also provides a common operations between different MP-BGP solutions.

Interested to understand the reason and looking to see if we can still add it if people agree.

Cheers,
Wim

---

From: Luca Martini <[email-masked]>
Date: Tue, 15 Jun 2010 17:15:09 -0600

Henderickx, Wim (Wim) wrote:
>
> Luca,
>
>  
>
> What is the reason we did not include the RD in the NLRI Field ? With 
> other MP-BGP solutions this allows for optimal resilience. On top it 
> also provides a common operations between different MP-BGP solutions.
>
>  
>
we did not add it because this is not a vpn, hence we did not need a 
address discriminator in BGP. For the multiple path requirement we were 
planning to use bgp add path.
> Interested to understand the reason and looking to see if we can still 
If you agree , I think this it would be a good idea to add the RD back 
because it seems that the  add-path
is not a popular BGP feature at this time, and I do not want to have our 
dynamic MS-PW solution depend on a feature that is quite complicated to 
develop and deploy.

Thanks.
Luca

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Wed, 16 Jun 2010 05:47:28 +0200

Luca, I believe we should add the RD to the NLRI.

-----Original Message-----
From: Luca Martini [mailto:[email-masked]] 
Sent: woensdag 16 juni 2010 1:15
To: Henderickx, Wim (Wim)
Cc: [email-masked]
Subject: Re: draft-ietf-pwe3-dynamic-ms-pw-10.txt

Thanks.
Luca