Subject: [PWE3] Overriding 5586 restrictions for PWs?

From: Alexander Vainshtein <[email-masked]>
Date: Thu, 29 Jul 2010 10:21:28 +0300

Luca and all,
I wonder whether overriding the 5586 restriction for using GAL in PWs makes much  sense.

The rationale for this doubt is based on the abstract view of MPLS and PW architecture and goes like following:

1.      To the best of my understanding, the ILM action associated with the PW label in T-PE is

a.      Pop

b.      Forward to a dedicated forwarder that is identified by the (now popped) PW label. This could be a trivial 1:1 PW forwarder, a VSI or something else.

2.      If this understanding is correct, the MPLS Forwarder would ignore the GAL as an "exception label" even in T-PE. (Of course this is exactly what would happen in S-PE, where the ILM action associated with the received PW label is "swap, push a new tunnel label and forward to the next hop towards the next S- or T-PE).

3.      If the PW does not use a CW, its forwarder would not be, generally speaking, able to distinguish between GAL and the first 32 bits of a regular packet.

4.      These problems could be resolved by looking at the BoS it in the PW label:  If BoS is set, send the packet to the PW forwarder, otherwise send it to some other entity that would examine the next label. However, this entity could not be a 3031-compliant MPLS forwarding instance itself, because it  would have to make some forwarding decisions based on both the PW label and GAL.

Looking at the original problem that (presumably) you have been trying to solve, I'd guess that it is demultiplexing OAM messages by type (ICMP Ping, LSP Ping, BFD, static PW status etc.).   This problem has been solved for all the OAM message types excluding static PW static by encapsulating all these messages in UDP/IP packets with UDP port-based demuxing.

Regards,
     Sasha

---

From: Luca Martini <[email-masked]>
Date: Thu, 29 Jul 2010 03:14:11 -0600

> b.      Forward to a dedicated forwarder that is identified by the (now popped) PW label. This could be a trivial 1:1 PW forwarder, a VSI or something else.
no that is not correct.
The pop will only forward if the S bit =1.
in this case s=0.

> 4.      These problems could be resolved by looking at the BoS it in the PW label:  If BoS is set, send the packet to the PW forwarder, otherwise send it to some other entity that would examine the…
we cannot break MPLS. A label stack without an s=1 label is a broken
MPLS stack.
> Looking at the original problem that (presumably) you have been trying to solve, I'd guess that it is demultiplexing OAM messages by type (ICMP Ping, LSP Ping, BFD, static PW status etc.).   This p…
Luca

---

From: Alexander Vainshtein <[email-masked]>
Date: Thu, 29 Jul 2010 13:18:15 +0300

Luca,
You've said:

	no that is not correct.

Could you point to some text in 3031 (or 3032) that says so?
Actually, I can point to the text that states that the action on a label does not
depend on its position in the stack. 

And, as a counterexample, popping and forwarding on a popped label with S=0 works quite well 
when you use PHP of a tunnel label carrying PWs and expose just the PW label to the PE... 
So what is the difference?

I think that S=1 should only be checked on a popped label if the NH in the appropriate
NHLFE is the LSR itself (i.e., its loopback interface). In this case S=0 would mean
forwarding back to the MPLS forwarder, while S=1 would mean that the network protocol
of the unlabeled packet must be inferred from the popped label (at least, this is my
reading of 3031 and 3032). But this is IMHO not the case with the PWs, where  the NH is 
specific PW forwarder.

Regards,
     Sasha

-----Original Message-----
From: Luca Martini [mailto:[email-masked]] 
Sent: Thursday, July 29, 2010 11:14 AM
To: Alexander Vainshtein
Cc: [email-masked]
Subject: Re: Overriding 5586 restrictions for PWs?

no that is not correct.

Luca

---

From: Alexander Vainshtein <[email-masked]>
Date: Fri, 30 Jul 2010 09:39:42 +0300

Re-sending - looks like it has not been delivered...

Regards,
     Sasha

-----Original Message-----
From: Alexander Vainshtein 
Sent: Thursday, July 29, 2010 12:18 PM
To: 'Luca Martini'
Cc: [email-masked]
Subject: RE: Overriding 5586 restrictions for PWs?

Luca,
You've said:

	no that is not correct.

Regards,
     Sasha

-----Original Message-----
From: Luca Martini [mailto:[email-masked]] 
Sent: Thursday, July 29, 2010 11:14 AM
To: Alexander Vainshtein
Cc: [email-masked]
Subject: Re: Overriding 5586 restrictions for PWs?

no that is not correct.

Luca