Subject: [PWE3] Out of order PW OAM packet problem

From: venkatesan mahalingam <[email-masked]>
Date: Fri, 23 Jul 2010 13:05:23 +0530

Hi,
Don't we need to avoid out of order PW OAM packets?

*PW MPLS Control Word*

    0                   1                   2                   3
    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |0 0 0 0| Flags |FRG|  Length   | Sequence Number               |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

        Figure 2: Preferred PW MPLS Control Word
*ACH Header:*

0                   1                   2                   3
   0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |0 0 0 1|Version|   Reserved    |         Channel Type          |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

       Figure 3: PW Associated Channel Header

PW data packets carry PW MPLS Control Word with Sequence Number for frame
ordering, frame duplication detection, and frame loss detection.
As per RFC-5085, PW OAM packets can carry ACH format i.e without Sequence
Number in CW to avoid different ECMP hashing behaviour,
so, how to avoid PW OAM packets' mis-ordering, duplication, and loss without
Sequence number in CW?

-- 
Best Regards,
Venkatesan Mahalingam.

---

From: Stewart Bryant <[email-masked]>
Date: Fri, 23 Jul 2010 09:47:24 +0100

Not if:

1) Messages using the ACH channel are idempotent, or

2) Messages using the ACH channel (that care about sequence) carry a 
sequence number in their payload.

Note that not everything that goes over an ACH is an OAM.

- Stewart

On 23/07/2010 08:35, venkatesan mahalingam wrote:
> _PW MPLS Control Word_
> _ACH Header:_
> PW data packets carry PW MPLS Control Word with Sequence Number for 
> frame ordering, frame duplication detection, and frame loss detection.
> As per RFC-5085, PW OAM packets can carry ACH format i.e without 
> Sequence Number in CW to avoid different ECMP hashing behaviour,
> so, how to avoid PW OAM packets' mis-ordering, duplication, and loss 
> without Sequence number in CW?
> -- 
> Best Regards,
> Venkatesan Mahalingam.
>
>
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pwe3

-- 
For corporate legal information go to:

http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: Alexander Vainshtein <[email-masked]>
Date: Fri, 23 Jul 2010 12:48:11 +0300

Venkatesan,
AFAIK, most PW implementations (excluding TDM PWs) set SN=0 on Tx and hence consider all PW packets as being received "in order" on Rx. This is possible because de-facto reordering only appears as short singular events. And PW clients usually can cope with these events quite well.

TDM PWs really use SN - not so much to fight reordering as to detect and compensate for lost packets.

OAM that is more sensitive to reordering than client traffic should be probably looked at with a grain of salt IMO.

My 2c,
     Sasha

________________________________
From: [email-masked] [[email-masked]] On Behalf Of venkatesan mahalingam [[email-masked]]
Sent: Friday, July 23, 2010 10:35 AM
To: [email-masked]
Subject: [PWE3] Out of order PW OAM packet problem

Hi,

PW MPLS Control Word

    0                   1                   2                   3

ACH Header:

0                   1                   2                   3

PW data packets carry PW MPLS Control Word with Sequence Number for frame ordering, frame duplication detection, and frame loss detection.
As per RFC-5085, PW OAM packets can carry ACH format i.e without Sequence Number in CW to avoid different ECMP hashing behaviour,
so, how to avoid PW OAM packets' mis-ordering, duplication, and loss without Sequence number in CW?

--
Best Regards,
Venkatesan Mahalingam.

---

From: Yaakov Stein <[email-masked]>
Date: Tue, 27 Jul 2010 11:31:06 +0300

add

3) if the intertransmission time of OAM messages is longer than the possible differential delay

Y(J)S

From: [email-masked] [mailto:[email-masked]] On Behalf Of Stewart Bryant
Sent: Friday, July 23, 2010 11:47
To: [email-masked]
Subject: Re: [PWE3] Out of order PW OAM packet problem

Not if:

2) Messages using the ACH channel (that care about sequence) carry a sequence number in their payload.

- Stewart

PW MPLS Control Word

    0                   1                   2                   3

0                   1                   2                   3

--
Best Regards,
Venkatesan Mahalingam.

pwe3 mailing list

[email-masked]<mailto:[email-masked]>

--