Subject: [PWE3] Control Word Problem in RFC4447

From: [email-masked]
Date: Tue, 20 Jul 2010 17:01:44 +0800

Dear Luca and all,
In RFC4447, each PW endpoint have the capability of being configurable 
with a parameter that specifies whether the use of the control word is 
PREFERRED or NOT PREFERRED. This kind of mechanism will not work in one 
use case:
PE1-----------PE2
1. Initially, PE1 CW is PREFERRED, and PE2 CW is NOT PREFERRED.
2. The negotiation result of PW CW is not supported, and PE1 send label 
mapping with CW=0 finally.
3. Then PE2 changes its CW configuration to PREFERRED.
4. According to the CW negotiation mechanism, the received label mapping 
from PE1 signals CW=0, then PE2 still send label mapping with CW=0.
5. The negotiation result of PW CW is still not supported, but the CW 
configuration on both PE1 and PE2 is PREFERRED.
 
Did I miss something important in this RFC? I can not work out this puzzle 
for the above use case.

What's worse, it seems difficult to solve this problem for SS-PW and MS-PW 
based on current CW negotiation mechanism, unless we change the CW to be 
not configurable, and default value is PREFERRED which can be degraded to 
NOT PREFERRED by negotiation automatically.

BR
Lizhong

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: Alexander Vainshtein <[email-masked]>
Date: Tue, 20 Jul 2010 13:20:23 +0300

Lizhong and all,
AFAIK, C-bit is part of the PW FEC element (both PW ID FEC (128) and Generalized PE FEC (129)).
As a consequence, changing local preference for CW at one of the end points results, first of all, in tear-down of the previous PW. After that new PW will be set up  using new set of CW preferences.

Does this address your problem?

Regards,
     Sasha

From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, July 20, 2010 12:02 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [PWE3] Control Word Problem in RFC4447

Dear Luca and all,
In RFC4447, each PW endpoint have the capability of being configurable with a parameter that specifies whether the use of the control word is PREFERRED or NOT PREFERRED. This kind of mechanism will not work in one use case:
PE1-----------PE2
1. Initially, PE1 CW is PREFERRED, and PE2 CW is NOT PREFERRED.
2. The negotiation result of PW CW is not supported, and PE1 send label mapping with CW=0 finally.
3. Then PE2 changes its CW configuration to PREFERRED.
4. According to the CW negotiation mechanism, the received label mapping from PE1 signals CW=0, then PE2 still send label mapping with CW=0.
5. The negotiation result of PW CW is still not supported, but the CW configuration on both PE1 and PE2 is PREFERRED.

Did I miss something important in this RFC? I can not work out this puzzle for the above use case.

What's worse, it seems difficult to solve this problem for SS-PW and MS-PW based on current CW negotiation mechanism, unless we change the CW to be not configurable, and default value is PREFERRED which can be degraded to NOT PREFERRED by negotiation automatically.

BR
Lizhong

---

From: [email-masked]
Date: Tue, 20 Jul 2010 18:49:16 +0800

Hi Sasha,
Yes, the previous PW will be tear-down which is caused by PE2 sending 
withdraw of PW. But PE1 will not withdraw the PW label in this case, and 
PE2 will retain the label advertised by PE1. This is because PW setup 
mechanism uses liberal label retention mode.
PE2 will negotiate the CW according to the previous CW (=0) advertised by 
PE1. Then PE2 will send label mapping with CW=0.

BR
Lizhong

Alexander Vainshtein <[email-masked]> wrote on 
2010-07-20 18:20:23:

> As a consequence, changing local preference for CW at one of the end
> points results, first of all, in tear-down of the previous PW. After
> that new PW will be set up  using new set of CW preferences.
> 
> In RFC4447, each PW endpoint have the capability of being 
> configurable with a parameter that specifies whether the use of the 
> control word is PREFERRED or NOT PREFERRED. This kind of mechanism 
> will not work in one use case: 
> PE1-----------PE2 
> 4. According to the CW negotiation mechanism, the received label 
> mapping from PE1 signals CW=0, then PE2 still send label mapping with 
CW=0. 
> 5. The negotiation result of PW CW is still not supported, but the 
> CW configuration on both PE1 and PE2 is PREFERRED. 
> 
> What's worse, it seems difficult to solve this problem for SS-PW and
> MS-PW based on current CW negotiation mechanism, unless we change 
> the CW to be not configurable, and default value is PREFERRED which 
> can be degraded to NOT PREFERRED by negotiation automatically. 
> 
> BR 
> Lizhong
> 
> ZTE Information Security Notice: The information contained in this 
> mail is solely property of the sender's organization. This mail 
> communication is confidential. Recipients named above are obligated 
> to maintain secrecy and are not permitted to disclose the contents 
> of this communication to others.
> This email and any files transmitted with it are confidential and 
> intended solely for the use of the individual or entity to whom they
> are addressed. If you have received this email in error please 
> notify the originator of the message. Any views expressed in this 
> message are those of the individual sender.

---

From: [email-masked]
Date: Tue, 20 Jul 2010 18:49:16 +0800

Hi Sasha,

BR
Lizhong

CW=0.

---

From: Alexander Vainshtein <[email-masked]>
Date: Tue, 20 Jul 2010 13:20:23 +0300

Lizhong and all,

Regards,
     Sasha

Dear Luca and all,

BR
Lizhong