Subject: [PWE3] Fwd: New Version Notification for draft-chen-mpls-ipv6-pw-lsp-ping-01.txt

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Mon, 19 Sep 2011 08:25:24 +0530

PWE3ers,

FYI, as this I-D targets the MPLS WG for a home but is relevant to PWE3 as it defines LSP Ping IPv6 PW target FEC types. 

Please send your comments to the MPLS list.

Thanks!

Thumb typed by Carlos Pignataro.
Excuze typofraphicak errows

Begin forwarded message:

> From: Mach Chen <[email-masked]>
> Date: September 19, 2011 6:58:48 AM GMT+05:30
> To: "[email-masked]" <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
> Subject: RE: New Version Notification for draft-chen-mpls-ipv6-pw-lsp-ping-01.txt
> 

> Hi,
> 
> We submitted a new draft that updates RFC4379 to explicitly constraint the existing PW FEC sub-TLVs for IPv4 LDP sessions, and extends Pseudowire LSP Ping (by defining two new LSP Ping sub-TLVs for IPv6 Pseudowire FECs) to the IPv6 scenario where an IPv6 LDP session is used to signal the Pseudowire (i.e., where the Sender's and Receiver's IP addresses are IPv6 addresses.) 
> 
> We'd appreciate that you could spend some time to read the draft (http://tools.ietf.org/html/draft-chen-mpls-ipv6-pw-lsp-ping-01 ) and give your comments!
> 
> Thanks,
> Mach
> 
> ----Original Message-----
>> From: [email-masked] [mailto:[email-masked]]
>> Sent: Wednesday, August 17, 2011 11:08 AM
>> To: Mach Chen
>> Cc: [email-masked]; [email-masked]; Mach Chen; [email-masked]
>> Subject: New Version Notification for draft-chen-mpls-ipv6-pw-lsp-ping-01.txt
>> 
>> A new version of I-D, draft-chen-mpls-ipv6-pw-lsp-ping-01.txt has been
>> successfully submitted by Mach(Guoyi) Chen and posted to the IETF repository.
>> 
>> Filename:     draft-chen-mpls-ipv6-pw-lsp-ping
>> Revision:     01
>> Title:         Label Switched Path (LSP) Ping for IPv6 Pseudowire FECs
>> Creation date:     2011-08-16
>> WG ID:         Individual Submission
>> Number of pages: 9
>> 
>> Abstract:
>>   Multi-Protocol Label Switching (MPLS) Label Switched Path (LSP) Ping
>>   and Traceroute mechanisms are commonly used to detect and isolate
>>   data plane failures in all MPLS LSPs including Pseudowire (PW) LSPs.
>>   The PW LSP Ping and Traceroute elements, however, are not specified
>>   for IPv6 address usage.
>> 
>>   Specifically, the Pseudowire FEC sub-TLVs for the Target FEC Stack in
>>   the LSP Ping and Traceroute mechanism are implicitly defined only for
>>   IPv4 Provider Edge (PEs) routers, and are not applicable for the case
>>   where PEs use IPv6 addresses.  There is, additionally, a degree of
>>   potential ambiguity in the specification of these sub-TLVs since the
>>   address family is not explicitly specified but it is to be inferred
>>   from the sub-TLV length.
>> 
>>   This document updates RFC4379 to explicitly constraint these existing
>>   PW FEC sub-TLVs for IPv4 LDP sessions, and extends Pseudowire LSP
>>   Ping to the IPv6 scenario where an IPv6 LDP session is used to signal
>>   the Pseudowire (i.e., where the Sender's and Receiver's IP addresses
>>   are IPv6 addresses.)  This is done by defining two new LSP Ping sub-
>>   TLVs for IPv6 Pseudowire FECs.
>> 
>> 
>> 
>> 
>> 
>> The IETF Secretariat
>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 19 Sep 2011 11:20:32 +0800

Carlos,

Thanks for the notice to the PWE3 list. Just speaking for myself, this
looks like a very useful draft.

Cheers,
Andy

On Mon, Sep 19, 2011 at 10:55 AM, Carlos Pignataro (cpignata)
<[email-masked]> wrote:
> PWE3ers,
> FYI, as this I-D targets the MPLS WG for a home but is relevant to PWE3 as
> it defines LSP Ping IPv6 PW target FEC types.
> Cc: "[email-masked]" <[email-masked]>, "[email-masked]"
> <[email-masked]>, "[email-masked]" <[email-masked]>
> We submitted a new draft that updates RFC4379 to explicitly constraint the
> existing PW FEC sub-TLVs for IPv4 LDP sessions, and extends Pseudowire LSP
> Ping (by defining two new LSP Ping sub-TLVs for IPv6 Pseudowire FECs) to the
> IPv6 scenario where an IPv6 LDP session is used to signal the Pseudowire
> (i.e., where the Sender's and Receiver's IP addresses are IPv6 addresses.)
>
> We'd appreciate that you could spend some time to read the draft
> (http://tools.ietf.org/html/draft-chen-mpls-ipv6-pw-lsp-ping-01 ) and give
> your comments!
>
> Thanks,
> Mach
>
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pwe3
>
>