Subject: [PWE3] Errata 1864 on RFC5601

From: Stewart Bryant <[email-masked]>
Date: Tue, 13 Sep 2011 20:00:31 +0100

Authors

Please can you recommend a resolution for the following errata

http://www.rfc-editor.org/errata_search.php?eid=1864

Thanks

Stewart

---

From: Stewart Bryant <[email-masked]>
Date: Tue, 13 Sep 2011 21:35:11 +0100

Authors

Please can I also have your recommended resolution on

http://www.rfc-editor.org/errata_search.php?eid=1866 and
http://www.rfc-editor.org/errata_search.php?eid=1871

Thanks

Stewart

---

From: Stewart Bryant <[email-masked]>
Date: Tue, 13 Sep 2011 21:41:23 +0100

Thanks to Adrian for taking a look at the Errata for RFC5601
(Pseudowire (PW) Management Information Base (MIB)) and
proposing resolutions. There are as you can see quite
a few we need to deal with.

This is a two week last call to the WG to verify that the
proposed changes are accurate and acceptable.

Unless I hear to the contrary I will dispose of
the following errata as shown below on or after
28th September 2011.

- Stewart

http://www.rfc-editor.org/errata_search.php?eid=2815
Editorial
Recommend - Verify

http://www.rfc-editor.org/errata_search.php?eid=1868
Editorial
Recommend - Hold for document update

http://www.rfc-editor.org/errata_search.php?eid=1869
Editorial
Recommend - Hold for document update

http://www.rfc-editor.org/errata_search.php?eid=1857
Editorial
Recommend - Hold for document update

http://www.rfc-editor.org/errata_search.php?eid=1853
Technical
This is a trivial error
Recommend
- Change to Editorial
- Hold for document update

http://www.rfc-editor.org/errata_search.php?eid=1855
Technical
Correct, but unlikely to cause any problems
Recommend
- Change to Editorial
- Hold for document update

http://www.rfc-editor.org/errata_search.php?eid=1856
Technical
This is correct.
It is unlikely that "unknown" is ever used in an implementation.
Therefore it is not critical to fix this.
Recommend:
- Fix typo in revised text s/lenght/length/
- Add note that this is a real problem and the correct fix
- Hold for document update

http://www.rfc-editor.org/errata_search.php?eid=1852
Technical
Although technically correct that the SYNTAX should be TimeStamp, this
is safe because the SYNTAX of TimeStamp is TimeTicks.
Recommend:
- Change to Editorial
- Add text above as a note
- Hold for document update.

http://www.rfc-editor.org/errata_search.php?eid=1859
Technical
Recommend:
- Change to Editorial
- Change text to
          "The local configuration of Frame Check Sequence (FCS)
           retention for this PW.  FCS retention can be configured for
           PW types High-Level Data Link Control (HDLC), Point-to-Point
           Protocol (PPP), and Ethernet only.  If this object is set to
           fcsRetentionEnable(2) and the implementation does not support
           the FCS retention for this PW, an error MUST be indicated by
           setting pwFcsRetentionStatus to localFcsRetentionCfgErr(4).
           This object can be changed only if the PW is not active."
- Verify

http://www.rfc-editor.org/errata_search.php?eid=1860
Technical
The original text looks clear and correct.
Recommend:
- Reject

http://www.rfc-editor.org/errata_search.php?eid=1861
Technical
Recommend:
- Change to Editorial
- Fix text to read
           "An entry in this table is created by the agent for every
            monitored interval for each monitored PW."
- Verify

http://www.rfc-editor.org/errata_search.php?eid=1862
Technical
Recommend:
- Change to Editorial
- Fix text to read
           "An entry in this table is created by the agent for every
            monitored day for each monitored PW."
- Additionally, in pwPerf1DayIntervalTable
      DESCRIPTION
           "This table provides per-PW performance information for
            the current day's measurement and the previous day's
            interval."
   s/day's interval/days' measurements/
- Verify

http://www.rfc-editor.org/errata_search.php?eid=1863
Technical
Recommend
- Change to Editorial
- Hold for document update

http://www.rfc-editor.org/errata_search.php?eid=1865 and
http://www.rfc-editor.org/errata_search.php?eid=1867
Recommend
- Change to Editorial
- Hold for document update

- Stewart