Subject: [PWE3] VCCV2

From: Yaakov Stein <[email-masked]>
Date: Wed, 1 Aug 2012 17:23:40 +0000

Hi all

I would like to bring to the list the questions Tom and I raised yesterday.

1)      Should we do a short (and quick turnaround) draft just on the CC types (obsoleting type 2 and introducing type 4) ?

2)      If so, should we merge VCCV2 with VCCV-2 ?

The alternative is a long draft that documents all of VCCV.

Y(J)S

---

From: Gregory Mirsky <[email-masked]>
Date: Wed, 1 Aug 2012 14:17:16 -0400

Dear Yaakov, Tom, et al.,
I'd support RFC 5085bis rather than formal obsolecence of PW VCCV Control Channel Type 2 and introduction of new Type 4.

    Regards,
        Greg
________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Yaakov Stein
Sent: Wednesday, August 01, 2012 10:24 AM
To: pwe3 ([email-masked])
Subject: [PWE3] VCCV2

Hi all

Y(J)S

---

From: Yaakov Stein <[email-masked]>
Date: Wed, 1 Aug 2012 18:19:13 +0000

Greg

Thanks for the opinion on content.
But for the meantime I was asking a question about document format.

Y(J)S

From: Gregory Mirsky [mailto:[email-masked]]
Sent: Wednesday, August 01, 2012 21:17
To: Yaakov Stein; pwe3 ([email-masked])
Subject: RE: VCCV2

    Regards,
        Greg

Y(J)S

---

From: Thomas Nadeau <[email-masked]>
Date: Wed, 1 Aug 2012 11:21:31 -0700

that is two (related) Issues. I think we were first asking about doc structure

tom

On Aug 1, 2012, at 11:17 AM, Gregory Mirsky <[email-masked]> wrote:

> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pwe3

---

From: Gregory Mirsky <[email-masked]>
Date: Wed, 1 Aug 2012 14:21:54 -0400

Yaakov,
let me re-phrase.
I'm for the long draft that documents all of VCCVs.

    Regards,
        Greg

________________________________
From: Yaakov Stein [mailto:[email-masked]]
Sent: Wednesday, August 01, 2012 11:19 AM
To: Gregory Mirsky; pwe3 ([email-masked])
Subject: RE: VCCV2

Greg

Y(J)S

    Regards,
        Greg

Y(J)S

---

From: David Allan I <[email-masked]>
Date: Wed, 1 Aug 2012 14:24:32 -0400

I agree, I've never been happy with the original document, and there is enough updated material that a revision IMO is in order.

cheers
Dave

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Gregory Mirsky
Sent: Wednesday, August 01, 2012 11:22 AM
To: Yaakov Stein; pwe3 ([email-masked])
Subject: Re: [PWE3] VCCV2

Yaakov,
let me re-phrase.

    Regards,
        Greg

Greg

Y(J)S

    Regards,
        Greg

Y(J)S

---

From: Alexander Vainshtein <[email-masked]>
Date: Wed, 1 Aug 2012 19:40:00 +0000

+1.

I would like to see an Applicability section in the "long draft" that would list pros and cons of each method.

My 2c,

     Sasha

________________________________
From: [email-masked] [[email-masked]] on behalf of David Allan I [[email-masked]]
Sent: Wednesday, August 01, 2012 8:24 PM
To: Gregory Mirsky; Yaakov Stein; pwe3 ([email-masked])
Subject: Re: [PWE3] VCCV2

cheers
Dave

Yaakov,
let me re-phrase.

    Regards,
        Greg

Greg

Y(J)S

    Regards,
        Greg

Y(J)S

This e-mail message is intended for the recipient only and contains information which is CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this transmission in error, please inform us by e-mail, phone or fax, and then delete the original and all copies thereof.

---

From: Mach Chen <[email-masked]>
Date: Wed, 1 Aug 2012 20:50:09 +0000

+1

Best regards,
Mach
Sent: Thursday, August 02, 2012 2:24

cheers
Dave

Yaakov,
let me re-phrase.

    Regards,
        Greg

Greg

Y(J)S

    Regards,
        Greg

Y(J)S

---

From: Yaakov Stein <[email-masked]>
Date: Sun, 26 Aug 2012 12:00:20 +0000

PWE chairs,

At the meeting Tom and I asked whether the WG wanted a quick update document,
or whether a full rewrite of all the VCCV RFCs was desired.

Stewart suggested that we first do a quick update and thereafter a "tutorial".

To a quick poll at the meeting there was (in the words of the minutes) an underwhelming response.
My own email to the list elicited only three responses.

Could you ask for people to express their opinions ?
(A - quick doc   B - full doc   C - A and then possibly B later on)

(I guess we have heard from Stewart in favor of C, and Greg M, Dave A, and Mach C in favor of B.
 I personally like C too.).

Y(J)S

---

From: "Andrew G. Malis" <[email-masked]>
Date: Sun, 26 Aug 2012 18:32:19 +0100

Working group,

Could you please respond to Yaakov's email, stating your preference?
We'll keep this open for the following week and make a choice next
weekend.

Thanks,
Andy

On Sun, Aug 26, 2012 at 1:00 PM, Yaakov Stein <[email-masked]> wrote:
> (A – quick doc   B – full doc   C – A and then possibly B later on)
>
>
>

---

From: Mahesh Jethanandani <[email-masked]>
Date: Sun, 26 Aug 2012 22:20:38 -0700

What would a quick update cover?

>  I personally like C too.).

Mahesh Jethanandani
[email-masked]

---

From: Alexander Vainshtein <[email-masked]>
Date: Mon, 27 Aug 2012 07:06:24 +0000

Andy, Yaakov and all,
I've already stated my preference for a full document (Option B) in my message to the list dated August 1 (http://www.ietf.org/mail-archive/web/pwe3/current/msg13209.html). I repeat it just in case (mainly because Yaakov did not mention it in his mail).

Regards,
     Sasha

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Andrew G. Malis
> Sent: Sunday, August 26, 2012 8:32 PM
> To: Yaakov Stein
> Cc: pwe3 ([email-masked]); [email-masked]

---

From: "Shah, Himanshu" <[email-masked]>
Date: Mon, 27 Aug 2012 10:01:09 -0400

I prefer Option B - full doc.

The full doc should cover in initial sections;  problem scope (with legacy RFCs), 
issues at hand and overview of the solution proposed.
This should suffice, instead of covering the same information in various documents.

Thanks,
himanshu

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Alexander Vainshtein
Sent: Monday, August 27, 2012 3:06 AM
To: Andrew G. Malis; Yaakov Stein
Cc: pwe3 ([email-masked])
Subject: Re: [PWE3] VCCV2

Andy, Yaakov and all,

Regards,
     Sasha

---

From: Gregory Mirsky <[email-masked]>
Date: Mon, 27 Aug 2012 12:59:17 -0400

Dear Andy, et al.,
I would like to confirm my earlier expressed support for 5085bis/Option B.

	Regards,
		Greg 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Andrew G. Malis
Sent: Sunday, August 26, 2012 10:32 AM
To: Yaakov Stein
Cc: pwe3 ([email-masked]); [email-masked]
Subject: Re: [PWE3] VCCV2

Working group,

Could you please respond to Yaakov's email, stating your preference?
We'll keep this open for the following week and make a choice next weekend.

Thanks,
Andy

---

From: Thomas Nadeau <[email-masked]>
Date: Mon, 27 Aug 2012 11:41:00 -0400

Take a look at the slides from the meeting as they detail this, but in summary we would eliminate the router alert option. This reduces things down to 2 true modes of operation, and we could also attach some language that clarifies how and when to use both. 

	The more comprehensive approach would consolidate all of the existing RFCs/drafts including MPLS-TP. This would normatively redefine all CC Types, would define type 2 as obsolete, type 1 as mandatory for CW, type 4 as mandatory for non-CW, and a variation of type 3 (manipulating TTL) as for multi-segment only

	--Tom

---

From: Thomas Nadeau <[email-masked]>
Date: Mon, 27 Aug 2012 10:59:37 -0700

--Tom

---

From: "Shahram Davari" <[email-masked]>
Date: Mon, 27 Aug 2012 18:02:34 +0000

Hi Yaakov,

I prefer C, since people are developing products and C is the fastest way to guide the industry.

Thanks
Shahram

From: [email-masked] [mailto:[email-masked]] On Behalf Of Yaakov Stein
Sent: Sunday, August 26, 2012 5:00 AM
To: [email-masked]
Cc: pwe3 ([email-masked])
Subject: Re: [PWE3] VCCV2

PWE chairs,

Y(J)S

---

From: Alexander Vainshtein <[email-masked]>
Date: Mon, 27 Aug 2012 18:14:22 +0000

Tom, and all,
IMHO and FWIW slides do not replace drafts and (eventually) RFCs.

As for making Type 4 mandatory for non-CW: I think that relegating Type 3 to MS-PW while declaring Type 4 as mandatory is highly problematic because it would mean retrofitting. 

My 2c,
     Sasha

________________________________________
From: [email-masked] [[email-masked]] on behalf of Thomas Nadeau [[email-masked]]
Sent: Monday, August 27, 2012 5:41 PM
To: Mahesh Jethanandani
Cc: Yaakov Stein; pwe3 ([email-masked]); [email-masked]
Subject: Re: [PWE3] VCCV2

        --Tom

---

From: Sam Aldrin <[email-masked]>
Date: Mon, 27 Aug 2012 11:16:04 -0700

I agree with Shahram and prefer option 'C' as well.
Detailed document can come later, but having a clear outline/summary of the options and their usage will help implementations, more importantly, removes the confusion.

Cheers
Sam

Sent from my iPad