Subject: [PWE3] Regarding Cisco's Statement of IPR Related to draft-ietf-pwe3-iccp-09

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 25 Oct 2012 11:34:56 -0400

To the PWE3 WG and the authors of draft-ietf-pwe3-iccp:

PWE3 participants may have noticed the IPR announcement below.  This leads
to two important questions:

1. The two authors of the IPR were also co-authors on the original
draft-martini-pwe3-iccp, and the patent application was filed almost
simultaneously with the publication of the original -00 version of the
draft. This leads to the difficult question of why this IPR wasn't
disclosed until now, more than four years after the initial filing and
almost three years from the public publication of the filing.  The chairs
would like the authors to respond to the lateness of the filing, given the
many announcements of the IETF's IPR policy, notably in the draft
boilerplate and in the Note Well, and elsewhere as well.

2. The chairs would also like to ask the working group if anyone has an
opinion about how or whether to continue the current WG draft given the
disclosure of the IPR and the license terms that have been published.

Thanks,
Andy and Matthew

---------- Forwarded message ----------
From: IETF Secretariat <[email-masked]>
Date: Tue, Oct 23, 2012 at 4:23 PM
Subject: [PWE3] IPR Disclosure: Cisco's Statement of IPR Related to
draft-ietf-pwe3-iccp-09
To: [email-masked], [email-masked], [email-masked],
[email-masked]
Cc: [email-masked], [email-masked], [email-masked],
[email-masked]

Dear Ali Sajassi, Luca Martini, Samer Salam, Satoru Matsushima:

 An IPR disclosure that pertains to your Internet-Draft entitled
"Inter-Chassis
Communication Protocol for L2VPN PE Redundancy" (draft-ietf-pwe3-iccp) was
submitted to the IETF Secretariat on 2012-10-23 and has been posted on the
"IETF
Page of Intellectual Property Rights Disclosures"
(https://datatracker.ietf.org/ipr/1898/). The title of the IPR disclosure is
"Cisco's Statement of IPR Related to draft-ietf-pwe3-iccp-09."");

The IETF Secretariat

_______________________________________________
pwe3 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pwe3

---

From: "Samer Salam (ssalam)" <[email-masked]>
Date: Thu, 25 Oct 2012 16:50:11 +0000

Hi Andy,

First and foremost we apologize for the late filing, it was an oversight on our part. While there is no excuse for the tardiness, we wish to assure the WG that no foul play was intended. Re-examining the evolution of the document, the procedures related to the IPR were added to the draft in a later version ( draft-ietf-pwe3-iccp-03 to be precise) and not as part of the initial draft, and this is our best guess as to why we missed filing the IPR disclosure earlier, and it only came to our attention when we were updating version –09 of the draft, since the patent was allowed in that same timeframe.

That said, we wish to clarify that the use of the IPR is not mandatory in the draft. It is an optional procedure for a specific error scenario. Furthermore, the terms of the IPR are no different from any other filed by Cisco under 'reasonable non-discriminatory terms'.

Regards,
Samer

From: "Andrew G. Malis" <[email-masked]<mailto:[email-masked]>>
Date: Thursday, October 25, 2012 8:34 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "Stewart Bryant (stbryant)" <[email-masked]<mailto:[email-masked]>>
Subject: [PWE3] Regarding Cisco's Statement of IPR Related to draft-ietf-pwe3-iccp-09

PWE3 participants may have noticed the IPR announcement below.  This leads to two important questions:

1. The two authors of the IPR were also co-authors on the original draft-martini-pwe3-iccp, and the patent application was filed almost simultaneously with the publication of the original -00 version of the draft. This leads to the difficult question of why this IPR wasn't disclosed until now, more than four years after the initial filing and almost three years from the public publication of the filing.  The chairs would like the authors to respond to the lateness of the filing, given the many announcements of the IETF's IPR policy, notably in the draft boilerplate and in the Note Well, and elsewhere as well.

2. The chairs would also like to ask the working group if anyone has an opinion about how or whether to continue the current WG draft given the disclosure of the IPR and the license terms that have been published.

Thanks,
Andy and Matthew

---------- Forwarded message ----------
From: IETF Secretariat <[email-masked]<mailto:[email-masked]>>
Date: Tue, Oct 23, 2012 at 4:23 PM
Subject: [PWE3] IPR Disclosure: Cisco's Statement of IPR Related to draft-ietf-pwe3-iccp-09
To: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>

 An IPR disclosure that pertains to your Internet-Draft entitled "Inter-Chassis
Communication Protocol for L2VPN PE Redundancy" (draft-ietf-pwe3-iccp) was
submitted to the IETF Secretariat on 2012-10-23 and has been posted on the "IETF
Page of Intellectual Property Rights Disclosures"
(https://datatracker.ietf.org/ipr/1898/). The title of the IPR disclosure is
"Cisco's Statement of IPR Related to draft-ietf-pwe3-iccp-09."");

The IETF Secretariat

_______________________________________________
pwe3 mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/pwe3

---

From: "Adrian Farrel" <[email-masked]>
Date: Sat, 27 Oct 2012 14:59:36 +0100

Hi,
 
Samer said:
 
> the use of the IPR is not mandatory in the draft. It is an optional procedure
for a specific error scenario.
 
That makes me wonder whether the WG would like to consider another way of
handling this specific error scenario, or even simply to remove the optional
procedure.
 
What do people think?
 
Thanks,
Adrian
 
From: [email-masked] [mailto:[email-masked]] On Behalf Of Samer
Salam (ssalam)
Sent: 25 October 2012 17:50
To: Andrew G. Malis; [email-masked]; [email-masked]
Cc: Stewart Bryant (stbryant)
Subject: Re: [PWE3] Regarding Cisco's Statement of IPR Related to
draft-ietf-pwe3-iccp-09
 
Hi Andy,
 
First and foremost we apologize for the late filing, it was an oversight on our
part. While there is no excuse for the tardiness, we wish to assure the WG that
no foul play was intended. Re-examining the evolution of the document, the
procedures related to the IPR were added to the draft in a later version (
draft-ietf-pwe3-iccp-03 to be precise) and not as part of the initial draft, and
this is our best guess as to why we missed filing the IPR disclosure earlier,
and it only came to our attention when we were updating version -09 of the
draft, since the patent was allowed in that same timeframe.
 
That said, we wish to clarify that the use of the IPR is not mandatory in the
draft. It is an optional procedure for a specific error scenario. Furthermore,
the terms of the IPR are no different from any other filed by Cisco under
'reasonable non-discriminatory terms'. 
 
Regards,
Samer
 
From: "Andrew G. Malis" <[email-masked]>
Date: Thursday, October 25, 2012 8:34 AM
To: "[email-masked]" <[email-masked]>, "[email-masked]"
<[email-masked]>
Cc: "Stewart Bryant (stbryant)" <[email-masked]>
Subject: [PWE3] Regarding Cisco's Statement of IPR Related to
draft-ietf-pwe3-iccp-09

PWE3 participants may have noticed the IPR announcement below.  This leads to
two important questions:

1. The two authors of the IPR were also co-authors on the original
draft-martini-pwe3-iccp, and the patent application was filed almost
simultaneously with the publication of the original -00 version of the draft.
This leads to the difficult question of why this IPR wasn't disclosed until now,
more than four years after the initial filing and almost three years from the
public publication of the filing.  The chairs would like the authors to respond
to the lateness of the filing, given the many announcements of the IETF's IPR
policy, notably in the draft boilerplate and in the Note Well, and elsewhere as
well.

2. The chairs would also like to ask the working group if anyone has an opinion
about how or whether to continue the current WG draft given the disclosure of
the IPR and the license terms that have been published.

Thanks,
Andy and Matthew
---------- Forwarded message ----------
From: IETF Secretariat <[email-masked]>
Date: Tue, Oct 23, 2012 at 4:23 PM
Subject: [PWE3] IPR Disclosure: Cisco's Statement of IPR Related to
draft-ietf-pwe3-iccp-09

The IETF Secretariat

---

From: Thomas Nadeau <[email-masked]>
Date: Sat, 27 Oct 2012 12:39:12 -0400

speaking as a co-author but one without the ipr claims, i am ok with the document as is given the standard licensing terms.

Tom 

On Oct 27, 2012, at 9:59 AM, "Adrian Farrel" <[email-masked]> wrote:

> Hi,
>  
> Samer said:
>  
> > the use of the IPR is not mandatory in the draft. It is an optional procedure for a specific error scenario.
>  
> That makes me wonder whether the WG would like to consider another way of handling this specific error scenario, or even simply to remove the optional procedure.
>  
> What do people think?
>  
> Thanks,
> Adrian
>  
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Samer Salam (ssalam)
> Subject: Re: [PWE3] Regarding Cisco's Statement of IPR Related to draft-ietf-pwe3-iccp-09
>  
> Hi Andy,
>  
> To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
> To: [email-masked], [email-masked], [email-masked], [email-masked]
> Cc: [email-masked], [email-masked], [email-masked], [email-masked]
>

---

From: Yaakov Stein <[email-masked]>
Date: Wed, 31 Oct 2012 08:06:15 +0000

Adrian,

I support removal of the procedure.

Timely disclosure is required if IPR is "essential" for an implementation to be compliant with an RFC.

Even if the procedure is optional, if it is written up in the RFC it is part of the IETF's definition
of the behavior, and thus when parties choose to implement that option the IPR becomes essential.
This is not the case of IPR being one way of implementing a described procedure.

I think that the IPR holders should support removal of the procedure as well,
as their lack of disclosure could lead to a patent (if granted) being ruled unenforceable.

Y(J)S

From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Saturday, October 27, 2012 16:00
To: 'Samer Salam (ssalam)'; 'Andrew G. Malis'; [email-masked]; [email-masked]
Cc: 'Stewart Bryant (stbryant)'
Subject: Re: [PWE3] Regarding Cisco's Statement of IPR Related to draft-ietf-pwe3-iccp-09

Hi,

What do people think?

Thanks,
Adrian

Hi Andy,

First and foremost we apologize for the late filing, it was an oversight on our part. While there is no excuse for the tardiness, we wish to assure the WG that no foul play was intended. Re-examining the evolution of the document, the procedures related to the IPR were added to the draft in a later version ( draft-ietf-pwe3-iccp-03 to be precise) and not as part of the initial draft, and this is our best guess as to why we missed filing the IPR disclosure earlier, and it only came to our attention when we were updating version -09 of the draft, since the patent was allowed in that same timeframe.

Regards,
Samer

Thanks,
Andy and Matthew
---------- Forwarded message ----------
From: IETF Secretariat <[email-masked]<mailto:[email-masked]>>
Date: Tue, Oct 23, 2012 at 4:23 PM
Subject: [PWE3] IPR Disclosure: Cisco's Statement of IPR Related to draft-ietf-pwe3-iccp-09
To: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>

The IETF Secretariat

---

From: "Samer Salam (ssalam)" <[email-masked]>
Date: Wed, 31 Oct 2012 15:42:55 +0000

Hi,

To further clarify: two ways of implementing the described procedure were identified in the course of the discussions, one without the IPR and one with. The current draft only captures the latter because it offers better reversion time characteristics (note that failover protection time is comparable for both, it is primarily the reversion time upon recovery that is different). With the approval of the other co-authors, we would be happy to:

1- Either Capture only the option without the IPR, OR
2- Capture both options with the above tradeoff highlighted

Regards,
Samer

From: Yaakov Stein <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, October 31, 2012 1:06 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "'Andrew G. Malis'" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "Stewart Bryant (stbryant)" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [PWE3] Regarding Cisco's Statement of IPR Related to draft-ietf-pwe3-iccp-09
Resent-From: <[email-masked]<mailto:[email-masked]>>
Resent-To: <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>
Resent-Date: Wednesday, October 31, 2012 1:06 AM

Adrian,

Y(J)S

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Saturday, October 27, 2012 16:00
To: 'Samer Salam (ssalam)'; 'Andrew G. Malis'; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: 'Stewart Bryant (stbryant)'
Subject: Re: [PWE3] Regarding Cisco's Statement of IPR Related to draft-ietf-pwe3-iccp-09

Hi,

What do people think?

Thanks,
Adrian

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Samer Salam (ssalam)
Sent: 25 October 2012 17:50
To: Andrew G. Malis; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: Stewart Bryant (stbryant)
Subject: Re: [PWE3] Regarding Cisco's Statement of IPR Related to draft-ietf-pwe3-iccp-09

Hi Andy,

Regards,
Samer

Thanks,
Andy and Matthew
---------- Forwarded message ----------
From: IETF Secretariat <[email-masked]<mailto:[email-masked]>>
Date: Tue, Oct 23, 2012 at 4:23 PM
Subject: [PWE3] IPR Disclosure: Cisco's Statement of IPR Related to draft-ietf-pwe3-iccp-09
To: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>

The IETF Secretariat