Subject: [PWE3] New draft - Efficient Multiplexing of ISDN User-Network Interfaces over TDM Pseudo-wires

From: Javi Muñoz <[email-masked]>
Date: Fri, 11 Jan 2013 14:23:27 +0100

Hi experts in PWE3 WG,
I just submitted a new draft "Efficient Multiplexing of ISDN 
User-Network Interfaces over TDM Pseudo-wires".
In this document, we propose a mechanism to efficiently multiplex a 
numberof ISDN interfaces over a single TDMPW. This mechanism would allow 
a single Access Gateway to remotely terminate a high number of distant 
local loops.
This draft can be accessed by the following link:

http://tools.ietf.org/html/draft-munozcalle-pwe3-multiplexing-isdn-interfaces-00 
<http://tools.ietf.org/html/draft-jiang-l2vpn-vpls-pe-etree-00>

Your comments and suggestions are greatly appreciated.
Best regards

Javi

---

From: Giles Heron <[email-masked]>
Date: Fri, 11 Jan 2013 17:40:51 +0000

Hi Javi,

your link below doesn't work.  It links to https://tools.ietf.org/html/draft-jiang-l2vpn-vpls-pe-etree-00 instead of to http://tools.ietf.org/html/draft-munozcalle-pwe3-multiplexing-isdn-interfaces-00.

oh the dangers of HTML-formatted email ;)

with respect to the draft itself do you have a real use-case or is the draft more of an intellectual exercise?  For example, given that we're in 2013 and bandwidth is generally pretty cheap, the benefit of using AAL2 to carry in-use channels only would seem to be minimal unless you are leasing TDM circuits to reach the remote gateway (in which case a TDM-based solution might be simpler than TDM over packet over TDM).

Giles

On 11 Jan 2013, at 13:23, Javi Muñoz <[email-masked]> wrote:

> Hi experts in PWE3 WG,
>  
> I just submitted a new draft "Efficient Multiplexing of ISDN User-Network Interfaces over TDM Pseudo-wires".
>  
> In this document, we propose a mechanism to efficiently multiplex a number of ISDN interfaces over a single TDMPW. This mechanism would allow a single Access Gateway to remotely terminate a high number of distant local loops.
>  
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pwe3

---

From: Yaakov Stein <[email-masked]>
Date: Sat, 12 Jan 2013 17:26:37 +0000

Giles,

I agree that a lot of the rationale behind pulling individual channels out of TDM to save the silence time has gone away.

However, I can think of a few use cases for AAL2 (and I am interested in hearing what Javi has to say).

The obvious case is satellite links. Here BW is still expensive, but it may be the only way to get to out-of-the-way places.

The other is the case of many ISDN channels on a link towards a network where they will be converted to VoIP flows.
Here the overhead of sending each VoIP flow together on the link may be prohibitive.
There are other solutions to this problem (e.g., RFC 4170), but using AAL2 may be a practical way of solving this problem.

Y(J)S

From: [email-masked] [mailto:[email-masked]] On Behalf Of Giles Heron
Sent: Friday, January 11, 2013 19:41
To: Javi Muñoz
Cc: [email-masked]
Subject: Re: [PWE3] New draft - Efficient Multiplexing of ISDN User-Network Interfaces over TDM Pseudo-wires

Hi Javi,

Giles

On 11 Jan 2013, at 13:23, Javi Muñoz <[email-masked]<mailto:[email-masked]>> wrote:

Hi experts in PWE3 WG,

http://tools.ietf.org/html/draft-munozcalle-pwe3-multiplexing-isdn-interfaces-00<http://tools.ietf.org/html/draft-jiang-l2vpn-vpls-pe-etree-00>
Your comments and suggestions are greatly appreciated.

Best regards

Javi
_______________________________________________
pwe3 mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/pwe3

---

From: Javi Muñoz <[email-masked]>
Date: Tue, 15 Jan 2013 20:18:21 +0100

Yaakov, Giles

The draft contains two key ideas: transporting only the in-use
channels, and using AAL2 to convey them as an efficient solution.

On the uses of the AAL2, I can think of these two:

- The emulation of ISDN bearer services in NGN, including
   multi-channel services. Obviously, the NGN requires TDM (ISDN)
   over packet.

- The substitution of several access gateways (AGWs) by a single,
   aggregated, AGW node. Traffic from many ISDN UNIs will be
   multiplexed over a single TDMPW.

Regarding the elimination of idle channels, I completely agree with
Yaakov in that the satellite scenario is a nice example. Generally
speaking I foresee three advantages when removing the idle channels
in the second use case above:

- Lower bandwidth requirements.
- Lower number TDMPWs, hence less management and signaling burden.
- Less traffic reaching the resulting concentrated AGW, reducing the
   "hot traffic spots" in the AGW surroundings

Whilst the two last advantages may be harder to quantify, I could
sketch some figures for the first one.

For instance lets consider an alternative provider which gets
5.000 ISDN customers from the 50.000 ones served by the
incumbent's central office (10% market share).
That makes 10000 B-channels. Let's
assume that the alternative provider rents a link from the
incumbent to carry the aggregated channels.

If every channel were transported, it would require the
equivalent of some 5 E4 links.

If only busy channels were transported, assuming 30mE per
channel and a blocking probability of 2%, we would need only the
equivalent of 324 channels (some 21 Mb/s).

When translated to cost, in Spain the wholesale price for a 100
Mb/s Ethernet link is about 1.000 Eur/month [1]. Prices for E4
links are higher, but we may assume the same figures per Mb/s.
This means about 7000 Eur/month per the 5xE4 link set and some 210
Eur/month for the busy-channels-only solution, which is saving some
1.3 Eur per customer per month. Modest as it may seem, the cost
will scale up quickly when increasing the installed base.  For
instance, if the incumbent were Telefonica and the alternative were
Jazztel (6.2% share instead of 10% above [2]), which has one
million customers, the savings may rise up to 9 MEur. per year.  Of
course, prices, market shares and ISDN popularity in other
countries may change.
  
[1] Prices fromhttp://es.wikitel.info/wiki/ORLA_en_Espa%C3%B1a
[2] Data fromhttp://www.cmt.es, market shares as of November 2010

Javi.

PD: Giles, thank you for your warning on the wrong link!

El 12/01/2013 18:26, Yaakov Stein escribió:
>
> Giles,
>
> I agree that a lot of the rationale behind pulling individual channels 
> out of TDM to save the silence time has gone away.
>
> The obvious case is satellite links. Here BW is still expensive, but 
> it may be the only way to get to out-of-the-way places.
>
> The other is the case of many ISDN channels on a link towards a 
> network where they will be converted to VoIP flows.
>
> There are other solutions to this problem (e.g., RFC 4170), but using 
> AAL2 may be a practical way of solving this problem.
>
> Y(J)S
>
> *From:[email-masked] [mailto:[email-masked]] *On Behalf 
> Of *Giles Heron
> *Sent:* Friday, January 11, 2013 19:41
> *To:* Javi Muñoz
> *Cc:* [email-masked]
> *Subject:* Re: [PWE3] New draft - Efficient Multiplexing of ISDN 
> User-Network Interfaces over TDM Pseudo-wires
>
> Hi Javi,
>
> your link below doesn't work.  It links to 
> https://tools.ietf.org/html/draft-jiang-l2vpn-vpls-pe-etree-00 instead 
> of to 
> http://tools.ietf.org/html/draft-munozcalle-pwe3-multiplexing-isdn-interfaces-00.
>
> with respect to the draft itself do you have a real use-case or is the 
> draft more of an intellectual exercise?  For example, given that we're 
> in 2013 and bandwidth is generally pretty cheap, the benefit of using 
> AAL2 to carry in-use channels only would seem to be minimal unless you 
> are leasing TDM circuits to reach the remote gateway (in which case a 
> TDM-based solution might be simpler than TDM over packet over TDM).
>
> Giles
>
> number of ISDN interfaces over a single TDMPW. This mechanism would 
> allow a single Access Gateway to remotely terminate a high number of 
> distant local loops.
>
> [email-masked] <mailto:[email-masked]>

---

From: Javi Muñoz <[email-masked]>
Date: Thu, 17 Jan 2013 18:13:47 +0100

Yaakov, Giles

Javi.