Subject: [PWE3] Fwd: "Running code" draft

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 10 Jan 2013 09:31:31 -0500

PWE3 WG,

There is a draft (see the forwarded message below) that proposes
adding an optional "Implementation Status" section to IETF WG drafts.
This section would be for the use of the WG during draft development
and the IESG during draft review, and would be removed prior to RFC
publication.

Matthew and I have two requests for WG participants:

1. Please read the draft, and if you have any comments, please send
the comments to the [email-masked] email list (or just privately to the
authors if you prefer).

2. Please consider adding this section to existing or proposed WG
drafts as you write them or update them. This is optional only, but
keep in mind that before Matthew and I can forward drafts to the IESG
for publication, this is information that we need to collect anyway
for the Shepherd's write-up to the IESG, so including it in the draft
makes submission to the IESG just a bit easier and quicker.

Thanks much,
Andy and Matthew

---------- Forwarded message ----------
From: Yaron Sheffer <[email-masked]>
Date: Wed, Jan 9, 2013 at 2:22 PM
Subject: "Running code" draft
To: WG Chairs <[email-masked]>

Hi,

Adrian and I published a draft [1] before the holidays that suggests
to include an Implementation Status section in I-Ds, where any extant
(even partial) implementations of the specification are described. The
goal is to increase working group members' confidence in the maturity
level of the spec, to motivate people to implement drafts before
publication, and several other lesser benefits.

We would like to encourage people on this list to include
Implementation Status sections in working group drafts (this is no
process change: anybody can include ANY additional sections in
drafts). We would appreciate comments on this proposal from this list,
and would be even happier to hear reports of your experience
implementing this idea in your WG.

Thanks,
    Yaron

[1] http://tools.ietf.org/html/draft-sheffer-running-code-01

---

From: Alexander Vainshtein <[email-masked]>
Date: Thu, 10 Jan 2013 14:47:22 +0000

Andy hi!

Once upon a time the IETF Routing Area had a rule stating that you need a running implementation before your draft can be published as a Standards Track RFC. 

I am not sure whether the PWE3 WG has been moved to Routing Area from Transport Area before or after this rule has been relaxed; but the running code" draft looks like an attempt to bring back these good old times...

Regards,
     Sasha

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Andrew G. Malis
> Sent: Thursday, January 10, 2013 4:32 PM
> To: [email-masked]
> Subject: [PWE3] Fwd: "Running code" draft
> 
> PWE3 WG,
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pwe3

This e-mail message is intended for the recipient only and contains information which is CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this transmission in error, please inform us by e-mail, phone or fax, and then delete the original and all copies thereof.

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 10 Jan 2013 10:06:44 -0500

Sasha,

As I recall, that rule went back to the days when the routing area was
really just working on the core routing protocols - OSPF, ISIS, BGP, etc.
They really did want to see evidence of running (and working!) code before
making changes to the routing protocol specs.

Cheers,
Andy

On Thu, Jan 10, 2013 at 9:47 AM, Alexander Vainshtein <
[email-masked]> wrote:

> Andy hi!
>
> Once upon a time the IETF Routing Area had a rule stating that you need a
> running implementation before your draft can be published as a Standards
> Track RFC.
>
> I am not sure whether the PWE3 WG has been moved to Routing Area from
> Transport Area before or after this rule has been relaxed; but the running
> code" draft looks like an attempt to bring back these good old times...
>
> Regards,
>      Sasha
>
> This e-mail message is intended for the recipient only and contains
> information which is CONFIDENTIAL and which may be proprietary to ECI
> Telecom. If you have received this transmission in error, please inform us
> by e-mail, phone or fax, and then delete the original and all copies
> thereof.
>

---

From: Alexander Vainshtein <[email-masked]>
Date: Thu, 10 Jan 2013 15:51:27 +0000

Andy,
Lots of thanks for a prompt response.

I definitely defer to you regarding the "root cause" of introducing such a rule: I have not been there then.
However I think that the root cause notwithstanding, the rule had many positive side effects that the "running code" draft tries to bring back in a weaker form.

Regards,
     Sasha

From: [email-masked] [mailto:[email-masked]] On Behalf Of Andrew G. Malis
Sent: Thursday, January 10, 2013 5:07 PM
To: Alexander Vainshtein
Cc: [email-masked]; Stewart Bryant ([email-masked])
Subject: Re: [PWE3] Fwd: "Running code" draft

Sasha,

As I recall, that rule went back to the days when the routing area was really just working on the core routing protocols - OSPF, ISIS, BGP, etc. They really did want to see evidence of running (and working!) code before making changes to the routing protocol specs.

Cheers,
Andy

On Thu, Jan 10, 2013 at 9:47 AM, Alexander Vainshtein <[email-masked]<mailto:[email-masked]>> wrote:
Andy hi!

Regards,
     Sasha

> From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf
> Of Andrew G. Malis
> To: [email-masked]<mailto:[email-masked]>
> the comments to the [email-masked]<mailto:[email-masked]> email list (or just privately to the
> authors if you prefer).
>
> From: Yaron Sheffer <[email-masked]<mailto:[email-masked]>>
> To: WG Chairs <[email-masked]<mailto:[email-masked]>>
>
> Hi,
>
> [email-masked]<mailto:[email-masked]>

_______________________________________________
pwe3 mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/pwe3