Subject: [PWE3] Retiring ACH TLVs

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 7 May 2013 18:08:34 +0100

Hi,

ACH TLVs keep popping up and causing Stewart and me trouble. Mainly it is about explaining why no-one actually wants to use them (i.e., when each new ACH Type is defined and has a "No TLVs" written for it, we get asked "why not?").

It seems to us that ACH TLVs are an idea that has been rejected. Initially we thought they might be used (especially for identifiers), but there seems to be good opinion that handling generic TLVs would be a pain.

Since I was heavily responsible for insisting that ACH TLVs were included in RFC 5586, it seems reasonable that I do the work to fix it.

The I-D below retires ACH TLVs and handles the necessary registry changes.

Note, of course, that structured data are still possible within individual ACHs if the protocol spec for an individual ACH decides to have them.

We're directing this work to the MPLS working group because that is where 5586 was written. I have BCC'ed PWE3, L2VPN, and BFD for information. 

Thanks for any comments.

As humble WG contributors we would be enthusiastic to see early WG adoption and last call :-)

Thanks,
Adrian

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: 07 May 2013 17:33
> To: Adrian Farrel; Stewart Bryant
> Subject: New Version Notification for draft-farbryantrel-mpls-retire-ach-tlv-
> 00.txt
> 
> 
> A new version of I-D, draft-farbryantrel-mpls-retire-ach-tlv-00.txt
> has been successfully submitted by Adrian Farrel and posted to the
> IETF repository.
> 
> Filename:	 draft-farbryantrel-mpls-retire-ach-tlv
> Revision:	 00
> Title:		 Retiring TLVs from the Associated Channel Header of the MPLS
> Generic Associated Channel
> Creation date:	 2013-05-07
> Group:		 Individual Submission
> Number of pages: 4
> URL:             http://www.ietf.org/internet-drafts/draft-farbryantrel-mpls-retire-
> ach-tlv-00.txt
> Status:          http://datatracker.ietf.org/doc/draft-farbryantrel-mpls-retire-ach-tlv
> Htmlized:        http://tools.ietf.org/html/draft-farbryantrel-mpls-retire-ach-tlv-00
> 
> 
> Abstract:
>    The MPLS Generic Associated Channel (G-ACh) is a generalization of
>    the applicability of the Pseudowire (PW) Associated Channel Header
>    (ACH).  RFC 5586 defines the concept of Type-Length-Variable (TLV)
>    constructs that can be carried in messages on the G-ACh by placing
>    them in the ACH.
> 
>    No Associated Channel Type yet defined uses a TLV.  Furthermore, it
>    is believed that handling TLVs in hardware introduces significant
>    problems to the fast-path, and since G-ACh messages are intended to
>    be processed substantially in hardware, the use of TLVs in
>    undesirable.
> 
>    This document updates RFC 5586 by retiring ACH TLVs and removing the
>    associated registry.
> 
> 
> 
> 
> The IETF Secretariat

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 8 May 2013 20:13:55 +0200

PWE3ers,

Comments on this draft should be directed to the mpls email list only.
Replying directly to Adrian's email (and not typing in the pwe3 list as
well) should accomplish that goal.

Thanks,
Andy

On Tue, May 7, 2013 at 7:08 PM, Adrian Farrel <[email-masked]> wrote:

> Hi,
>
> ACH TLVs keep popping up and causing Stewart and me trouble. Mainly it is
> about explaining why no-one actually wants to use them (i.e., when each new
> ACH Type is defined and has a "No TLVs" written for it, we get asked "why
> not?").
>
> It seems to us that ACH TLVs are an idea that has been rejected. Initially
> we thought they might be used (especially for identifiers), but there seems
> to be good opinion that handling generic TLVs would be a pain.
>
> Since I was heavily responsible for insisting that ACH TLVs were included
> in RFC 5586, it seems reasonable that I do the work to fix it.
>
> Note, of course, that structured data are still possible within individual
> ACHs if the protocol spec for an individual ACH decides to have them.
>
> We're directing this work to the MPLS working group because that is where
> 5586 was written. I have BCC'ed PWE3, L2VPN, and BFD for information.
>
> Thanks for any comments.
>
> > URL:
> http://www.ietf.org/internet-drafts/draft-farbryantrel-mpls-retire-
> > ach-tlv-00.txt
> > Status:
> http://datatracker.ietf.org/doc/draft-farbryantrel-mpls-retire-ach-tlv
> > Htmlized:
> http://tools.ietf.org/html/draft-farbryantrel-mpls-retire-ach-tlv-00
> >
> >
> > Abstract:
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pwe3
>