Subject: Re: [PWE3] FW: New Version Notification for draft-zhang-l3vpn-label-sharing-00.txt

From: Mingui Zhang <[email-masked]>
Date: Tue, 23 Jul 2013 08:21:14 +0000

Hi Eric,

Please see my response in-line below.

I add the pwe3 mailing list since this document is related to the following draft submitted for pwe3.
ICCP Application TLVs for VPN Route Label Sharing
http://www.ietf.org/internet-drafts/draft-zhang-pwe3-iccp-label-sharing-00.txt

Thanks,
Mingui

>-----Original Message-----
>From: Eric Rosen [mailto:[email-masked]]
>Sent: Monday, July 22, 2013 11:10 PM
>To: Mingui Zhang
>Cc: [email-masked]; [email-masked]
>Subject: Re: FW: New Version Notification for
>draft-zhang-l3vpn-label-sharing-00.txt
>
>
>As far as I can tell, your scheme only handles the case where the two egress
>PEs connect to the exact same set of CEs.  If so, this applicability
>restriction should be clearly stated.
>
>In Figure 2.1, you show CE2 connected to PE3 and PE4.  Now suppose we also
>have CE4 connected to PE3 and PE5.  If PE3 fails, one might want use PE4 as
>a backup for CE2, while using PE5 as a backup for CE4.  Your scheme doesn't
>seem to handle this.

Not exactly.

If PE3 and PE4 allocate (1100, vNH1) for CE2 while PE3 and PE5 allocate (1101, vNH2) for CE4. The scheme works well. This also answers your first question.

>
>Also, even in the case of Figure 2.1, it seems entirely possibly that one
>might want PE3's primary route to CE2 to be via the directly attached
>interface, while wanting PE4's primary route to CE2 to be via PE3.  Does
>your scheme handle this case?

Interesting point. 
Yes, it handles. Please see the right part of eq1: Sxy3+M. If the backup tunnel goes through Pxy->PE4->PE3->vNH, then Sxy3+M < = Sxy4+S. That means eq1 does not hold.

---

From: Eric Rosen <[email-masked]>
Date: Tue, 23 Jul 2013 10:42:21 -0400

Eric> In Figure 2.1, you show CE2 connected to PE3 and PE4.  Now suppose we also
Eric> have CE4 connected to PE3 and PE5.  If PE3 fails, one might want use PE4 as
Eric> a backup for CE2, while using PE5 as a backup for CE4.  Your scheme doesn't
Eric> seem to handle this.

Mingui> If PE3 and PE4 allocate (1100, vNH1) for CE2 while PE3 and PE5
Mingui> allocate (1101, vNH2) for CE4. The scheme works well.

Are you now suggesting to allocate a vNH address and shared label for every
CE?  Since there are many more CEs than PEs, that would make the scaling
properties of the scheme a lot less favorable.

Eric> Also, even in the case of Figure 2.1, it seems entirely possibly that
Eric> one might want PE3's primary route to CE2 to be via the directly
Eric> attached interface, while wanting PE4's primary route to CE2 to be via
Eric> PE3.  Does your scheme handle this case?

Mingui> Yes, it handles. Please see the right part of eq1: Sxy3+M. If the
Mingui> backup tunnel goes through Pxy->PE4->PE3->vNH, then Sxy3+M < =
Mingui> Sxy4+S. That means eq1 does not hold.

I think that equation is based only on the IGP link costs.  A service
provider might use BGP LOCAL_PREF to give the PE3-->CE2 route a higher
degree of preference than the PE4-->CE2 route, in which case PE4's normal
route to CE2 could be via PE3, independent of the IGP link costs.  Of
course, PE4 will switch to the directly attached route when it learns,
through IGP, that PE3 is not reachable.  But in that case you might not meet
the FRR goal.

---

From: Mingui Zhang <[email-masked]>
Date: Wed, 24 Jul 2013 01:50:47 +0000

Hi Eric,

Please see the comments in-line.

Thanks,
Mingui

>Sent: Tuesday, July 23, 2013 10:42 PM
>To: Mingui Zhang
>Cc: [email-masked]; [email-masked]; [email-masked]

That's not true. Please search the following sentence in the draft.
"Egress PEs create a vNH router in IGP to represent the set of CEs dual-homed to the same egress PEs in the Service Provider's backbone."
I don't think this kind of allocation bears scalability issues.

>through IGP, that PE3 is not reachable.  But in that case you might not meet

To achieve the goal of protection, the draft suggested the PEs in the RG use routes that they learn from the CE.
If the service provider insists on using the route from just one PE, he is ready to give up the reliability that can be provided by multiple PEs.