Subject: [PWE3] Poll for WG adoption of draft-shen-pwe3-endpoint-fast-protection-04

From: "Bocci, Matthew (Matthew)" <[email-masked]>
Date: Fri, 30 Aug 2013 14:26:02 +0000

This email begins a two week poll to help the chairs determine if there is consensus to adopt draft-shen-pwe3-endpoint-fast-protection-04 as an PWE3 working group draft.

The draft can be found here:
http://tools.ietf.org/id/draft-shen-pwe3-endpoint-fast-protection-04.txt

Please read the draft and indicate to the list if you support adoption, or if you do not support adoption (giving reasons).

Please note that this is only a call for adoption. There needs to be consensus that this draft is a good basis for the work, but it does not need to be perfect at this stage.

The poll for adoption will close in two weeks time, on Friday 13th September.

Best regards,

Matthew

---

From: "Bocci, Matthew (Matthew)" <[email-masked]>
Date: Fri, 30 Aug 2013 14:33:42 +0000

Coincidentally, we are also polling for knowledge of any IPR that applies to this draft, to ensure that IPR has been disclosed in compliance with IETF IPR rules (see RFCs 3979, 4879, 3669 and 5378 for more details).

If you are listed as a document author or contributor please respond to this email whether or not you are aware of any relevant IPR. The draft will not be adopted until a response has been received from each author and contributor.

If you are on the PWE3 WG email list but are not listed as an author or contributor, then please explicitly respond only if you are aware of any IPR that has not yet been disclosed in conformance with IETF rules.

Matthew

On 30/08/2013 15:26, "Bocci, Matthew (Matthew)" <[email-masked]<mailto:[email-masked]>> wrote:

Best regards,

Matthew

---

From: Sam Aldrin <[email-masked]>
Date: Fri, 30 Aug 2013 11:28:31 -0700

Hi,

I would like to see the  following questions answered before the document
could be adopted.
Here are the reasons why.

1. The scope of the document says End point protection for SS-PW and MS-PW.
But what it is failing to consider is the absence of signaling component. I
do not see how this will work when the PW's are set up statically w/o the
dynamic signaling in both SS-PW and MS-PW?

2. Would also like to see how the protection works, in terms of setup and
working model, where a MS-PW is made of dynamically signaled SS-PW and
statically setup SS-PW stitched to form a MS-PW.

3. By reading sec 5. the way I understood that this is only possible with
control plane being present. If my understanding is incorrect, would like
to see text detailing on how this could be achieved in the absence of
CP(control plane).

4. In case CP is mandatory, I would like to see the document title and
scope to change to reflect the same.

thanks
-sam

On Fri, Aug 30, 2013 at 7:26 AM, Bocci, Matthew (Matthew) <
[email-masked]> wrote:

>  This email begins a two week poll to help the chairs determine if there
> is consensus to adopt draft-shen-pwe3-endpoint-fast-protection-04 as an
> PWE3 working group draft.
>
>  Please read the draft and indicate to the list if you support adoption,
> or if you do not support adoption (giving reasons).
>
>  Please note that this is only a call for adoption. There needs to be
> consensus that this draft is a good basis for the work, but it does not
> need to be perfect at this stage.
>
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pwe3
>
>

---

From: Yimin Shen <[email-masked]>
Date: Sat, 31 Aug 2013 13:40:10 +0000

Sam,

Thanks for your questions. 

This draft assumes LDP-signaled PWs, which is the case in most PWE3 deployment. But we can add some text to also address the scenarios that you mentioned with static PWs or mixture of dynamic + static PWs. In fact, all the procedures in the draft will still apply in this case, except that you won't need the LDP extension in section 5, because you don't have LDP. 

So instead of running LDP between a pair of primary PE and protector, all you need is static configuration on the protector to coordinate it with the primary PE and make sure correct forwarding state is installed, so that the protector can send redirected traffic towards the target CE. The PLR's behavior will be the same as currently specified. In particular, you will need to do the followings on the protector.

- know which primary PEs and primary PWs or PW segments that the protector protects.
- create a context label table for each primary PE.
- install a label route for each protected PW or PW segment in the corresponding context label table. The next hop should be the backup AC (in the case of SS-PW) or a label swap to the label of the next segment of the backup PW (in the case of MS-PW).
- point incoming bypass tunnel(s) to their corresponding context label table, to result in a label look-up in that table.

Then your forwarding state is ready in place. This is applicable to static SS-PWs, static MS-PWs, and static and dynamic MS-PW segment stitching. Essentially, the forwarding state in the data-plane is the ultimate goal of this PW endpoint protection. If your network already has LDP for PW signaling, you can used the LDP extension to coordinate your protector with primary PE. Otherwise, just use static configuration to achieve the same.

Hope this has answered your questions.

Thanks,

-Yimin Shen
Juniper Networks

From: [email-masked] [mailto:[email-masked]] On Behalf Of Sam Aldrin
Sent: Friday, August 30, 2013 2:29 PM
To: Bocci, Matthew (Matthew)
Cc: [email-masked]
Subject: Re: [PWE3] Poll for WG adoption of draft-shen-pwe3-endpoint-fast-protection-04

Hi,
I would like to see the  following questions answered before the document could be adopted.
Here are the reasons why.
1. The scope of the document says End point protection for SS-PW and MS-PW. But what it is failing to consider is the absence of signaling component. I do not see how this will work when the PW's are set up statically w/o the dynamic signaling in both SS-PW and MS-PW?

2. Would also like to see how the protection works, in terms of setup and working model, where a MS-PW is made of dynamically signaled SS-PW and statically setup SS-PW stitched to form a MS-PW.
3. By reading sec 5. the way I understood that this is only possible with control plane being present. If my understanding is incorrect, would like to see text detailing on how this could be achieved in the absence of CP(control plane).
4. In case CP is mandatory, I would like to see the document title and scope to change to reflect the same.
thanks
-sam

On Fri, Aug 30, 2013 at 7:26 AM, Bocci, Matthew (Matthew) <[email-masked]> wrote:
This email begins a two week poll to help the chairs determine if there is consensus to adopt draft-shen-pwe3-endpoint-fast-protection-04 as an PWE3 working group draft.

Best regards,

Matthew