Subject: [PWE3] Poll for WG adoption and IPR check of draft-zhang-pwe3-iccp-stp-00

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 4 Dec 2013 15:53:02 -0500

This email begins a two week poll to help the chairs determine if
there is consensus to adopt draft-zhang-pwe3-iccp-stp-00 as an PWE3
working group draft.

The draft can be found here:
http://tools.ietf.org/html/draft-zhang-pwe3-iccp-stp-00

Please read the draft and indicate to the list if you support
adoption, or if you do not support adoption (giving reasons).

Please note that this is only a call for adoption. There needs to be
consensus that this draft is a good basis for the work, but it does
not need to be perfect at this stage.

Coincidentally, we are also polling for knowledge of any IPR that
applies to this draft, to ensure that IPR has been disclosed in
compliance with IETF IPR rules (see RFCs 3979, 4879, 3669 and 5378 for
more details).

If you are listed as a document author or contributor please respond
to this email whether or not you are aware of any relevant IPR. The
draft will not be adopted until a response has been received from each
author and contributor.

If you are on the PWE3 WG email list but are not listed as an author
or contributor, then please explicitly respond regarding IPR only if
you are aware of any IPR that has not yet been disclosed in
conformance with IETF rules.

The poll for adoption will close in two weeks time, on Wednesday 18th December.

Best regards,
Andy

---

From: Gregory Mirsky <[email-masked]>
Date: Wed, 4 Dec 2013 21:59:11 +0000

Hi,
I think that the proposal would benefit from stronger description of use case(s) that it intended to address. At this time, the topology presented in Fig.2.1 can be supported with what already is defined in draft-ietf-pwe3-iccp-12. Hence,
no/do not support

	Regards,
		Greg

-----Original Message-----
From: pwe3 [mailto:[email-masked]] On Behalf Of Andrew G. Malis
Sent: Wednesday, December 04, 2013 12:53 PM
To: [email-masked]
Subject: [PWE3] Poll for WG adoption and IPR check of draft-zhang-pwe3-iccp-stp-00

This email begins a two week poll to help the chairs determine if there is consensus to adopt draft-zhang-pwe3-iccp-stp-00 as an PWE3 working group draft.

Please read the draft and indicate to the list if you support adoption, or if you do not support adoption (giving reasons).

Please note that this is only a call for adoption. There needs to be consensus that this draft is a good basis for the work, but it does not need to be perfect at this stage.

Coincidentally, we are also polling for knowledge of any IPR that applies to this draft, to ensure that IPR has been disclosed in compliance with IETF IPR rules (see RFCs 3979, 4879, 3669 and 5378 for more details).

If you are listed as a document author or contributor please respond to this email whether or not you are aware of any relevant IPR. The draft will not be adopted until a response has been received from each author and contributor.

If you are on the PWE3 WG email list but are not listed as an author or contributor, then please explicitly respond regarding IPR only if you are aware of any IPR that has not yet been disclosed in conformance with IETF rules.

Best regards,
Andy
_______________________________________________
pwe3 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pwe3

---

From: Mingui Zhang <[email-masked]>
Date: Thu, 5 Dec 2013 02:26:13 +0000

I am not aware of any IPR in this draft.

Thanks,
Mingui

>Sent: Thursday, December 05, 2013 4:53 AM
>To: [email-masked]
>This email begins a two week poll to help the chairs determine if there is
>consensus to adopt draft-zhang-pwe3-iccp-stp-00 as an PWE3 working group
>draft.
>
>Please note that this is only a call for adoption. There needs to be consensus
>that this draft is a good basis for the work, but it does not need to be perfect at
>this stage.
>
>Coincidentally, we are also polling for knowledge of any IPR that applies to this
>draft, to ensure that IPR has been disclosed in compliance with IETF IPR rules
>(see RFCs 3979, 4879, 3669 and 5378 for more details).
>
>If you are listed as a document author or contributor please respond to this
>email whether or not you are aware of any relevant IPR. The draft will not be
>adopted until a response has been received from each author and contributor.
>
>If you are on the PWE3 WG email list but are not listed as an author or
>contributor, then please explicitly respond regarding IPR only if you are aware of
>any IPR that has not yet been disclosed in conformance with IETF rules.
>

---

From: Wenhuafeng <[email-masked]>
Date: Thu, 5 Dec 2013 04:01:08 +0000

I am not aware of any IPR that is relevant to this draft.

Thanks,
Huafeng 

________________________________________
发件人: pwe3 [[email-masked]] 代表 Andrew G. Malis [[email-masked]]
发送时间: 2013年12月5日 4:53
收件人: [email-masked]
主题: [PWE3] Poll for WG adoption and IPR check of        draft-zhang-pwe3-iccp-stp-00

Best regards,
Andy

---

From: Mingui Zhang <[email-masked]>
Date: Fri, 6 Dec 2013 00:45:46 +0000

Hi Greg,

Thanks for attention. This solution is designed for the use case that geo-dispersed DSLAMs running STP need enhance the reliability of the connections between the entire STP network and the carrier network.

Want to address several key points here: 1. These DSLAMs are running STP. 2. These DSLAMs are not geo-close to each other. Multiple DSLAMs are connected to the carrier network at different locations. 3. When one connection to the carrier network fails, customers wish a connection in another location can continue to work after the re-convergence of the STP rather than compromising the whole STP network. The failure of the connection may be due to the failure of the PE, the AC or even the CE (a DSLAM) itself. 4. Customers want to balance the load among those connections, therefore all these connections need be active. 

Please note that the draft is not proposed to replace anything. I agree with you that the application "can be supported". That's why we want to introduce the proposal into the ICCP draft as an _additional_ application. Currently, there are two applications in the ICCP draft, PW-RED and mLACP. These two applications are not applicable to above use case to meet the requirements of customers. 

If I misunderstood anything, please correct me.

--
Mingui

>From: pwe3 [mailto:[email-masked]] On Behalf Of Gregory Mirsky
>Sent: Thursday, December 05, 2013 5:59 AM
>To: Andrew G. Malis; [email-masked]
>Subject: Re: [PWE3] Poll for WG adoption and IPR check of
>draft-zhang-pwe3-iccp-stp-00
>
>Hi,
>I think that the proposal would benefit from stronger description of use case(s)
>that it intended to address. At this time, the topology presented in Fig.2.1 can
>be supported with what already is defined in draft-ietf-pwe3-iccp-12. Hence,
>no/do not support
>
>	Regards,
>		Greg
>

---

From: Wenhuafeng <[email-masked]>
Date: Fri, 6 Dec 2013 10:02:57 +0000

The use case is valid. 
Support for adoption as a coauthor.

Regards,
Huafeng 

________________________________________
发件人: pwe3 [[email-masked]] 代表 Mingui Zhang [[email-masked]]
发送时间: 2013年12月6日 8:45
收件人: Gregory Mirsky; Andrew G. Malis; [email-masked]
主题: Re: [PWE3] Poll for WG adoption and IPR     check   of      draft-zhang-pwe3-iccp-stp-00

Hi Greg,

--
Mingui

---

From: Yaakov Stein <[email-masked]>
Date: Mon, 9 Dec 2013 10:51:32 +0000

I do not support adoption,
partly because I don't think PWE3 should be taking on any new work,
and partly because I don't think the use case is sufficiently interesting.

Y(J)S

-----Original Message-----
From: pwe3 [mailto:[email-masked]] On Behalf Of Andrew G. Malis
Sent: 04 December, 2013 22:53
To: [email-masked]
Subject: [PWE3] Poll for WG adoption and IPR check of draft-zhang-pwe3-iccp-stp-00

Best regards,
Andy

---

From: Mingui Zhang <[email-masked]>
Date: Wed, 11 Dec 2013 07:18:28 +0000

Hi Yaakov, 

Thanks for the comment!

As I know from vendor implementers, 'ring' topology is widely used by customers in their DSLAM networks. It's common for such a network to have multiple attach points to an SP's L2VPN network... For such kind of connections, there are various private solutions to meet customers' requirements. That's why we designed this standard proposal for customers.

I find implementers are interested in such proposal, from which I see a chance to bring implementations to the existing pwe3 draft. 

Not to debate. Just to add some info.

Regards,
Mingui

>From: pwe3 [mailto:[email-masked]] On Behalf Of Yaakov Stein
>Sent: Monday, December 09, 2013 6:52 PM
>partly because I don't think PWE3 should be taking on any new work, and partly
>because I don't think the use case is sufficiently interesting.
>
>Y(J)S
>
>

---

From: Wenhuafeng <[email-masked]>
Date: Wed, 11 Dec 2013 07:56:05 +0000

Support as an implementer :)

Huafeng

-----邮件原件-----
发件人: pwe3 [mailto:[email-masked]] 代表 Mingui Zhang
发送时间: 2013年12月11日 15:18
收件人: Yaakov Stein; Andrew G. Malis; [email-masked]
主题: Re: [PWE3] Poll for WG adoption and IPR check of draft-zhang-pwe3-iccp-stp-00

Hi Yaakov, 

Thanks for the comment!

Regards,
Mingui

>partly because I don't think PWE3 should be taking on any new work, and 
>partly because I don't think the use case is sufficiently interesting.
>
>Y(J)S
>
>
>This email begins a two week poll to help the chairs determine if there 
>is consensus to adopt draft-zhang-pwe3-iccp-stp-00 as an PWE3 working 
>group draft.
>
>Please read the draft and indicate to the list if you support adoption, 
>or if you do not support adoption (giving reasons).
>
>consensus that this draft is a good basis for the work, but it does not 
>need to be perfect at this stage.
>
>compliance with IETF IPR rules (see RFCs 3979, 4879, 3669 and 5378 for more details).
>
>If you are listed as a document author or contributor please respond to 
>this email whether or not you are aware of any relevant IPR. The draft 
>will not be adopted until a response has been received from each author and contributor.
>
>contributor, then please explicitly respond regarding IPR only if you 
>are aware of any IPR that has not yet been disclosed in conformance with IETF rules.
>

---

From: Gregory Mirsky <[email-masked]>
Date: Thu, 12 Dec 2013 07:05:25 +0000

Hi Mingui,
thank you for the extensive explanation. Have to admit, that I still am not convinced that the Fig.2.1 and the description make strong case for new protocol extension. I think that there are other possibilities, e.g. tunnel BPDUs over PW and use RFC 7023 for MPLS and Ethernet OAM interworking. Do you think that will work?

	Regards,
		Greg

-----Original Message-----
From: Mingui Zhang [mailto:[email-masked]] 
Sent: Thursday, December 05, 2013 4:46 PM
To: Gregory Mirsky; Andrew G. Malis; [email-masked]
Subject: RE: [PWE3] Poll for WG adoption and IPR check of draft-zhang-pwe3-iccp-stp-00

Hi Greg,

--
Mingui

>I think that the proposal would benefit from stronger description of 
>use case(s) that it intended to address. At this time, the topology 
>presented in Fig.2.1 can be supported with what already is defined in 
>draft-ietf-pwe3-iccp-12. Hence, no/do not support
>
>	Regards,
>		Greg
>

---

From: [email-masked]
Date: Fri, 13 Dec 2013 10:29:56 +0800

Support the adoption.

Thanks,
Hongjun Zhai
---------------------------------------------
Add: No.68 Zijinghua Road, Yuhuatai District,
Nanjing City, R.P. China, 210012

Tel: +86 025 52877345
Email: [email-masked]
---------------------------------------------

"Andrew G. Malis" <[email-masked]> 
发件人:  "pwe3" <[email-masked]>
2013-12-05 04:53

收件人
"[email-masked]" <[email-masked]>
抄送

主题
[PWE3] Poll for WG adoption and IPR check of draft-zhang-pwe3-iccp-stp-00

The poll for adoption will close in two weeks time, on Wednesday 18th 
December.

Best regards,
Andy

---

From: Mingui Zhang <[email-masked]>
Date: Fri, 13 Dec 2013 08:59:19 +0000

Hi Greg,

Let me give an analysis of the "BPDU tunneling over PW+RFC7023 model". The following figure is used.

              +--------------+       +=============+
              |              |       |             |
              |              |       |             |
              |       +---+  |       |  +-----+    |
              |   +---+CE1+<6>-------<5>+ PE1 |    |
              |  <1>  +---+  |       |  +-----+    |
              | +-+-+        |       |     ||      |
              | |CE3|        |       |     ||tunnel|
              | +-+-+        |       |     ||      |
              |  <2>  +---+  |       |  +-----+    |
              |   +---+CE2+<3>-------<4>+ PE2 |    |
              |       +---+  |       |  +-----+    |
              |              |       |             |
              | Multi-homed  |       |             |
              | STP Network  |       |             |
              +--------------+       +=============+

In this model, the ports connected to the STP network at the PEs' side are non-bridge ports (e.g., port <4>, <5>). The tunnel between PE1 and PE2 is a transparent tunnel of BPDUs. For CE1 and CE2, they regard that there is a direct link between them.

[Issue1] Assume port <1> was blocked according to the STP calculation. Now, link CE3-CE2 fails, port <2> is blocked while port <1> is unblocked. Since the BPDUs is just tunneled, PE2 is unaware of this change. It may continue to send traffic to CE3 via CE2 where a black-hole happens. 

In order to handle this issue, PEs have to snoop the TC message of the STP network so the tunnel is not "transparent" to BPDUs anymore. When the Topology Change event is sensed, these PEs should withdraw MAC addresses of those instances affected by the TC event across the L2VPN network.

[Issue2] When port <4> fails, CE1 is unaware. Suppose CE2 is the root bridge, port <6> has to wait for 3 STP HELLO Intervals (3*2s) and 2 Forwarding Delays (2*15s). The STP network takes at least 36 seconds to complete the convergence. The convergence process of the STP network is greatly slowed down. This actually changes the behavior of customers' STP networks!

In order to speed up the convergence, CE1 has to sense the state of the link between CE2 and PE2. The interworking PEs and CEs have to cope with various combinations of failures. There is no standard solution yet.

[Issue3] As I know, RFC7023 is scoped to only single segment PWs. When the STP network is attached to more than two PEs, I guess a full mesh PWs have to be set up. Not clear yet what behaviors these PEs should have.

Jump to an upper level, in the "ICCP-STP" model, PEs "participate" the STP calculation, therefore we need not design the complex interworking mechanism.

Thanks,
Mingui

>From: Gregory Mirsky [mailto:[email-masked]]
>Sent: Thursday, December 12, 2013 3:05 PM
>To: Mingui Zhang; Andrew G. Malis; [email-masked]
>thank you for the extensive explanation. Have to admit, that I still am not
>convinced that the Fig.2.1 and the description make strong case for new
>protocol extension. I think that there are other possibilities, e.g. tunnel BPDUs
>over PW and use RFC 7023 for MPLS and Ethernet OAM interworking. Do you
>think that will work?
>
>	Regards,
>		Greg
>
>Thanks for attention. This solution is designed for the use case that
>geo-dispersed DSLAMs running STP need enhance the reliability of the
>connections between the entire STP network and the carrier network.
>
>Want to address several key points here: 1. These DSLAMs are running STP. 2.
>These DSLAMs are not geo-close to each other. Multiple DSLAMs are connected
>to the carrier network at different locations. 3. When one connection to the
>carrier network fails, customers wish a connection in another location can
>continue to work after the re-convergence of the STP rather than compromising
>the whole STP network. The failure of the connection may be due to the failure of
>the PE, the AC or even the CE (a DSLAM) itself. 4. Customers want to balance
>the load among those connections, therefore all these connections need be
>active.
>
>Please note that the draft is not proposed to replace anything. I agree with you
>that the application "can be supported". That's why we want to introduce the
>proposal into the ICCP draft as an _additional_ application. Currently, there are
>two applications in the ICCP draft, PW-RED and mLACP. These two applications
>are not applicable to above use case to meet the requirements of customers.
>

---

From: Jiangyuanlong <[email-masked]>
Date: Tue, 17 Dec 2013 02:37:03 +0000

Support adoption.

Regards,
Yuanlong

-----Original Message-----
From: pwe3 [mailto:[email-masked]] On Behalf Of Andrew G. Malis
Sent: Thursday, December 05, 2013 4:53 AM
To: [email-masked]
Subject: [PWE3] Poll for WG adoption and IPR check of draft-zhang-pwe3-iccp-stp-00

Best regards,
Andy

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 19 Dec 2013 12:04:28 -0500

This ends the adoption poll for draft-zhang-pwe3-iccp-stp-00. There
was a good discussion, and resulting changes to be included in an
update of the draft in order to reflect rough consensus. The authors
are going to produce draft-zhang-pwe3-iccp-stp-01 to incorporate the
discussion, and following that they will just change the name to then
produce draft-ietf-pwe3-iccp-stp-00.

Cheers,
Andy