Subject: RE: [PWE3] AD Review of draft-ietf-pwe3-cw-03.txt

From: "Yaakov Stein" <[email-masked]>
Date: Tue, 12 Apr 2005 13:43:56 +0200

> >           If a non-zero length field is received, the PW payload
MUST 
> >           be trimmed if required. 
> 
> What is meant by "if required" - To me, this either MUST be 
> trimmed or not (no need to suggest an implementation loophole 
> if none should exist).

How about this ?
  If a non-zero length field is received, the PW payload MUST 
  be trimmed if the actual packet length is larger than that indicated.

<snip> 
> That's two I caught, there must be more. Please run the doc 
> through a spell checker.

The question is how to set the spelling checker 
when we have Danny and Stewart as co-chairs.
Should it be set to American spelling
(signaling, synchronize)
or British
(signalling, sycnhronise) ?
But in either case syncronise would be flagged.

Y(J)S

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Yaakov Stein" <[email-masked]>
Date: Thu, 21 Apr 2005 17:06:37 +0200

> > Sequence number (Bit 16 to 31): 
> > 
> >           The sequence number specifies the sequence number of a
packet
> >           Usage of the sequence number field is OPTIONAL or
MANDATORY 
> >           depending on the emulated service. For services for which 
> >           usage of the sequence number is MANDATORY, the sequence
> >           number cycles over all values. For services for which
usage
> >           of the sequence number is OPTIONAL it MUST be set to zero
> >           by the sender and ignored by the receiver if not used.  
> >           Otherwise it MUST cycle from 1 to 65535 (2**16-1). The 
> >           sequence number window size for packet acceptance is
dependent
> >           on the parameters of both the PW and 
> >           the MPLS PSN, and SHOULD be configurable. The mechanism
used 
> >           by the decapsulating PE to syncronise the expected
sequence 
> >           number with the received sequence number is implementation

> >           dependent.   
> 
> I would be happy to include this. This is what has been 
> implemented far. Including the text would save four drafts 
> including exception text explaining why they used the 
> complete sequence space.
> 

Stewart, 

Not only does this capture what HAS been implemented,
it captures WHY that is the case (simply those cases
where the SN is mandatory do not need to keep SN=0
as a special case).

I fully support this type of wording, but think it is a bit
to complex.

The following is a bit simpler (at least to me):

          The sequence number implements the sequencing function [ARCH].
          For some emulated services usage of the sequence number field
is OPTIONAL 
          while for others it is MANDATORY. For services for which 
          usage is MANDATORY, the sequence number cycles over all values

          from 0 to 65535 (2**16-1).
          For services for which usage is OPTIONAL, when the sequence
number 
          is used it cycles from 1 to 65535 (2**16-1), and a zero value
          indicates that it is not used.
          The size of the window used for packet acceptance is dependent
          on the parameters of both the PW and the MPLS PSN, and 
          SHOULD be configurable. The mechanism used by a receiver
          to synchronise the expected and received sequence numbers 
          is implementation dependent.   

Y(J)S