Subject: RE: [PWE3] Generic vs Preferred CW

From: Sasha Vainshtein <[email-masked]>
Date: Mon, 25 Apr 2005 15:25:10 +0200

Stewart and all,
I believe that this issue has been raised many, many times on this list, 
but still...

Please note that while all the TDM (SAToP, CESoPSN, TDMoIP and now CEP) 
encapsulations comply with the format of the preferred CW, they
all use the sequence number field in a way that differs from the way 
it is used in the rest of the encasulations: 

- there is no option NOT to support sequencing 
- the value 0 is not diferent from any other value of the
  sequence number and is not skiped on wrap-around
- the sequence number in the first packet of the PW
  is set to a random number.

One of the non-historic reasons for this diffference is that
TDM PWs use sequence numbers not just to detect misordered and,
possibly lost packets, but also to compensate for each lost packet
and, where possible, to re-order mis-ordered packets. All this
must be done in the data path of the TDM PWs and becomes simpler 
if the circular sequence number space without any gaps is used.

Today the logic of setting and processing the sequence number is defined
in the service-specific drafts, and I do not see any reason why it
should not remain so. (In the case of multi-hop/multi-segment PWs
this logic shall, hopefully, be limited to U-PEs which are
service-specific.)

The bottom line:

I do not see any problem with enforcing the format of the preferred CW 
(i.e. Option "b") provided that specification of the usage of the sequence 
number field should be left to service-specific drafts.
  
Regards,
                                  Sasha Vainshtein
email:                         [email-masked] <mailto:[email-masked]> 
phone:                       +972-3-7569993 (office)
fax:                            +972-3-6487779
mobile:                      +972-52-8674833 

> -----Original Message-----
> From: Stewart Bryant [mailto:[email-masked]]
> Sent: Monday, April 25, 2005 12:56 PM
> To: pwe3
> Subject: [PWE3] Generic vs Preferred CW
> 
> 
> I am working on -04 of the CW draft that takes into a/c
> the feedback that I have received from the list and
> AD on -03.
> 
> Before I complete this I need to ask the list to
> consider the following proposed text:
> 
> ---------------------------------------------------------------
> 
> 
> 3.   Generic PW MPLS Control Word
> 
>     The Generic PW MPLS Control Word is shown in Figure 1.
> 
> 
>      0                   1                   2                   3
>      0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>     |0 0 0 0|          Specified by PW Encapsulation                |
>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
> 
>           Figure 1: Generic PW MPLS Control Word
> 
> 
>     The PW set-up protocol or configuration mechanism 
> determines whether
>     a PW uses a PW MPLS Control Word (PWMCW). Bits 0..3 
> differ from the
>     first four bits of an IP packet [BCP] and hence provide the
>     necessary MPLS payload discrimination.
> 
>     When a PWMCW is used, it MUST adhere to the Generic MPLS Control
>     Word format as illustrated in Figure 1 above. It SHOULD 
> also follow
>     the following format:
> 
> 
>      0                   1                   2                   3
>      0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>     |0 0 0 0| Flags |FRG|  Length   | Sequence Number               |
>     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
> 
>          Figure 2: PW Preferred MPLS Control Word
> 
>     The meaning of the fields of the PW Preferred MPLS Control Word
>     (Figure 2) is as follows:
> 
> --------------------------------------------------------------------
> 
> With the proposed changes to the CEP draft, the only encaps 
> that do not
> use the preferred CW is ATM 1 to 1 Cell Mode AAL5 PDU Frame Mode.
> 
> We therefore have two choices:
> 
> a) Leave the text above and thereby leave the ambiguity as to how
> important it is to use preferred vs generic CW.
> 
> b) Change the text to say that the encap MUST use the Preferred
> CW, and add exception text to the ATM draft.
> 
> I think that option (b) is better, because it requires
> future encapsulations that do not adhere to the Preferred CW
> to draw attention to the technical reasons why.
> 
> Views?
> 
> - Stewart
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
> 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 25 Apr 2005 14:21:04 +0100

> number field should be left to service-specific drafts.

I was proposing to use the text that Yaakov recently proposed.
I will publish in a seperate thread.

Stewart