Subject: [PWE3] Sequence numbers

From: Stewart Bryant <[email-masked]>
Date: Mon, 25 Apr 2005 14:24:02 +0100

Since Sasha raises it, here is the sequence number text
proposed by Yaakov.

I will wait to see the consenus on the a/b choice and then
publish control word -04 in a day or so.

Stewart

Sequence number (Bit 16 to 31):

           The sequence number implements the sequencing function
           [RFC3985]. For some emulated services usage of the sequence
           number field is OPTIONAL while for others it is MANDATORY.
           For services for which usage is MANDATORY, the sequence
           number cycles over all values from 0 to 65535 (2**16-1).

           For services for which usage is OPTIONAL, when the sequence
           number is used it cycles from 1 to 65535 (2**16-1), and a
           zero value indicates that it is not used.

           The size of the window used for packet acceptance is
           dependent on the parameters of both the PW and the MPLS PSN,
           and SHOULD be configurable. The mechanism used by a receiver
           to synchronize the expected and received sequence numbers
           is implementation dependent.

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Sasha Vainshtein <[email-masked]>
Date: Mon, 25 Apr 2005 18:13:01 +0200

Stewart and all,

Please see some comments inline below.

Regards,
                                  Sasha Vainshtein
email:                         [email-masked] <mailto:[email-masked]> 
phone:                       +972-3-7569993 (office)
fax:                            +972-3-6487779
mobile:                      +972-52-8674833 

> -----Original Message-----
> From: Stewart Bryant [mailto:[email-masked]]
> Sent: Monday, April 25, 2005 4:49 PM
> To: Sasha Vainshtein
> Cc: Yaakov Stein (E-mail); pwe3
> Subject: Re: [PWE3] Sequence numbers
> 
> 
> 
> 
> Sasha Vainshtein wrote:
> 
> > Stewart, Yaakov and all,
> > I am not sure that the binding between MANDATORY/OPTIONAL 
> > sequencing support and skipping zero is a good idea even if
> > it happens to reflect correctly the current state of things.
> > 
> > Please consider the hypothetical use case when, for some reason, 
> > the ATM N-to-one Cell PW encapsulation changes its 
> currently OPTIONAL 
> > sequencing support to MANDATORY (may be not quite a crazy 
> idea because
> > this is the only way to guarantee that ATM PM works properly across
> > these PWs). Such a change would make ALL the 
> implementations - both ones 
> > that did not support sequencing and ones that did - non-compliant
> > because the sequencing method must be now changed in the 
> latter, not just
> > added to the former...
> > 
> > Passing the description of how the sequencing is performed to the 
> > service-specific documents looks much more stable to me.
> 
> Sasha
> 
> It seems unlikely that we will need a third type of sequence number
> design unless we move to a larger number. 
>
[Sasha] I hope so.
>
> It would therefore be a good thing if we could write down in one 
> place the description of the two cases. 
>
[Sasha] Sure - if the mapping between the specific encapsulations
and the common methods can be defined in a stable way. 
Otherwise we can provide the description of the two cases 
(possibly with some hints to their respective pros and cons) 
and leave the definition of the specific mapping in the 
service-specific documents. 
>
> Perhaps we could find a better pair of words
> than OPTIONAL/MANDATORY to describe the two cases.
> Stewart
> 
> > 
> > Regards,
> >                                   Sasha Vainshtein
> > email:                         [email-masked] 
<mailto:[email-masked]> 
> phone:                       +972-3-7569993 (office)
> fax:                            +972-3-6487779
> mobile:                      +972-52-8674833 
> 
> 
> 
>>-----Original Message-----
>>From: Stewart Bryant [mailto:[email-masked]]
>>Sent: Monday, April 25, 2005 3:24 PM
>>To: pwe3
>>Subject: [PWE3] Sequence numbers
>>
>>

---

From: "Yaakov Stein" <[email-masked]>
Date: Tue, 26 Apr 2005 11:20:46 +0200

> it happens to reflect correctly the current state of things.

I repeat my previous comment that the only reason
to skip zero is due to its being used to indicate that
the SN is not being used. So there is a strong binding
between the two.

If you do not see the reason for this binding,
why were you so interested in the TDM encaps
NOT skipping the zero? They could have easily skipped
zero even though the CW was mandatory.

Y(J)S

---

From: Sasha Vainshtein <[email-masked]>
Date: Tue, 26 Apr 2005 12:13:06 +0200

Yaakov,
Of course your reasoning is logically perfect.

The problem is that the decision to make sequencing
support for a specific PW service OPTIONAL or MANDATORY 
in many cases is NOT based on any logic.

Even some TDM encapsulation could do without the CW
sequencing (e.g., for TDMoIP in AAL1 mode the sequencing 
function could be provided by the AAL1 sequence numbers). 

And when you apply a perfect logical rule to a basically 
illogical situation, the results can be quite embarassing.

Regards,
                                  Sasha Vainshtein

> From: Yaakov Stein [mailto:[email-masked]]
> Sent: Tuesday, April 26, 2005 11:21 AM
> To: Sasha Vainshtein; Stewart Bryant
> Cc: pwe3
> Subject: RE: [PWE3] Sequence numbers
> 
> 
>  
> > Stewart, Yaakov and all,