Subject: RE: [PWE3] AD Review of draft-ietf-pwe3-cw-03.txt

From: Sasha Vainshtein <[email-masked]>
Date: Thu, 14 Apr 2005 17:15:00 +0200

Mark (and all),
Thank you for a prompt response.
Please see a few answers inline below.

Regards,
                                  Sasha Vainshtein
email:                         [email-masked] <mailto:[email-masked]> 
phone:                       +972-3-7569993 (office)
fax:                            +972-3-6487779
mobile:                      +972-52-8674833 

> -----Original Message-----
> From: W. Mark Townsley [mailto:[email-masked]]
> Sent: Thursday, April 14, 2005 4:08 PM
> To: Sasha Vainshtein
> Cc: Stewart Bryant; PWE3 WG (E-mail); Danny McPherson; Luca 
> Martini; Ron Cohen (E-mail); Yaakov Stein (E-mail); Andrew G. 
> Malis (E-mail)
> Subject: Re: [PWE3] AD Review of draft-ietf-pwe3-cw-03.txt
> 
> 
> 
> Thanks Sasha... Responses inline..
> 
> Sasha Vainshtein wrote:
> 
> >> >    All IP packets [RFC791][RFC1883] start with a version 
> >> >    number that is
> >> >    checked by LSRs performing MPLS payload inspection. To 
> >> >    prevent the
> >> >    incorrect processing of packets carried within a PW, 
> PW packets
> >> >    carried over an MPLS PSN SHOULD NOT start with the 
> >> >    value 4 (IPv4) or the value 6 (IPv6) in the first 
> nibble [BCP], 
> >> >    as those are assumed to carry normal IP payloads.
> >>
> >>Mark> Why not specify a MUST NOT here?
> >>
> >>Luca> Some of the TDM PWs might start with a 4, as they do 
> not have a
> >>Luca> conformant CW.
> >>So they are non-conformant and it should be duly noted. I 
> >>don't think that just because the TDM specs happen to already 
> >>be in violation we should relax the requirement for all. 
> >>
> > 
> > [Sasha]AFAIK the only PW that still uses a non-comformant CW
> > [Sasha]is CEP (draft-ietf-pwe3-sonet-10.txt), and this document
> > [Sasha]both states the problem and describes a solution.
> > [Sasha](Low-rate) TDM PW encapsulations described in the SAToP
> > [Sasha](draft-ietf-pwe3-satop-01.txt), CESoPSN 
> > [Sasha](draft-ietf-pwe3-cesopsn-02.txt) and TDMoIP 
> > (draft-ietf-pwe3-tdmoip-03.txt) docs all use a conformant CW. 
> > [Sasha]Hence I would say that TDM PWs are NOT in violation and
> > [Sasha]should not be cited as the reason to relax a requirement
> > [Sasha]if such is deemed necessary.
> 
> Then in your mind we can use a MUST NOT here in the CW spec?
>
[Sasha] I do not see any problem with that.  
>
> > 
> > ... snipped
> > 
> >> > 3.   Generic PW MPLS Control Word
> >> >
> >> >    Length (bits 10 to 15):
> >> >           The value of the length field, if non-zero, can 
> >> >           be used to
> >> >           remove any padding added by the PSN. If the 
> entire packet
> >> >           length is less than 64 bytes, the length field 
> >> >           MUST be set to
> >> >           the length of the PW payload plus the length of 
> >> >           the control word. Otherwise it MUST be set to zero.
> >> >
> >> >           If a non-zero length field is received, the PW 
> >> >           payload MUST be trimmed if required.
> >>
> >>Mark> What is meant by "if required" - To me, this either 
> >>MUST be trimmed or
> >>Mark> not (no need to suggest an implementation loophole if 
> >>none should exist).
> >>Mark>
> >>
> >>Luca> no, it means that the payload might already be the 
> >>correct length ,
> >>Luca> hence it might not need to be trimmed....
> >>Luca> Not all short packet have to be padded , some media do 
> >>not require
> >>Luca> padding ....
> >>
> >>So, just to be sure, we are stating that the payload length 
> >>field MUST be set 
> >>for < 64 byte payloads regardless of media type, but there is 
> >>an "if required" 
> >>on the trimming when receiving a non-zero length as some 
> >>media types do not need 
> >>the length field.
> >>
> > 
> > [Sasha] I have commented on this subject already.
> > 
> > [Sasha]Neither this draft nor any service-specific
> > [Sasha]draft explains how to treat the following situations
> > [Sasha](LEN_CW is the value of the Length field and LEN_L2
> > [Sasha]is the length of the MPLS payload derived from the Layer 2
> > [Sasha]lentgh after stripping the Layer 2 header and the 
> label stack,
> > [Sasha]MAX_PAD = 46 is the max. padding that can be added 
> by Ethernet):
> > [Sasha]
> > [Sasha](1) (LEN_CW == 0) && (LEN_L2 < 64)       
> > [Sasha](2) (LEN_CW > 0) && (LEN_L2 < LEN_CW)
> > [Sasha](3) (LEN_CW > 0) && (LEN_L2 > LEN_CW + MAX_PAD) 
> > [Sasha]
> > [Sasha]To me all the cases above look like malformed packets to be
> > [Sasha] silently discarded...
> 
> I'm not sure the document needs to specify all possible error 
> conditions. It 
> would certainly be nice, but I'm not sure it is 100% necessary.
> 
> > [Sasha]Note that in these terms  "trimming is not
> > [Sasha]required" means that (LEN_CW > 0) && (LEN_L2 == LEN_CW).
> > [Sasha]I'd also say that "trimming is required" means
> > 
> > [Sasha](LEN_CW > 0) && (LEN_L2 > LEN_CW) && (LEN_L2 <= 
> LEN_CW + MAX_PAD)
> > 
> > [Sasha]Maybe it is worth explicitly specifying these rules?
> 
> Perhaps so. My concern was a bit less comprehensive, but you 
> make a good point. 
> I'll wait to hear other opinions if there are any...
[Sasha] Basically I have written this text to explain 
that "is required" is ambiguous, and IMO your concern 
was exactly about that. How to make it unambiguous is
a different issue.
> 
> > 
> >>Yes, I understand the issue here is ethernet, I'm not 
> >>debating when it is 
> >>necessary or not. I simply find it odd that we have an 
> >>exception clause on the 
> >>trimming, but not on the setting of the field.
> >>
> >>Also, I think it might be helpful for interoperability to 
> >>point out ethernet as 
> >>an example of when this field would be used. This shouldn't 
> >>take more than a 
> >>sentence or two and perhaps a reference.
> >>
> > 
> > [Sasha] IMO it is also worth noting that any hypothetical media
> > that pads L2 frames to sizes exceeding 64 would not be suitable
> > for carrying MPLS PWs oaver it. 
> 
> Yes, I agree.
> 
> - Mark
> 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Ron Cohen" <[email-masked]>
Date: Thu, 14 Apr 2005 21:34:10 +0300

Hi,

The authors of CEP draft are working to align the CEP CW with the
recommended PW CW. 

However, I do see a problem with the current sequence number text.
The TDM emulation drafts all work on all values of the sequence number
and do not skip over the 0 value. This is aligned with the use of
sequence numbers in RTP. 

Best would be to mandate the use of the entire range of sequence numbers
when configured to set and track sequence numbers for all services (not
only TDM), and set the sequence number to zero when not used.

If no consensus on this change for all PW services can be agreed, I
suggest to change the current text in CW draft to something similar to
the following:

Sequence number (Bit 16 to 31): 

          The sequence number specifies the sequence number of a packet
          Usage of the sequence number field is OPTIONAL or MANDATORY 
          depending on the emulated service. For services for which 
          usage of the sequence number is MANDATORY, the sequence
          number cycles over all values. For services for which usage
          of the sequence number is OPTIONAL it MUST be set to zero
          by the sender and ignored by the receiver if not used.  
          Otherwise it MUST cycle from 1 to 65535 (2**16-1). The 
          sequence number window size for packet acceptance is dependent
          on the parameters of both the PW and 
          the MPLS PSN, and SHOULD be configurable. The mechanism used 
          by the decapsulating PE to syncronise the expected sequence 
          number with the received sequence number is implementation 
          dependent.   

Regards
Ron

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Sasha Vainshtein
Sent: Thursday, April 14, 2005 6:15 PM
To: 'W. Mark Townsley'
Cc: Yaakov Stein (E-mail); PWE3 WG (E-mail); Danny McPherson; Andrew G.
Malis (E-mail); Ron Cohen (E-mail); Luca Martini; Stewart Bryant
Subject: RE: [PWE3] AD Review of draft-ietf-pwe3-cw-03.txt

Mark (and all),

Regards,
                                  Sasha Vainshtein
email:                         [email-masked]
<mailto:[email-masked]> 
phone:                       +972-3-7569993 (office)
fax:                            +972-3-6487779
mobile:                      +972-52-8674833 

> > [Sasha]Neither this draft nor any service-specific [Sasha]draft 
> > explains how to treat the following situations [Sasha](LEN_CW is the

> > value of the Length field and LEN_L2 [Sasha]is the length of the 
> > MPLS payload derived from the Layer 2 [Sasha]lentgh after stripping 
> > the Layer 2 header and the
> label stack,
> > [Sasha]Note that in these terms  "trimming is not [Sasha]required" 
> > means that (LEN_CW > 0) && (LEN_L2 == LEN_CW). [Sasha]I'd also say 
> > that "trimming is required" means
> > 
> > [Sasha] IMO it is also worth noting that any hypothetical media that

> > pads L2 frames to sizes exceeding 64 would not be suitable for 
> > carrying MPLS PWs oaver it.
> 
> Yes, I agree.
> 
> - Mark
>

---

From: Stewart Bryant <[email-masked]>
Date: Tue, 19 Apr 2005 22:39:02 +0100

> suggest to change the current text in CW draft to something similar to

Given the number of implementations that skip 0, I think that we can
take it as read that there will be no consensus for this.

>           number with the received sequence number is implementation 

I would be happy to include this. This is what has been implemented
far. Including the text would save four drafts including exception
text explaining why they used the complete sequence space.

I don't think that we should let this drag on, so unless I hear technical
reasons for doing otherwise I will include this amendment in the next
vesion of the control word draft.

Stewart

---

From: [email-masked]
Date: Tue, 19 Apr 2005 22:54:17 +0100

Hi Stewart, Ron,
I support this wording.
Tim

Stewart Bryant <[email-masked]> 
Sent by: [email-masked]
19/04/2005 22:39

To
Ron Cohen <[email-masked]>
cc
"'Yaakov Stein \(E-mail\)'" <[email-masked]>, "'PWE3 WG \(E-mail\)'" 
<[email-masked]>, "'Danny McPherson'" <[email-masked]>, "'Andrew G. Malis 
\(E-mail\)'" <[email-masked]>, "'W. Mark Townsley'" 
<[email-masked]>, "'Luca Martini'" <[email-masked]>, "'Sasha 
Vainshtein'" <[email-masked]>
Subject
Re: [PWE3] AD Review of draft-ietf-pwe3-cw-03.txt

Stewart