Subject: RE: [PWE3] Sequence numbers

From: Sasha Vainshtein <[email-masked]>
Date: Mon, 25 Apr 2005 17:05:31 +0200

Stewart, Yaakov and all,
I am not sure that the binding between MANDATORY/OPTIONAL 
sequencing support and skipping zero is a good idea even if
it happens to reflect correctly the current state of things.

Please consider the hypothetical use case when, for some reason, 
the ATM N-to-one Cell PW encapsulation changes its currently OPTIONAL 
sequencing support to MANDATORY (may be not quite a crazy idea because
this is the only way to guarantee that ATM PM works properly across
these PWs). Such a change would make ALL the implementations - both ones 
that did not support sequencing and ones that did - non-compliant
because the sequencing method must be now changed in the latter, not just
added to the former...

Passing the description of how the sequencing is performed to the 
service-specific documents looks much more stable to me.

Regards,
                                  Sasha Vainshtein
email:                         [email-masked] <mailto:[email-masked]> 
phone:                       +972-3-7569993 (office)
fax:                            +972-3-6487779
mobile:                      +972-52-8674833 

> -----Original Message-----
> From: Stewart Bryant [mailto:[email-masked]]
> Sent: Monday, April 25, 2005 3:24 PM
> To: pwe3
> Subject: [PWE3] Sequence numbers
> 
> 
> Since Sasha raises it, here is the sequence number text
> proposed by Yaakov.
> 
> I will wait to see the consenus on the a/b choice and then
> publish control word -04 in a day or so.
> 
> Stewart
> 
> Sequence number (Bit 16 to 31):
> 
>            The sequence number implements the sequencing function
>            [RFC3985]. For some emulated services usage of the sequence
>            number field is OPTIONAL while for others it is MANDATORY.
>            For services for which usage is MANDATORY, the sequence
>            number cycles over all values from 0 to 65535 (2**16-1).
> 
>            For services for which usage is OPTIONAL, when the sequence
>            number is used it cycles from 1 to 65535 (2**16-1), and a
>            zero value indicates that it is not used.
> 
>            The size of the window used for packet acceptance is
>            dependent on the parameters of both the PW and the 
> MPLS PSN,
>            and SHOULD be configurable. The mechanism used by 
> a receiver
>            to synchronize the expected and received sequence numbers
>            is implementation dependent.
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
> 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 25 Apr 2005 15:48:37 +0100

> service-specific documents looks much more stable to me.

Sasha

It seems unlikely that we will need a third type of sequence number
design unless we move to a larger number. It would therefore be
a good thing if we could write down in one place the description
of the two cases. Perhaps we could find a better pair of words
than OPTIONAL/MANDATORY to describe the two cases.

Stewart

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 25 Apr 2005 10:48:53 -0400

I agree with Sasha's comment below.

Cheers,
Andy

----------