Subject: [QUIC] New Issue: stream state transition diagram typo

From: Ahsan Saba <[email-masked]>
Date: Wed, 2 Nov 2016 07:30:39 +0000

Hi,

Getting the ball rolling with a simple one. I believe there is a typo in the diagram showing stream state transitions on Page 29 of draft-hamilton-quic-transport-protocol-01. The transition from half closed (local) and half closed (remote) to closed is done by send FIN and recv FIN respectively. It should be reversed.

Also wondering if similar “smallish” issues should be posted on the mailing list or github in the future.

Regards,
Saba

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 2 Nov 2016 01:02:16 -0700

Hi Ahsan,

Getting the ball rolling with a simple one. I believe there is a typo in
> the diagram showing stream state transitions on Page 29 of
> draft-hamilton-quic-transport-protocol-01. The transition from half
> closed (local) and half closed (remote) to closed is done by send FIN and
> recv FIN respectively. It should be reversed.
>

Ah! Nice catch -- fixed.

> mailing list or github in the future.

Not sure. Is it ok to do github before documents are adopted?

- jana

Regards,
> Saba
>
>
>
> _______________________________________________
> QUIC mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/quic
>
>

---

From: Martin Thomson <[email-masked]>
Date: Thu, 3 Nov 2016 02:20:37 +1100

> Not sure. Is it ok to do github before documents are adopted?

Not a chair, but if you have things on github, you can do github.  The
docs are currently private, so the process for managing them is
entirely up to the authors.

Note that moving repos around can be a little tricky.  You have to be
owner of both source and target organization.  If there is an official
organization, and the chairs are amenable, hosting the docs there
might be easiest to manage (with a prominent disclaimer about status).
Copying is possible, but it loses some information (issues primarily)
and forking is a disaster.

---

From: "Eggert, Lars" <[email-masked]>
Date: Wed, 2 Nov 2016 15:29:57 +0000

> entirely up to the authors.

Need to check with Mark, but I think the intent is that we'd be appointing WG editors for the various work items during Seoul, and ideally also also be adopting some of the current batch of individual IDs as the basis for those WG work items.

We'd then move those underneath the WG github at https://github.com/quicwg and follow the process at https://github.com/quicwg/wg-materials/blob/master/CONTRIBUTING.md that Mark has just asked for feedback on.

Lars

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 2 Nov 2016 10:25:17 -0700

On Wed, Nov 2, 2016 at 8:29 AM, Eggert, Lars <[email-masked]> wrote:

> Need to check with Mark, but I think the intent is that we'd be appointing
> WG editors for the various work items during Seoul, and ideally also also
> be adopting some of the current batch of individual IDs as the basis for
> those WG work items.
>
> We'd then move those underneath the WG github at https://github.com/quicwg
> and follow the process at https://github.com/quicwg/wg-
> materials/blob/master/CONTRIBUTING.md that Mark has just asked for
> feedback on.
>

That's what I figured as well. Thanks for the clarification.
We'll continue discussions of the individual drafts on the mailing list in
the meanwhile.