Subject: Re: [QUIC] Working process / contribution policy for the QUIC WG -- comments?

From: =JeffH <[email-masked]>
Date: Tue, 15 Nov 2016 10:31:29 +0900

> As discussed previously, we plan on using Github to manage our
 > documents and issues list.
 >
 > To help people understand how that will work, we've started to write
 > down a contribution policy, based upon the process that was used to
 > develop HTTP/2 successfully. Please take a moment and read:
 >
 > https://github.com/quicwg/wg-materials/blob/master/CONTRIBUTING.md
 >
 > If you have any suggestions, questions or concerns, please raise them
 > on the mailing list, or against that repo. Note that the separate
 > "issues" mailing list hasn't yet been activated until we confirm this
 > process with the WG.

One question is whether the quic specs will all be placed in the 
<https://github.com/quicwg/wg-materials/> repo, or whether y'all will 
create another repo (under ithub.com/quicwg) for all the specs, or a 
separate repo for each draft, or... ?

HTH,

=JeffH

---

From: "Eggert, Lars" <[email-masked]>
Date: Tue, 15 Nov 2016 02:46:23 +0000

On 2016-11-15, at 10:31, =JeffH <[email-masked]<mailto:[email-masked]>> wrote:

One question is whether the quic specs will all be placed in the <https://github.com/quicwg/wg-materials/> repo, or whether y'all will create another repo (under ithub.com/quicwg<http://ithub.com/quicwg>) for all the specs, or a separate repo for each draft, or... ?

Current thinking is one repo (and a common document format, e.g. Markdown) for the four heavily intertwined initial documents (since text may move and issues may affect multiple ones). Additional separate repos for other IDs that are more standalone.

Lars

---

From: Martin Thomson <[email-masked]>
Date: Tue, 15 Nov 2016 12:46:36 +0900

On 15 November 2016 at 11:46, Eggert, Lars <[email-masked]> wrote:
> Current thinking is one repo (and a common document format, e.g. Markdown)
> for the four heavily intertwined initial documents (since text may move and
> issues may affect multiple ones). Additional separate repos for other IDs
> that are more standalone.

Jeff identified the repo that is for working group materials.  In
HTTP, we kept meeting agendas, minutes, slides, and other material
like that in a repo like wg-materials, separate from the working
documents.

Concentrating drafts and their issues in the same repo helps a lot.

---

From: Patrick McManus <[email-masked]>
Date: Tue, 15 Nov 2016 12:49:50 +0900

On Tue, Nov 15, 2016 at 12:46 PM, Martin Thomson <[email-masked]>
wrote:

> +1

quic folk might like to look at the current HTTPbis example
https://github.com/httpwg/http-extensions which houses a number of current
active drafts and their issue lists

---

From: "Eggert, Lars" <[email-masked]>
Date: Tue, 15 Nov 2016 04:38:43 +0000

On 2016-11-15, at 12:46, Martin Thomson <[email-masked]<mailto:[email-masked]>> wrote:

On 15 November 2016 at 11:46, Eggert, Lars <[email-masked]<mailto:[email-masked]>> wrote:

That would be https://github.com/quicwg/wg-materials

There was some concerns that once there are many drafts, having just a single repo for drafts would make it very noisy. Hence the intent to try and do some sort of loose grouping.

Lars

---

From: Martin Thomson <[email-masked]>
Date: Tue, 15 Nov 2016 14:47:55 +0900

On 15 November 2016 at 13:38, Eggert, Lars <[email-masked]> wrote:
> There was some concerns that once there are many drafts, having just a
> single repo for drafts would make it very noisy. Hence the intent to try and
> do some sort of loose grouping.

I believe that what we discussed was having a single repo for the four
drafts we proto-adopted today (five if the HTTP part gets split).
Yes, there is a concern that the level of noise might be high with
issues and traffic for all of those documents on the same repo, but
having them in the same place allows us a bit of flexibility and
coherence that separate repos might make difficult.  For instance, we
can more easily move text between documents, make changes to multiple
drafts in a single change set, and track issues that cover multiple
documents.

When it comes time to do an operational
challenges/requirements/discussion document, I will likely argue to
have that in a separate repo.

---

From: "Eggert, Lars" <[email-masked]>
Date: Tue, 15 Nov 2016 05:56:47 +0000

> drafts in a single change set, and track issues that cover multiple

Sorry for being unclear - I believe four (or five) is a small enough number that those issues - should they even arise - are very manageable. What I meant to express was that we shouldn't necessarily put all other future documents into the same repo by default, but instead make that a conscious decision, with a preference for separate repos.

> have that in a separate repo.

We are aligned.

Lars

---

From: Daniel Kahn Gillmor <[email-masked]>
Date: Tue, 15 Nov 2016 15:45:24 +0900

On Tue 2016-11-15 11:46:23 +0900, Eggert, Lars wrote:
> On 2016-11-15, at 10:31, =JeffH wrote:
>
>> https://github.com/quicwg/wg-materials/ repo

Also, there is apparently https://github.com/ietf-quic, which contains
(i think) an older version of the charter.

Could we consolidate all these repos under a single github
"organization" so that it's not a hunting game to find the relevant
repos?

               --dkg

---

From: "Eggert, Lars" <[email-masked]>
Date: Tue, 15 Nov 2016 07:36:35 +0000

On 2016-11-15, at 15:45, Daniel Kahn Gillmor <[email-masked]<mailto:[email-masked]>> wrote:
Also, there is apparently https://github.com/ietf-quic, which contains
(i think) an older version of the charter.

IMO we can just delete that.

Lars

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 15 Nov 2016 22:17:46 +0900

+1

> On 15 Nov. 2016, at 4:36 pm, Eggert, Lars <[email-masked]> wrote:
> 
> On 2016-11-15, at 15:45, Daniel Kahn Gillmor <[email-masked]> wrote:

--
Mark Nottingham   https://www.mnot.net/