Subject: ECN support in QUIC

From: Ingemar Johansson S <[email-masked]>
Date: Fri, 2 Dec 2016 12:09:58 +0000

Hi

I commented a little on  draft-iyengar-quic-loss-recovery-01
https://mailarchive.ietf.org/arch/msg/quic/qhYslAmlbPPCaF57Qm70_Trg4XQ
Realize that he draft was renamed to draft-ietf-quic-recovery shortly  after. I will read it and see if my comments are still valid.

I have one question though as regards to ECN support in QUIC, where will this be described. I can imagine that parts of it will go in quic-recovery but I assume that quic-transport needs an update for the protocol specifics, does the handshake and negotiation as well as possible fallback upon failure go there as well.

/Ingemar

==================================
Ingemar Johansson  M.Sc.
Master Researcher

Ericsson AB
Wireless Access Networks
Labratoriegränd 11
971 28, Luleå, Sweden
Phone +46-1071 43042
SMS/MMS +46-73 078 3289
[email-masked]<mailto:[email-masked]>
www.ericsson.com

     No, you can´t tell people anything
         You've got to show 'em
              Bruce Springsteen
==================================

---

From: Ian Swett <[email-masked]>
Date: Sat, 3 Dec 2016 10:40:06 -0500

Good point, I added an open issue for ECN.  Feel free to add any comments
there.

https://github.com/quicwg/base-drafts/issues/68

On Fri, Dec 2, 2016 at 7:09 AM, Ingemar Johansson S <
[email-masked]> wrote:

> Realize that he draft was renamed to draft-ietf-quic-recovery shortly
>  after. I will read it and see if my comments are still valid.
>
>
>
> I have one question though as regards to ECN support in QUIC, where will
> this be described. I can imagine that parts of it will go in quic-recovery
> but I assume that quic-transport needs an update for the protocol
> specifics, does the handshake and negotiation as well as possible fallback
> upon failure go there as well.
>
>
>
> /Ingemar
>
>
>
> SMS/MMS +46-73 078 3289 <+46%2073%20078%2032%2089>
>
> [email-masked]
>
> www.ericsson.com
>
>
>
>          You’ve got to show ‘em

---

From: Ingemar Johansson S <[email-masked]>
Date: Mon, 5 Dec 2016 09:16:44 +0000

Thanks. Added some the specifics below on Github
/Ingemar
-------------
The specific items that are needed are (perhaps more ?)

  *   ECN echo in protocol, preferrably as a mandatory to implement part, RFC7560 can provide with valuable input in the design
  *   ECN negotiation, the work on updated ECN semantics in TSVWG should be addressed (L4S support)
  *   Fallback for in various failure cases, and RFC6679 and draft-kuehlewind-tcpm-ecn-fallback-01 may provide input
  *   Address user space limitation, collect best current practice to read/write ECN bits for different OS.
  *   Align meaning of ECN-CE marking of ECT(0) and ECT(1) traffic with TSVWG

From: Ian Swett [mailto:[email-masked]]
Sent: den 3 december 2016 16:40
To: Ingemar Johansson S <[email-masked]>
Cc: [email-masked]
Subject: Re: ECN support in QUIC

Good point, I added an open issue for ECN.  Feel free to add any comments there.

On Fri, Dec 2, 2016 at 7:09 AM, Ingemar Johansson S <[email-masked]<mailto:[email-masked]>> wrote:
Hi

/Ingemar

Ericsson AB
Wireless Access Networks
Labratoriegränd 11
971 28, Luleå, Sweden
Phone +46-1071 43042
SMS/MMS +46-73 078 3289<tel:+46%2073%20078%2032%2089>
[email-masked]<mailto:[email-masked]>
www.ericsson.com<http://www.ericsson.com>

---

From: Ingemar Johansson S <[email-masked]>
Date: Thu, 22 Dec 2016 10:18:43 +0000

Hi

I decided that it is high time to get started with this after the holidays.
The prosed ECN TODO items are described in https://github.com/quicwg/base-drafts/issues/68 .

  *   ECN echo in protocol, preferrably as a mandatory to implement part, RFC7560 can provide with valuable input in the design
  *   ECN negotiation, the work on updated ECN semanticts in TSVWG should be addressed (L4S support)
  *   Fallback for in various failure cases, RFC6679 and draft-kuehlewind-tcpm-ecn-fallback-01 may provide input
  *   Address user space limitation, collect best current practice to read/write ECN bits for different OS.
  *   Align meaning of ECN-CE marking of ECT(0) and ECT(1) traffic with TSVWG

My thinking is that it is perhaps best to start with a draft that describes how these TODOs are solved ?. As it evolves, select parts of it can be moved  to the applicable WG drafts, most likely this ECN in QUIC can silently expire unless there are parts that don’t fit in an existing WG draft.
Does this sound reasonable ?

/Ingemar

/Ingemar

Ericsson AB
Wireless Access Networks
Labratoriegränd 11
971 28, Luleå, Sweden
Phone +46-1071 43042

---

From: Michael Welzl <[email-masked]>
Date: Sun, 25 Dec 2016 11:05:03 +0100

> On Dec 22, 2016, at 11:18 AM, Ingemar Johansson S <[email-masked]> wrote:
> 
> Hi
>  
> The prosed ECN TODO items are described in https://github.com/quicwg/base-drafts/issues/68 <https://github.com/quicwg/base-drafts/issues/68> . 
> ECN echo in protocol, preferrably as a mandatory to implement part, RFC7560 can provide with valuable input in the design
> ECN negotiation, the work on updated ECN semanticts in TSVWG should be addressed (L4S support)
> Fallback for in various failure cases, RFC6679 and draft-kuehlewind-tcpm-ecn-fallback-01 may provide input
> Address user space limitation, collect best current practice to read/write ECN bits for different OS.
> Align meaning of ECN-CE marking of ECT(0) and ECT(1) traffic with TSVWG
>  

It does, to me…

cheers,
Michael

>  
> /Ingemar
>  
> From: Ian Swett [mailto:[email-masked] <mailto:[email-masked]>] 
> To: Ingemar Johansson S <[email-masked] <mailto:[email-masked]>>
> Cc: [email-masked] <mailto:[email-masked]>
> https://github.com/quicwg/base-drafts/issues/68 <https://github.com/quicwg/base-drafts/issues/68>
>  
> On Fri, Dec 2, 2016 at 7:09 AM, Ingemar Johansson S <[email-masked] <mailto:[email-masked]>> wrote:
> Hi
>  
> https://mailarchive.ietf.org/arch/msg/quic/qhYslAmlbPPCaF57Qm70_Trg4XQ <https://mailarchive.ietf.org/arch/msg/quic/qhYslAmlbPPCaF57Qm70_Trg4XQ>
> SMS/MMS +46-73 078 3289 <tel:+46%2073%20078%2032%2089>
> [email-masked] <mailto:[email-masked]>
> www.ericsson.com <http://www.ericsson.com/>
>