Subject: Patents on RTT marking?

From: Martin Duke <[email-masked]>
Date: Mon, 24 Jul 2017 09:34:28 -0700

A colleague sent me this Telecom Italia patent:

https://www.google.com/patents/US9264336

This seems to be at least in the neighborhood of the preferred approach for
RTT measurement by middleboxes (option 3a in Prague). I find reading
patents to be among the least enjoyable and productive things to do, but my
reading is that this doesn't quite describe our approach here. This is
partly because the concept seems to be endpoint measurement rather than
middlebox measurement.

Anyhow, I'm putting this out there for consideration. If people smarter
than me think this covers 3a, perhaps this steers towards something like
Packet Number Echo.

Martin Duke

---

From: Mike Bishop <[email-masked]>
Date: Mon, 24 Jul 2017 17:08:03 +0000

I leave patent reading to the lawyers.  Let’s start by designing the best solution we can, and figure out any impacted IP once we know what we want.

From: QUIC [mailto:[email-masked]] On Behalf Of Martin Duke
Sent: Monday, July 24, 2017 9:34 AM
To: IETF QUIC WG <[email-masked]>
Subject: Patents on RTT marking?

https://www.google.com/patents/US9264336<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.google.com%2Fpatents%2FUS9264336&data=02%7C01%7Cmichael.bishop%40microsoft.com%7C88a31141dced43fe35fc08d4d2b1e0cf%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636365108808326205&sdata=BqweL5Z6RTBhkeHXiJBR7XWaPjLvApM5%2FJa6E04bFA0%3D&reserved=0>

This seems to be at least in the neighborhood of the preferred approach for RTT measurement by middleboxes (option 3a in Prague). I find reading patents to be among the least enjoyable and productive things to do, but my reading is that this doesn't quite describe our approach here. This is partly because the concept seems to be endpoint measurement rather than middlebox measurement.

Anyhow, I'm putting this out there for consideration. If people smarter than me think this covers 3a, perhaps this steers towards something like Packet Number Echo.

Martin Duke