Subject: Version numbers for implementation drafts

From: Eric Rescorla <[email-masked]>
Date: Wed, 12 Jul 2017 09:54:43 -0700

It seems like people have started looking at implementing what's in
the editor's copy rather than strict -04, and that seems like it potentially
creates an opportunity for confusion. So, how shall we handle that?
Just call it -05 and you're at your own risk?

-Ekr

---

From: Ian Swett <[email-masked]>
Date: Wed, 12 Jul 2017 12:58:13 -0400

05 SGTM

---

From: Patrick McManus <[email-masked]>
Date: Wed, 12 Jul 2017 13:18:53 -0400

we should have used 160 bit version numbers to accommodate sha-1
git-revision's of the editor's copy :)

I'm using some other random codepoint I squatted on the wiki for
experimentation when not talking about a published ID...

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 12 Jul 2017 17:30:46 +0000

What about hq-04.01-transitional?
________________________________________
From: QUIC [[email-masked]] on behalf of Patrick McManus [[email-masked]]
Sent: 12 July 2017 18:18
To: Ian Swett
Cc: Eric Rescorla; IETF QUIC WG
Subject: Re: Version numbers for implementation drafts

we should have used 160 bit version numbers to accommodate sha-1 git-revision's of the editor's copy :)

I'm using some other random codepoint I squatted on the wiki for experimentation when not talking about a published ID...

On Wed, Jul 12, 2017 at 12:58 PM, Ian Swett <[email-masked]<mailto:[email-masked]>> wrote:
05 SGTM

On Wed, Jul 12, 2017 at 12:54 PM, Eric Rescorla <[email-masked]<mailto:[email-masked]>> wrote:

-Ekr

-----------------------------
http://www.bbc.co.uk
This e-mail (and any attachments) is confidential and
may contain personal views which are not the views of the BBC unless specifically stated.
If you have received it in
error, please delete it from your system.
Do not use, copy or disclose the
information in any way nor act in reliance on it and notify the sender
immediately.
Please note that the BBC monitors e-mails
sent or received.
Further communication will signify your consent to
this.
-----------------------------

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 12 Jul 2017 10:33:45 -0700

On Wed, Jul 12, 2017 at 10:30 AM, Lucas Pardue <[email-masked]>
wrote:

> ____________________________

This is about the QUIC version #, which is just an integer. The other
thread is about ALPN :)

-Ekr

> ___________