Subject: Unidirectional Streams discussion

From: Mark Nottingham <[email-masked]>
Date: Tue, 25 Jul 2017 17:36:15 +1000

Everyone,

In Prague, we discussed Unidirectional Streams.

  Issue: https://github.com/quicwg/base-drafts/issues/175
  Draft minutes: https://github.com/quicwg/wg-materials/blob/master/ietf99/minutes.md#unidirectional-streams

The outcome of that discussion was that Martin would continue to work on his proposal, and EKR would experiment with unidirectional streams in a branch of his implementation, to gain experience with them and help judge the amount of complexity they save or add.

We'll take a look at their work at the October interim meeting.

In the meantime, our approach remains bidirectional streams (including for the purposes of Implementation Draft 2)*.

Please refrain from discussing unidirectional streams on-list; if Martin and EKR have questions to help guide their exploration, they should ask the group, but otherwise we shouldn't be spending additional time on this until we have their results.

Thanks,

* Editors / Martin Duke -- please clarify that ID2 will be using bidirectional streams as necessary.

--
Mark Nottingham   https://www.mnot.net/

---

From: Martin Duke <[email-masked]>
Date: Tue, 25 Jul 2017 15:41:20 -0700

clarification added.

On Tue, Jul 25, 2017 at 12:36 AM, Mark Nottingham <[email-masked]> wrote:

>   Draft minutes: https://github.com/quicwg/wg-
> materials/blob/master/ietf99/minutes.md#unidirectional-streams
>
> The outcome of that discussion was that Martin would continue to work on
> his proposal, and EKR would experiment with unidirectional streams in a
> branch of his implementation, to gain experience with them and help judge
> the amount of complexity they save or add.
>
> In the meantime, our approach remains bidirectional streams (including for
> the purposes of Implementation Draft 2)*.
>
> Please refrain from discussing unidirectional streams on-list; if Martin
> and EKR have questions to help guide their exploration, they should ask the
> group, but otherwise we shouldn't be spending additional time on this until
> we have their results.
>
> Thanks,
>
>