Subject: RE: Interests of Using QUIC for 3GPP 5G Core Control Plane

From: Mike Bishop <[email-masked]>
Date: Tue, 22 Aug 2017 23:51:50 +0000

Hi, Liang -

I wanted to make sure we got back to you on this, since this didn't make it onto the IETF 99 agenda and I didn't see any subsequent list discussion.

The answer to the question you ask in your slides is definitely "no":  the QUIC transport will not be sent to the IESG by Q4 of 2017.  The QUIC WG was chartered in October 2016 and our chartered milestones say that we hope to finish the transport, TLS, and congestion control docs by March of 2018.  That already seems somewhat improbable to me.  (Chairs and fellow editors, speak up if you disagree.)

This is a really interesting proposal and I'd love to see it move forward.  You say that it would need to be "a stable WG document," which seems slightly contradictory - a WG document is inherently still changing.  If what you need is the fact that those features are present and not going to be removed, we're already there.  If what you need is that the wire format is locked, I don't think that's likely.

But if 5G slips, or just has feature requirements to relay to us so that it could leverage QUIC in future work, I'm interested in seeing what those requirements would be.

From: QUIC [mailto:[email-masked]] On Behalf Of GENG Liang
Sent: Tuesday, July 11, 2017 5:29 PM
To: quic <[email-masked]>
Subject: Interests of Using QUIC for 3GPP 5G Core Control Plane

Dear all,

We are proposing and promoting the use of QUIC for 3GPP SBA control plane. This results from various advantages of QUIC protocol, which align with the 3GPP requirements:

-Performance advantages including 0-RTT and Multiplexing
-Reliability advantages including ACK mechanism over UDP and etc.

We put together a set of sides to introduce the timeline of 3GPP work and what we think are important to be considered if QUIC could be potentially adopted.

Although I fully understand that the WG session may be packed in IETF99, we would really appreciate if a 5-10 mins could be allocated to us to present this interest to all QUIC colleagues.

Any comments will be extremely welcome.

Best wishes
Liang

________________________________
Liang GENG
China Mobile Research Institute

---

From: Martin Thomson <[email-masked]>
Date: Wed, 23 Aug 2017 10:13:31 +1000

I agree with Mike, it seems like your timelines are too tight for a
requirement on *QUIC*.

But that's probably the wrong way to look at this.  The question you
should instead ask is whether HTTP can meet your requirements.  Based
on the slides, it would appear that HTTP with HTTP/2 and TLS 1.3 would
meet those requirements.

That leaves the option to use QUIC open when QUIC is ready.  We have
what we believe is an adequate story for seamlessly introducing QUIC
into a system that uses HTTP.

Creating dependencies on HTTP generically and maybe HTTP/2 and TLS 1.3
would be a reasonable plan in my view.

On 23 August 2017 at 09:51, Mike Bishop <[email-masked]> wrote:
> Hi, Liang –
>
>
>
> I wanted to make sure we got back to you on this, since this didn’t make it
> onto the IETF 99 agenda and I didn’t see any subsequent list discussion.
>
>
>
> The answer to the question you ask in your slides is definitely “no”:  the
> QUIC transport will not be sent to the IESG by Q4 of 2017.  The QUIC WG was
> chartered in October 2016 and our chartered milestones say that we hope to
> finish the transport, TLS, and congestion control docs by March of 2018.
> That already seems somewhat improbable to me.  (Chairs and fellow editors,
> speak up if you disagree.)
>
>
>
> This is a really interesting proposal and I’d love to see it move forward.
> You say that it would need to be “a stable WG document,” which seems
> slightly contradictory – a WG document is inherently still changing.  If
> what you need is the fact that those features are present and not going to
> be removed, we’re already there.  If what you need is that the wire format
> is locked, I don’t think that’s likely.
>
>
>
> But if 5G slips, or just has feature requirements to relay to us so that it
> could leverage QUIC in future work, I’m interested in seeing what those
> requirements would be.
>
>
>
> We are proposing and promoting the use of QUIC for 3GPP SBA control plane.
> This results from various advantages of QUIC protocol, which align with the
> 3GPP requirements:
>
>
>
> We put together a set of sides to introduce the timeline of 3GPP work and
> what we think are important to be considered if QUIC could be potentially
> adopted.
>
>
>
> Although I fully understand that the WG session may be packed in IETF99, we
> would really appreciate if a 5-10 mins could be allocated to us to present
> this interest to all QUIC colleagues.
>
>
>