Subject: Remote interop days

From: "Eggert, Lars" <[email-masked]>
Date: Thu, 16 Nov 2017 07:13:26 +0000

Hi,

someone brought up the idea to have more frequent remote interop days, in addition to our in-person interop events, where implementers could use Slack and Hangout, etc. to coordinate testing and debugging their stacks.

Designating a given day each week/fortnight/month for this might be simpler to arrange than pairwise agreements between implementers, because you could just show up and reasonably expect for someone to be available who'd want to try and interop. My guess is that it'd be a 24h thing (due to time zones).

Questions to the implementers:

(1) Should we try this?
(2) Cadence?
(3) Any suggestions/tweaks/additions?

Lars

---

From: Sebastiaan Deckers <[email-masked]>
Date: Thu, 16 Nov 2017 15:32:10 +0800

> (3) Any suggestions/tweaks/additions?

The current QUIC WG About page links [1] to a Slack instance for,
apparently, the same purpose. However there is no public signup AFAICT.
Would these remote interop days be public, private, or somewhere in between?

1. https://datatracker.ietf.org/wg/quic/about/#dependency_graph
   "Slack channels for interop/implementors; not covered by IETF Note Well"

---

From: "Eggert, Lars" <[email-masked]>
Date: Thu, 16 Nov 2017 07:43:14 +0000

On 2017-11-16, at 15:32, Sebastiaan Deckers <[email-masked]> wrote:
> 
> On Thu, Nov 16, 2017 at 3:13 PM, Eggert, Lars <[email-masked] <mailto:[email-masked]>> wrote:
> The current QUIC WG About page links [1] to a Slack instance for, apparently, the same purpose.

That is the Slack instance we would use.

> However there is no public signup AFAICT. Would these remote interop days be public, private, or somewhere in between?

Please correct me if I'm wrong, but I think Slack unfortunately can be configured for public (unconfirmed) signup. (We would do that if we could.)

The *intent* here is certainly that this Slack is public: everyone on it can add more members, and if anyone would like to join, they should simply email the editors or (preferred) chairs.

Lars

> 1. https://datatracker.ietf.org/wg/quic/about/#dependency_graph <https://datatracker.ietf.org/wg/quic/about/#dependency_graph>

---

From: "Eggert, Lars" <[email-masked]>
Date: Thu, 16 Nov 2017 07:44:06 +0000

On 2017-11-16, at 15:43, Lars Eggert <[email-masked]> wrote:
> 
> On 2017-11-16, at 15:32, Sebastiaan Deckers <[email-masked] <mailto:[email-masked]>> wrote:
>> 

unfortunately *cannot* be configured

---

From: Sebastiaan Deckers <[email-masked]>
Date: Thu, 16 Nov 2017 16:38:39 +0800

On Thu, Nov 16, 2017 at 3:43 PM, Eggert, Lars <[email-masked]> wrote:

> I think Slack unfortunately cannot be configured for public (unconfirmed)
> signup. (We would do that if we could.)

Suggestions (in no particular order nor exhaustive):
- https://github.com/outsideris/slack-invite-automation
- https://github.com/rauchg/slackin
- https://publicslack.com

---

From: "Morten V. Pedersen" <[email-masked]>
Date: Thu, 16 Nov 2017 09:43:36 +0100

You may also consider: https://zulipchat.com/
Fee and open source.

- M

On 11/16/2017 09:38 AM, Sebastiaan Deckers wrote:
> On Thu, Nov 16, 2017 at 3:43 PM, Eggert, Lars <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     I think Slack unfortunately cannot be configured for public
>     (unconfirmed) signup. (We would do that if we could.)
>
>

---

From: Patrick McManus <[email-masked]>
Date: Thu, 16 Nov 2017 16:55:59 +0800

if anyone in this thread would like a slack signup, just mail me (or just
about anyone else on the list :)) - happy to oblige.

---

From: Subodh Iyengar <[email-masked]>
Date: Thu, 16 Nov 2017 19:58:11 +0000

I support this and would be happy to participate. A once per month cadence would give me some time to build features to test during interop, and be frequent enough to give me the kick I need to keep updated with the latest draft features.

I imagine this would be a temporary thing for a few months until people build the tooling needed to keep their implementations running for longer with self service options like being able to look at client and server logs.

Subodh

________________________________
From: QUIC <[email-masked]> on behalf of Patrick McManus <[email-masked]>
Sent: Thursday, November 16, 2017 12:55:59 AM
To: Morten V. Pedersen
Cc: IETF QUIC WG
Subject: Re: Remote interop days

if anyone in this thread would like a slack signup, just mail me (or just about anyone else on the list :)) - happy to oblige.

On Thu, Nov 16, 2017 at 4:43 PM, Morten V. Pedersen <[email-masked]<mailto:[email-masked]>> wrote:
You may also consider: https://zulipchat.com/<https://urldefense.proofpoint.com/v2/url?u=https-3A__zulipchat.com_&d=DwMFaQ&c=5VD0RTtNlTh3ycd41b3MUw&r=h3Ju9EBS7mHtwg-wAyN7fQ&m=3FDvZWYtwS4WbP9AIc1_Yg41unEgECMgbLRUO9AB4U8&s=4KKTnILfvcaTDg_f0R_pirC9P0UE3TsZTnEWvvGSSSg&e=>
Fee and open source.

- M

On 11/16/2017 09:38 AM, Sebastiaan Deckers wrote:
On Thu, Nov 16, 2017 at 3:43 PM, Eggert, Lars <[email-masked]<mailto:[email-masked]>> wrote:
I think Slack unfortunately cannot be configured for public (unconfirmed) signup. (We would do that if we could.)

Suggestions (in no particular order nor exhaustive):
- https://github.com/outsideris/slack-invite-automation
- https://github.com/rauchg/slackin
- https://publicslack.com<https://urldefense.proofpoint.com/v2/url?u=https-3A__publicslack.com&d=DwMFaQ&c=5VD0RTtNlTh3ycd41b3MUw&r=h3Ju9EBS7mHtwg-wAyN7fQ&m=3FDvZWYtwS4WbP9AIc1_Yg41unEgECMgbLRUO9AB4U8&s=rdHTPkzDKq_EDzQXb9cVg9V6345T9kKX0khoWYbNTkM&e=>

---

From: Ian Swett <[email-masked]>
Date: Thu, 16 Nov 2017 22:41:03 -0500

I would participate if we held one in mid-December.  Any more often than
one per month would likely not be that helpful at this point.

On Thu, Nov 16, 2017 at 2:58 PM, Subodh Iyengar <[email-masked]> wrote:

> I support this and would be happy to participate. A once per month cadence
> would give me some time to build features to test during interop, and be
> frequent enough to give me the kick I need to keep updated with the latest
> draft features.
>
>
> I imagine this would be a temporary thing for a few months until people
> build the tooling needed to keep their implementations running for longer
> with self service options like being able to look at client and server
> logs.
>
>
> Subodh
> ------------------------------
> *From:* QUIC <[email-masked]> on behalf of Patrick McManus <
> [email-masked]>
> *Sent:* Thursday, November 16, 2017 12:55:59 AM
> *To:* Morten V. Pedersen
> *Cc:* IETF QUIC WG
> *Subject:* Re: Remote interop days
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__zulipchat.com_&d=DwMFaQ&c=5VD0RTtNlTh3ycd41b3MUw&r=h3Ju9EBS7mHtwg-wAyN7fQ&m=3FDvZWYtwS4WbP9AIc1_Yg41unEgECMgbLRUO9AB4U8&s=4KKTnILfvcaTDg_f0R_pirC9P0UE3TsZTnEWvvGSSSg&e=>
> Fee and open source.
>
> - M
>
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__publicslack.com&d=DwMFaQ&c=5VD0RTtNlTh3ycd41b3MUw&r=h3Ju9EBS7mHtwg-wAyN7fQ&m=3FDvZWYtwS4WbP9AIc1_Yg41unEgECMgbLRUO9AB4U8&s=rdHTPkzDKq_EDzQXb9cVg9V6345T9kKX0khoWYbNTkM&e=>
>
>
>
>

---

From: Christian Huitema <[email-masked]>
Date: Thu, 16 Nov 2017 22:33:45 -0800

Great idea. And +1 for the mid December target. With a draft-08 published, we could test varints.

-- Christian Huitema 

> On Nov 16, 2017, at 7:41 PM, Ian Swett <[email-masked]> wrote:
> 
> I would participate if we held one in mid-December.  Any more often than one per month would likely not be that helpful at this point.
> 
>> On Thu, Nov 16, 2017 at 4:43 PM, Morten V. Pedersen <[email-masked]> wrote:

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 21 Nov 2017 13:23:46 +0800

+1 -- I would participate (if it's before I leave for vacation.)

On Fri, Nov 17, 2017 at 2:33 PM, Christian Huitema <[email-masked]>
wrote:

>> I support this and would be happy to participate. A once per month
>> cadence would give me some time to build features to test during interop,
>> and be frequent enough to give me the kick I need to keep updated with the
>> latest draft features.
>>
>>
>> On Thu, Nov 16, 2017 at 4:43 PM, Morten V. Pedersen <[email-masked]
>> > wrote:
>>