Subject: spin bit in QUIC

From: Roni Even <[email-masked]>
Date: Tue, 14 Nov 2017 08:41:06 +0000

Hi,
It is good that the conclusion about the geo location security issue is that the spin bit does not add privacy risk on top of what can be done without it.

As for the spin bit. RTT calculation are used for trouble shooting in TCP see in draft-even-quic-troubleshooting-video-delivery-00.
The spin bit will provide similar functionality even though it is less reliable as was mentioned since it is not part of the QUIC state machine.
We envision that we will see a lot of QUIC traffic in the network and having the spin bit can help with identifying bottle necks in the network and reducing QUIC latency.  It will be important to have the spin bit in V1 and the main text is already in the github

Thanks
Roni Even

---

From: [email-masked]
Date: Tue, 14 Nov 2017 09:38:25 +0000

Adding to what Roni has below, first, I applaud to the spin bit design for their time since the Prague meeting and many thanks to Ted for presenting those findings.

>From Ted's presentation, it appears that the design team accomplished what they were asked to do, that is, look at geolocation threat and Min RTT. Slide 7 from Ted's presentation lays out negligible threat and at least not any additional adversarial information.  Given this, I would have thought design team to be less tentative and come to a clear consensus.

Also, agree with Marcus on his enumeration on the need for spin bit and as Roni pointed out inclusion of spin but in v1 gives us some real -world deployment experience on performance and bottlenecks.

I ask the chairs to add spin bit for v1.

-Sanjay

From: QUIC [mailto:[email-masked]] On Behalf Of Roni Even
Sent: Tuesday, November 14, 2017 4:41 PM
To: QUIC WG <[email-masked]>
Subject: [E] spin bit in QUIC

Hi,

Thanks
Roni Even

---

From: JESUS MARIA MARTIN GARCIA <[email-masked]>
Date: Wed, 15 Nov 2017 01:24:27 +0000

+1

Even with the limitations known, the spin bit will allow service providers to measure latency in the network for troubleshooting.

That's why I want to add my support for the inclusion of the spin bit into V1

BR
Jesus
Make a small change everyday

Jesús Martín | Telefónica S.A.

De: QUIC [mailto:[email-masked]] En nombre de [email-masked]
Enviado el: martes, 14 de noviembre de 2017 10:38
Para: QUIC WG <[email-masked]>
CC: Roni Even <[email-masked]>
Asunto: RE: spin bit in QUIC

-Sanjay

From: QUIC [mailto:[email-masked]] On Behalf Of Roni Even
Sent: Tuesday, November 14, 2017 4:41 PM
To: QUIC WG <[email-masked]<mailto:[email-masked]>>
Subject: [E] spin bit in QUIC

Hi,

Thanks
Roni Even

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: "Lubashev, Igor" <[email-masked]>
Date: Wed, 15 Nov 2017 03:46:57 +0000

If the operators believe that this bit will improve their networks and will help end user experience for QUIC, I am all for it (since the privacy risks of this bit is practically negligible).

  *   Igor

From: JESUS MARIA MARTIN GARCIA [mailto:[email-masked]]
Sent: Wednesday, November 15, 2017 9:24 AM
To: [email-masked]; QUIC WG <[email-masked]>
Subject: RE: spin bit in QUIC

+1

BR
Jesus

De: QUIC [mailto:[email-masked]] En nombre de [email-masked]<mailto:[email-masked]>
Enviado el: martes, 14 de noviembre de 2017 10:38
Para: QUIC WG <[email-masked]<mailto:[email-masked]>>
CC: Roni Even <[email-masked]<mailto:[email-masked]>>
Asunto: RE: spin bit in QUIC

-Sanjay

Hi,

Thanks
Roni Even