Subject: ECN in QUIC side meeting

From: Ingemar Johansson S <[email-masked]>
Date: Mon, 13 Nov 2017 02:41:37 +0000

Hi
I would like to propose that we, that is anybody interested in getting ECN support in QUIC, meet this week to discuss the details and a way forward towards the ultimate goal to get this to happen.
Something of a proposal is already written up in
https://github.com/quicwg/base-drafts/wiki/ECN-in-QUIC

I created a doodle where you can add your preference
https://doodle.com/poll/dupqc7bv6dmha6ra

/Ingemar
==================================
Ingemar Johansson  M.Sc.
Master Researcher

Ericsson Research
Network Protocols & E2E Performance
Labratoriegränd 11
971 28, Luleå, Sweden
Phone +46-1071 43042
SMS/MMS +46-73 078 3289
[email-masked]<mailto:[email-masked]>
www.ericsson.com

The world is full of magical things patiently
    waiting for our wits to grow sharper
               Bertrand Russell
==================================

---

From: Ingemar Johansson S <[email-masked]>
Date: Mon, 13 Nov 2017 10:28:38 +0000

Hi
Seems like we already now have a winner.
All of the doodlers so far have selected the time slot 16.00-17.00 on Thursday, which means that I hereby decide that we'll pick that slot.
I will try to arrange with a meeting room.

A wiki on the subject is already in place https://github.com/quicwg/base-drafts/wiki/ECN-in-QUIC
For those of you who attend, a few short questions to consider

  1.  Do the proposed ECN fields look OK ?
  2.  ECN in dedicated ACK frame, is this OK ?
     *   If yes, should the timestamps be baked in the same ACK frame
  3.  ECN capability exchange already at connection setup, for or against ?
  4.  Is it time to add this to the QUIC transport draft ?

/Ingemar

From: Ingemar Johansson S
Sent: den 13 november 2017 10:42
To: QUIC WG <[email-masked]>
Cc: [email-masked]' <[email-masked]>; [email-masked]' <[email-masked]>; Bob Briscoe ([email-masked]) <[email-masked]>; 'Mirja Kuehlewind (IETF)' <[email-masked]>; Ian Swett <[email-masked]>; [email-masked]' <[email-masked]>; Jana Iyengar ([email-masked]) <[email-masked]>; Christian Huitema <[email-masked]>; De Schepper, Koen (Koen) <[email-masked]>; Marcus Ihlar <[email-masked]>
Subject: ECN in QUIC side meeting

Hi

/Ingemar

Ericsson Research

---

From: Ingemar Johansson S <[email-masked]>
Date: Mon, 13 Nov 2017 10:53:42 +0000

Hi

The Hullet room is now booked for this meeting.

/Ingemar

From: Ingemar Johansson S [mailto:[email-masked]]
Sent: den 13 november 2017 18:29
To: QUIC WG <[email-masked]>
Subject: RE: ECN in QUIC side meeting

Hi

  1.  ECN capability exchange already at connection setup, for or against ?
  2.  Is it time to add this to the QUIC transport draft ?

/Ingemar

From: Ingemar Johansson S
Sent: den 13 november 2017 10:42
To: QUIC WG <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]' <[email-masked]<mailto:[email-masked]>>; [email-masked]' <[email-masked]<mailto:[email-masked]>>; Bob Briscoe ([email-masked]<mailto:[email-masked]>) <[email-masked]<mailto:[email-masked]>>; 'Mirja Kuehlewind (IETF)' <[email-masked]<mailto:[email-masked]>>; Ian Swett <[email-masked]<mailto:[email-masked]>>; [email-masked]' <[email-masked]<mailto:[email-masked]>>; Jana Iyengar ([email-masked]<mailto:[email-masked]>) <[email-masked]<mailto:[email-masked]>>; Christian Huitema <[email-masked]<mailto:[email-masked]>>; De Schepper, Koen (Koen) <[email-masked]<mailto:[email-masked]>>; Marcus Ihlar <[email-masked]<mailto:[email-masked]>>
Subject: ECN in QUIC side meeting

Hi

/Ingemar

Ericsson Research