Subject: Re: I-D Action: draft-ietf-quic-manageability-01.txt

From: "Brian Trammell (IETF)" <[email-masked]>
Date: Wed, 1 Nov 2017 15:15:07 +0000

> On 26 Oct 2017, at 13:38, Philipp S. Tiesel <[email-masked]> wrote:
> 
> Hi,
> 
> I really like the listing of which information QUIC exposes.
> I have just one little question about it: Should Section 3 also state which information is exposed my the integrated TLS handshake?

Yes, it should.

> AFAIK, the TLS handshake exposes the application protocol and host name in clear.

As I understand it, TLS1.3 should fix this.

> I am not sure whether it also exposes the initial QUIC connection parameters in clear.

As I read it, the cleartext packets only contain the TLS1.3 handshake.

Cheers,

Brian

> AVE!
>   Philipp S. Tiesel / phils…
> 
>> On 25. Oct 2017, at 10:11, [email-masked] wrote:
>> 
>> 
>> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>> This draft is a work item of the QUIC WG of the IETF.
>> 
>>        Title           : Manageability of the QUIC Transport Protocol
>>        Authors         : Mirja Kuehlewind
>>                          Brian Trammell
>> 	Filename        : draft-ietf-quic-manageability-01.txt
>> 	Pages           : 13
>> 	Date            : 2017-10-25
>> 
>> Abstract:
>>   This document discusses manageability of the QUIC transport protocol,
>>   focusing on caveats impacting network operations involving QUIC
>>   traffic.  Its intended audience is network operators, as well as
>>   content providers that rely on the use of QUIC-aware middleboxes,
>>   e.g. for load balancing.
>> 
>> 
>> The IETF datatracker status page for this draft is:
>> https://datatracker.ietf.org/doc/draft-ietf-quic-manageability/
>> 
>> There are also htmlized versions available at:
>> https://tools.ietf.org/html/draft-ietf-quic-manageability-01
>> https://datatracker.ietf.org/doc/html/draft-ietf-quic-manageability-01
>> 
>> A diff from the previous version is available at:
>> https://www.ietf.org/rfcdiff?url2=draft-ietf-quic-manageability-01
>> 
>> 
>> Please note that it may take a couple of minutes from the time of submission
>> until the htmlized version and diff are available at tools.ietf.org.
>> 
>> Internet-Drafts are also available by anonymous FTP at:
>> ftp://ftp.ietf.org/internet-drafts/
>> 
>> 
> 
>

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 1 Nov 2017 08:25:46 -0700

On Wed, Nov 1, 2017 at 8:15 AM, Brian Trammell (IETF) <[email-masked]>
wrote:

> > I have just one little question about it: Should Section 3 also state
> which information is exposed my the integrated TLS handshake?
>
> Yes, it should.
>

Not at present, though we are working on it for the future.

-Ekr

---

From: "Brian Trammell (IETF)" <[email-masked]>
Date: Wed, 1 Nov 2017 15:27:42 +0000

hi Ekr,

> On 1 Nov 2017, at 15:25, Eric Rescorla <[email-masked]> wrote:
> 
> 
> 
> On Wed, Nov 1, 2017 at 8:15 AM, Brian Trammell (IETF) <[email-masked]> wrote:
> 

Thanks for the correction. I'll add this to the set of exposed information for QUIC at present in the working copy of the draft, then.

Cheers,

Brian

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 1 Nov 2017 15:28:56 +0000

➢ > AFAIK, the TLS handshake exposes the application protocol and host name in clear.
    
➢     As I understand it, TLS1.3 should fix this.
    
ALPN (application protocol) is in cleartext. The SNI (server name) extension is also in cleartext, but there is some work starting (https://tools.ietf.org/html/draft-ietf-tls-sni-encryption-00) to address this.

---

From: "Brian Trammell (IETF)" <[email-masked]>
Date: Wed, 1 Nov 2017 15:41:45 +0000

Proposed addition to the draft at https://github.com/quicwg/ops-drafts/pull/21

> On 1 Nov 2017, at 15:27, Brian Trammell (IETF) <[email-masked]> wrote:
> 
> hi Ekr,
>