Subject: Re: spin bit in QUIC: troubleshooting

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Wed, 15 Nov 2017 01:35:19 +0000

That’s a good point. I really think the balance should be achieved between privacy and operation. Spin bit is a good example. I support it.

BR,
Rachel

发件人: QUIC [mailto:[email-masked]] 代表 DRUTA, DAN
发送时间: 2017年11月15日 9:11
收件人: Ian Swett <[email-masked]>
抄送: QUIC WG <[email-masked]>; [email-masked]
主题: Re: spin bit in QUIC: troubleshooting

I will add my support for the inclusion of the spin bit into V1 and make a few more points.
Considering that the design team analysis concluded that the spin bit does not add any additional privacy risk and the very specific need addressing latency has been documented and validated by a large number of WG members, I believe the QUIC working group has a unique opportunity to show that we can design protocols that are efficient, privacy sensitive and network management friendly.
This particular design, while not perfect does have the biggest benefit relative to the risks and it should be adopted from the beginning.
Best Regards,
Dan

On Nov 15, 2017, at 5:21 AM, Ian Swett <[email-masked]<mailto:[email-masked]>> wrote:
Thanks for clarifying Emile.

On Tue, Nov 14, 2017 at 1:06 PM, <[email-masked]<mailto:[email-masked]>> wrote:
Hi Ian,

It was suggested in the latest discussion on the RTT design team mailing list to have one bit for packet lost, one for latency (spin bit or eq.) and one for congestion.
It seems a simplistic approach on one hand but an invariant on the long term.

Regards
Emile

De : Ian Swett [mailto:[email-masked]<mailto:[email-masked]>]
Envoyé : mardi 14 novembre 2017 22:51
À : STEPHAN Emile IMT/OLN
Cc : QUIC WG
Objet : Re: spin bit in QUIC: troubleshooting

What would the other bit or two be used for?  If there is no standardized use of those bits in v1, then I believe we should wait to reserve them when their usage is defined, given we'd need a version bump to specify how they were being used.  At the moment, the management use case is not competing with anyone else for bits in the short header.

On Tue, Nov 14, 2017 at 5:14 AM, <[email-masked]<mailto:[email-masked]>> wrote:
Hi

Last week Orange experienced a fallback of QUIC to TCP on one of its networks. The issues were not visible in QUIC traffic. The troubleshooting was made using TCP packets information. This is not sustainable on the long term when numerous applications using different versions of QUIC will stop to fallback to TCP.

Based on the exchange we had in the RTT design team and in today meeting , it sounds reasonable to reserve at least 2 bits (ideally 3 bits as discussed in the design team) for manageability in the QUIC invariants and to start experimenting the spin bit in QUIC V1.

Regards
Emile

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc

pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler

a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,

Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;

they should not be distributed, used or copied without authorisation.

If you have received this email in error, please notify the sender and delete this message and its attachments.

As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.

Thank you.

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc

pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler

a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,

Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;

they should not be distributed, used or copied without authorisation.

If you have received this email in error, please notify the sender and delete this message and its attachments.

As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.

Thank you.

---

From: "Diego R. Lopez" <[email-masked]>
Date: Wed, 15 Nov 2017 01:46:26 +0000

Not to forget the possibility of open, independent measurements, supporting research data collection…

So yes, support.

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]<mailto:[email-masked]>
Tel:        +34 913 129 041
Mobile: +34 682 051 091
-----------------------------------

On 15/11/17 9:36, "QUIC en nombre de Huangyihong (Rachel)" <[email-masked]<mailto:[email-masked]> en nombre de [email-masked]<mailto:[email-masked]>> wrote:

BR,
Rachel

Regards
Emile

Regards
Emile

Thank you.

Thank you.

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: Fioccola Giuseppe <[email-masked]>
Date: Wed, 15 Nov 2017 02:54:44 +0000

Hi All,
I support the inclusion of the spin bit into V1. My suggestion is to have one bit for packet loss, one for latency and one for congestion. I would also mention draft-ietf-ippm-alt-mark that details how to use one bit or two bits for packet loss and latency calculation.

Best Regards,

Giuseppe

Da: QUIC [mailto:[email-masked]] Per conto di Huangyihong (Rachel)
Inviato: mercoledì 15 novembre 2017 02:35
A: DRUTA, DAN; Ian Swett
Cc: QUIC WG; [email-masked]
Oggetto: Re: spin bit in QUIC: troubleshooting

BR,
Rachel

发件人: QUIC [mailto:[email-masked]] 代表 DRUTA, DAN
发送时间: 2017年11月15日 9:11
收件人: Ian Swett <[email-masked]<mailto:[email-masked]>>
抄送: QUIC WG <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
主题: Re: spin bit in QUIC: troubleshooting

Regards
Emile

Regards
Emile

Thank you.

Thank you.

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie. 

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks. 

Rispetta l'ambiente. Non stampare questa mail se non è necessario.

---

From: Liang GENG <[email-masked]>
Date: Wed, 15 Nov 2017 08:15:34 +0000

Hi all,

I also support the inclusion of the spin bit. As network is going to be equipped with more diversified dedication (much finer granularity , i.e. slicing), monitoring and measurement will be even more essential for maintain various type of guarantees (latency, bandwidth, deterministic etc.). Spin bit is a not-to-miss feature for Quic itself to fit in this near-future evolution.

Best wishes
Liang

________________________________
Liang GENG
China Mobile Research Institute

From: Fioccola Giuseppe<mailto:[email-masked]>
Date: 2017-11-15 10:54
To: Huangyihong (Rachel)<mailto:[email-masked]>; DRUTA, DAN<mailto:[email-masked]>; Ian Swett<mailto:[email-masked]>; QUIC WG<mailto:[email-masked]>
CC: [email-masked]<mailto:[email-masked]>
Subject: R: spin bit in QUIC: troubleshooting
Hi All,
I support the inclusion of the spin bit into V1. My suggestion is to have one bit for packet loss, one for latency and one for congestion. I would also mention draft-ietf-ippm-alt-mark that details how to use one bit or two bits for packet loss and latency calculation.

Best Regards,

Giuseppe

BR,
Rachel

Regards
Emile

Regards
Emile

Thank you.

Thank you.