Subject: FW: [IANA #409959] General Request for Assignments

From: Bernard Aboba <[email-masked]>
Date: Fri, 11 Feb 2011 13:48:34 -0800

Can someone answer the following questions?

1. What is different between WiMAX WiFi and normal IEEE 802.11?  We already
have a number of IEEE 802.11 NAS-Port-types allocated and have proposed
additional data for this. 

2. Why do DHCP and a location service need NAS-Port-Type values?  

3. Why should we just allocate a generic WiMAX NAS-Port and let additional
data be included in a WiMAX Forum VSA? 

On Fri Nov 26 15:45:24 2010, [email-masked] wrote:
> Contact Name :
> Avi Lior
> 
> Contact Email :
> [email-masked]
> 
> Type of Assignment :
> Seeing new Nas-Port-Type values as follows:
> TBD for WIMAX-3GPP-PRIF:
>    WiMAX Pre-Release 8 IWK Function
> TBD for WIMAX-WIFI-IWK:  WiMAX
>    WIFI Interworking
> TBD for WIMAX-SFF: Signaling Forwarding Function
>    for LTE/3GPP2.
> TBD for WIMAX-HA-LMA:  WiMAX HA and or LMA
>    function.
> TBD for WIMAX-DHCP : WIMAX DCHP service
> TBD for WIMAX-
>    LBS  : WiMAX location based service
> TBD for WIMAX-WVS : WiMAX
>    voice service
> 
> Registry :
> NAS-Port-Type (attribute 61) from RADIUS Type Registry
> 
> Description :
> These assignments will allow the RADIUS server to determine the
>    service context of the access-request.  For example whether the
>    RADIUS message is coming from a Signalling Forwarding Function(SFF)
>    or WiMAX voice function etc.
> 
> Additional Info :
> Reference specifications are avaialble from WiMAX Forum at the
>    following site:
> http://www.wimaxforum.org/
>

---

From: Alan DeKok <[email-masked]>
Date: Sat, 12 Feb 2011 08:59:26 +0100

Bernard Aboba wrote:
> *3. Why should we just allocate a generic WiMAX NAS-Port and let
> additional data be included in a WiMAX Forum VSA? *

  I'm of two minds about this.  Subclassing the NAS-Port-Type by
requiring SDOs to add their own "WiMAX-NAS-Port-Type" attribute seems
inefficient.

  That being said, there's already a WiMAX-Transport-Type attribute
define.  So adding WiMAX-NAS-Port-Type might not be out of the realm of
possibility.

  Still, there are nearly 2^32 unallocated values for NAS-Port-Type.  I
think the only reason not to assign these values is for consistency, not
efficiency.

  Alan DeKok.

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://psg.com/lists/radiusext/>