Subject: Consensus poll for IANA #409959 NAS-Port-Type value request

From: "Sanchez, Mauricio (HP Networking)" <[email-masked]>
Date: Fri, 8 Apr 2011 18:30:56 +0000

During IETF 80 one of the agenda topics discussed was whether to approve a request received by IANA for allocation of additional NAS-port-type values relating to Wimax as described below

Type of Assignment :
Nas-Port-Type values as follows:
TBD for WIMAX-3GPP-PRIF:  WiMAX Pre-Release 8 IWK Function
TBD for WIMAX-WIFI-IWK:  WiMAX   WIFI Interworking
TBD for WIMAX-SFF: Signaling Forwarding Function  for LTE/3GPP2.
TBD for WIMAX-HA-LMA:  WiMAX HA and or LMA   function.
TBD for WIMAX-DHCP : WIMAX DCHP service
TBD for WIMAX- LBS  : WiMAX location based service
TBD for WIMAX-WVS : WiMAX  voice service

The snippet of meeting notes relating to this topic are show below:

---- <meeting note snippet begin>---------------------------

Request for registration for NAS-port-type.  Under 3575, falls under expert review.  This request is for NAS-port-type relating to WiMax
- Stefan comments that there's already type for WiFi so not sure why another one is needed, just one.
- Klaas comments that agrees with Stefan's comments.
- Nancy comments that looking at the current assignment is that there is only 1 allocation per mode.
- Bernard takes the general comment of only allocating one as the response to take back to the request.  Given consensus here, will verify that opinion in the reflector.

---- <meeting note snippet end>---------------------------

The sentiment in the room was clearly against approving this IANA request and at this time we would like to confirm this on the mailing list.

Please respond to this email and state whether you are in favor or against approving this IANA request.

Thanks,
MS

---

From: "Alper Yegin" <[email-masked]>
Date: Sun, 10 Apr 2011 23:41:12 +0300

Hello,

Avi had sent an email explaining how this is not same as regular WiFi
access. Please see the attachment for his email.

Neither Avi nor I was at the meeting to re-iterate these points. Hopefully
this explanation is sufficient. If not, let us know.

Alper

From: [email-masked] [mailto:[email-masked]] On
Behalf Of Sanchez, Mauricio (HP Networking)
Sent: Friday, April 08, 2011 9:31 PM
To: [email-masked]'
Subject: Consensus poll for IANA #409959 NAS-Port-Type value request

During IETF 80 one of the agenda topics discussed was whether to approve a
request received by IANA for allocation of additional NAS-port-type values
relating to Wimax as described below 

Type of Assignment :

Request for registration for NAS-port-type.  Under 3575, falls under expert
review.  This request is for NAS-port-type relating to WiMax

- Stefan comments that there's already type for WiFi so not sure why another
one is needed, just one.

- Nancy comments that looking at the current assignment is that there is
only 1 allocation per mode.

- Bernard takes the general comment of only allocating one as the response
to take back to the request.  Given consensus here, will verify that opinion
in the reflector.

The sentiment in the room was clearly against approving this IANA request
and at this time we would like to confirm this on the mailing list.  

Please respond to this email and state whether you are in favor or against
approving this IANA request.  

Thanks,

MS 

Subject: [IANA #409959] Genreral Request for Assignements
From: "Avi Lior" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>, "Alper Yegin" <[email-masked]>
Date: Tue, 15 Mar 2011 20:39:35 +0300

 Hi Bernard,

Thank you for the review of the NAS-Port-Type IANA request for assignment.
In a previous email you were seeking answers to the following questions:
Bernard wrote:

Can someone answer the following questions?

1. What is different between WiMAX WiFi and normal IEEE 802.11?  We already
have a number of IEEE 802.11 NAS-Port-types allocated and have proposed
additional data for this.

2. Why do DHCP and a location service need NAS-Port-Type values? 

3. Why should we just allocate a generic WiMAX NAS-Port and let additional
data be included in a WiMAX Forum VSA?

The general answer to your question is as follows:

For a given session, the WIMAX AAA Server interacts with many different
WiMAX network elements and also non-WiMAX network elements.  The approach
taken by WiMAX is to have an explicit indication from the NAS as to the
context of the RADIUS access-request.  The NAS-Port-Type is viewed as the
attribute to provide that information.

WRT 1) the WiMAX AAA needs to be able to differentiate between a normal WiFi
Access and a WiMAX NAS which is an a WiFI-WiMAX IWK NAS which has additional
behaviours over and above the "normal" wifi AP.  T

WRT 2) Again, WiMAX AAA needs to differentiate between the request from both
these entities because the AAA behaviour is different when request comes
from  a DHCP server vs., a Location Based Server.

WRT 3)  WiMAX would just be inventing our own NAS-Port-Type attribute.  We
thought the idea is that we reuse attributes when we can. Since there
doesn't seem to be a lack of number space associated with NAS-Port-Type
there doesn't seem to be a reason to invent our own attribute.

-- Avi Lior
--Bridgewater Systems

---

From: Stefan Winter <[email-masked]>
Date: Mon, 11 Apr 2011 07:51:05 +0200

Hi,
 
> Neither Avi nor I was at the meeting to re-iterate these points.
> Hopefully this explanation is sufficient. If not, let us know.
>
>

I for one didn't get the difference between normal WiFi and
WiMAX-Wifi-IWK. The email sounded like WiMAX is doing WiFi+additional
things, i.e. a "profile" of WiFi.

The argument in the meeting was: is the stuff that WiMAX-Wifi is doing
conformant to IEEE 802.11? If yes, it *is* WiFi and there's a
NAS-Port-Type allocation for it already.

If it is *not* conforming to IEEE 802.11, then maybe it needs a new
NAS-Port-Type.

Greetings,

Stefan Winter

-- 
Stefan WINTER
Ingenieur de Recherche
Fondation RESTENA - Réseau Téléinformatique de l'Education Nationale et de la Recherche
6, rue Richard Coudenhove-Kalergi
L-1359 Luxembourg

Tel: +352 424409 1
Fax: +352 422473

---

From: Avi Lior <[email-masked]>
Date: Mon, 11 Apr 2011 06:24:37 -0400

Regarding the below comments:
- Stefan comments that there’s already type for WiFi so not sure why another one is needed, just one.
- Klaas comments that agrees with Stefan’s comments.
- Nancy comments that looking at the current assignment is that there is only 1 allocation per mode.

Maybe it wasn't made clear why WiMAX requires these assignment. An email was sent recently and also this was discussed previously on the RADEXT reflector (See Nov. 2009).

Briefly:

The AAA in WiMAX is responsible to interact with various types of WiMAX NASes and also non-WiMAX NASes:  The AAA thus needs to be able to determine which type of NAS it communicates with to determine the context of the Access-Request.  WiMAX decided that it want an explicit indication of the type of NAS and hence wants to use the NAS-Port-Type to determine the context of the call.

The question is whether or not the NAS-Port-Type is the attribute to be used for that.  The answer seems to be yes.

Second, the objection also seems to be based the number being requested.  Is there a shortage of numbers?  I don't think so.  This was also discussed by the group in the past.

-- Avi Lior
--Bridgewater Systems

On 08-04-11 14:30 , "Sanchez, Mauricio (HP Networking)" <[email-masked]<mailto:[email-masked]>> wrote:

Type of Assignment :

Request for registration for NAS-port-type.  Under 3575, falls under expert review.  This request is for NAS-port-type relating to WiMax
- Stefan comments that there’s already type for WiFi so not sure why another one is needed, just one.
- Klaas comments that agrees with Stefan’s comments.
- Nancy comments that looking at the current assignment is that there is only 1 allocation per mode.
- Bernard takes the general comment of only allocating one as the response to take back to the request.  Given consensus here, will verify that opinion in the reflector.

Thanks,
MS