Subject: [radext] WG Action: Conclusion of RADIUS EXTensions (radext)

From: IESG Secretary <[email-masked]>
Date: Wed, 23 Mar 2022 06:11:50 -0700

The RADIUS EXTensions (radext) WG in the Operations and Management Area 
has concluded. The IESG contact persons are Benjamin Kaduk, Warren 
Kumari, and Robert Wilton.

RADEXT has achieved a substantial amount of work, successfully 
completing all chartered work for which sufficient energy existed to
advance a solution document. The mailing list will remain open for 
discussion of RADIUS-related topics, with the expectation that specific 
concrete work items will typically be directed OPSAWG for processing.

Should a community of interest arise to republish the core RADIUS
specifications on the standards track, RADEXT might be reopened after
a new chartering process to confirm the scope of and interest in the 
proposed work.

---

From: Alan DeKok <[email-masked]>
Date: Wed, 23 Mar 2022 09:14:51 -0400

Uh.... what?

> On Mar 23, 2022, at 9:11 AM, IESG Secretary <[email-masked]> wrote:
> 
> _______________________________________________
> radext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/radext

---

From: <[email-masked]>
Date: Wed, 23 Mar 2022 13:18:59 +0000

Hi all, 

I'm also surprised by this as I was expecting a follow-up to the thread: https://mailarchive.ietf.org/arch/msg/radext/_FtimLquGVY8e_EL6qSvCm15PFw/

Cheers,
Med

> -----Message d'origine-----
> De : radext <[email-masked]> De la part de Alan DeKok
> Envoyé : mercredi 23 mars 2022 14:15
> À : [email-masked]
> Objet : Re: [radext] WG Action: Conclusion of RADIUS EXTensions (radext)
> 
>   Uh.... what?
> 
> > The RADIUS EXTensions (radext) WG in the Operations and Management
> > Area has concluded. The IESG contact persons are Benjamin Kaduk,
> > Warren Kumari, and Robert Wilton.
> >
> > discussion of RADIUS-related topics, with the expectation that
> > specific concrete work items will typically be directed OPSAWG for
> processing.
> >

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Benjamin Kaduk <[email-masked]>
Date: Wed, 23 Mar 2022 06:24:20 -0700

I'd like to reiterate that this is a success story and we've done good
work.

I do see in the thread at
https://mailarchive.ietf.org/arch/msg/radext/_FtimLquGVY8e_EL6qSvCm15PFw/
that there is interest in seeing work like standardizing 6613/6614, and I
agree that that would be a good thing to do.  But there was a lot more
"this is a good thing to do" than "I am willing to work on it", and given
the recent history of the WG, the IESG is going to need to see a clear plan
for how that will happen.  The right way to demostrate that plan and the
community to make it happen is to get a fresh charter approved through a
new chartering process.  I am confident that treating it as a new
chartering process will more accurately reflect reality than trying to do
it as a recharter of the group that's been stagnant recently.

If we want to start that chartering process right now, that would actually
be a good thing!  But I think that we should acknowledge the reality that
there is not much of a current WG to recharter, and effectively this would
be a fresh chartering effort.

Thanks again for all the good work,

Ben

---

From: <[email-masked]>
Date: Wed, 23 Mar 2022 13:25:23 +0000

Hi,

In my understanding, no one has challenged the proposal to close of the WG and to work on the remaining issues inside OPSAWG.

Regards,

Lionel

Orange Restricted

> De : radext <[email-masked]> De la part de
> [email-masked]
> Envoyé : mercredi 23 mars 2022 14:19
> À : Alan DeKok <[email-masked]>; [email-masked]
> I'm also surprised by this as I was expecting a follow-up to the thread:
> > De : radext <[email-masked]> De la part de Alan DeKok Envoyé
> > : mercredi 23 mars 2022 14:15 À : [email-masked] Objet : Re: [radext]
> > WG Action: Conclusion of RADIUS EXTensions (radext)
> >
> >   Uh.... what?
> >
> > > On Mar 23, 2022, at 9:11 AM, IESG Secretary
> > > <[email-masked]>
> > wrote:
> > >
> > > specifications on the standards track, RADEXT might be reopened
> > > after a new chartering process to confirm the scope of and interest
> > > in the proposed work.
> > >
> ______________________________________________________________________
> ___________________________________________________
> 
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou
> copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le
> signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si
> ce message a ete altere, deforme ou falsifie. Merci.
> 
> This message and its attachments may contain confidential or privileged
> information that may be protected by law; they should not be distributed, used or
> copied without authorisation.

---

From: <[email-masked]>
Date: Wed, 23 Mar 2022 13:32:06 +0000

Re-,

The reality is none of the recent extensions I'm aware of (which are btw straightforward as they follow the radext guidelines) were published in opsawg. I don't expect that to change, which is unfortunate from a protocol maintenance perspective.

Cheers,
Med

> De : MORAND Lionel INNOV/NET <[email-masked]>
> Envoyé : mercredi 23 mars 2022 14:25
> À : BOUCADAIR Mohamed INNOV/NET <[email-masked]>; Alan
> DeKok <[email-masked]>; [email-masked]
> Objet : RE: [radext] WG Action: Conclusion of RADIUS EXTensions (radext)
> 
> Hi,
> 
> In my understanding, no one has challenged the proposal to close of the
> WG and to work on the remaining issues inside OPSAWG.
> 
> Regards,
> 
> Lionel
> 
> 
> Orange Restricted
> 
> > [email-masked] Envoyé : mercredi 23 mars 2022 14:19 À :
> > Alan DeKok <[email-masked]>; [email-masked] Objet : Re:
> > [radext] WG Action: Conclusion of RADIUS EXTensions (radext)
> >
> > Hi all,
> >
> > > Envoyé
> > > : mercredi 23 mars 2022 14:15 À : [email-masked] Objet : Re:
> > > [radext] WG Action: Conclusion of RADIUS EXTensions (radext)
> > >
> > >   Uh.... what?
> > >
> > > > completing all chartered work for which sufficient energy existed
> > > > to advance a solution document. The mailing list will remain open
> > > > for discussion of RADIUS-related topics, with the expectation that
> > > > after a new chartering process to confirm the scope of and
> > > > interest in the proposed work.
> > > >
> > confidentielles ou privilegiees et ne doivent donc pas etre diffuses,
> > exploites ou copies sans autorisation. Si vous avez recu ce message
> > par erreur, veuillez le signaler a l'expediteur et le detruire ainsi
> > que les pieces jointes. Les messages electroniques etant susceptibles
> > d'alteration, Orange decline toute responsabilite si ce message a ete
> altere, deforme ou falsifie. Merci.
> >
> > This message and its attachments may contain confidential or
> > privileged information that may be protected by law; they should not
> > be distributed, used or copied without authorisation.

---

From: Alan DeKok <[email-masked]>
Date: Wed, 23 Mar 2022 11:08:19 -0400

> In my understanding, no one has challenged the proposal to close of the WG and to work on the remaining issues inside OPSAWG.

  I'm in favour of moving forwards.  My understanding from the list thread was that there were multiple people interested in keeping RADEXT alive.  Which is why the decision to close it was a surprise.

  I'm happy to move forward with whatever means is useful.  If there are many people willing to participate, then it seems reasonable to keep RADEXT alive.

  My issue with OPSAWG is that it doesn't seem to make much more progress than RADEXT.  And while OPSAWG is "officially" the place for general things, there is a very strong bias there for items which are known to active participants  As Mohamed has pointed out, attempts to bring up other subjects are resoundingly ignored.

  Which means that in practice, it's essentially impossible to get RADIUS work done in OPSAWG.

  Alan DeKok.

---

From: Jan-Frederik Rieckers <[email-masked]>
Date: Thu, 24 Mar 2022 15:01:07 +0100

Hi to all,

as a relatively new IETF attendee, I don't yet fully understand how the 
different working groups work, so I'm not yet entirely sure what the 
impact of moving this work to OPSAWG is.

However, as operator of the eduroam Federation Proxy for Germany running 
almost exclusively RADIUS over TLS for connecting the different 
entities, I'd also be happy to see especially RFC6614 as a standard and 
would be happy to help with that.

Greetings

Janfred

-- 
E-Mail: [email-masked] | Fon: +49 30884299-339 | Fax: +49 30884299-370
Pronomen: er/sein | Pronouns: he/him
__________________________________________________________________________________

DFN - Deutsches Forschungsnetz | German National Research and Education 
Network
Verein zur Förderung eines Deutschen Forschungsnetzes e.V.
Alexanderplatz 1 | 10178 Berlin
www.dfn.de

Vorstand: Prof. Dr. Odej Kao (Vorsitzender) | Dr. Rainer Bockholt | 
Christian Zens
Geschäftsführung: Dr. Christian Grimm | Jochem Pattloch
VR AG Charlottenburg 7729B | USt.-ID. DE 1366/23822

---

From: Bernard Aboba <[email-masked]>
Date: Thu, 24 Mar 2022 10:57:16 -0400

Closing the RADEXT WG is just recognizing what has already occurred.  The
WG was no longer making progress on critical work items, such as completing
the process described in RFC 6421 (securing RADIUS).

I don't think that the RFC 6421 process can be completed in OPSAWG either.
To do this successfully will require focus and bringing together
implementers, certification groups (such as WFA) and possibly government
agencies (e.g. NIST).

 It would probably make sense to create a highly focused charter focussed
on standardizing the Experimental protocols developed so far within the RFC
6421 process. It might also make sense to formally deprecate RADIUS as part
of that work.

---

From: <[email-masked]>
Date: Thu, 24 Mar 2022 18:31:44 +0000

I agree.

Regards,

Lionel

Le 24 mars 2022 15:57, Bernard Aboba <[email-masked]> a écrit :
Closing the RADEXT WG is just recognizing what has already occurred.  The WG was no longer making progress on critical work items, such as completing the process described in RFC 6421 (securing RADIUS).

I don't think that the RFC 6421 process can be completed in OPSAWG either.  To do this successfully will require focus and bringing together implementers, certification groups (such as WFA) and possibly government agencies (e.g. NIST).

 It would probably make sense to create a highly focused charter focussed on standardizing the Experimental protocols developed so far within the RFC 6421 process. It might also make sense to formally deprecate RADIUS as part of that work.

On Thu, Mar 24, 2022 at 10:28 AM Jan-Frederik Rieckers <[email-masked]<mailto:[email-masked]>> wrote:
Hi to all,

Greetings

Janfred

--
E-Mail: [email-masked]<mailto:[email-masked]> | Fon: +49 30884299-339 | Fax: +49 30884299-370
Pronomen: er/sein | Pronouns: he/him
__________________________________________________________________________________

DFN - Deutsches Forschungsnetz | German National Research and Education
Network
Verein zur Förderung eines Deutschen Forschungsnetzes e.V.
Alexanderplatz 1 | 10178 Berlin
www.dfn.de<http://www.dfn.de>

_______________________________________________
radext mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/radext