Subject: Re: (radius) Closing loopholes

From: William "Chops" Westfield <[email-masked]>
Date: Mon, 1 Mar 99 14:42:10 PST

I suppose our thorniest incompatibilities have shown up when trying to
map our (non-flat) interface naming scheme into the puny 16 bits that the
radius spec allows for NAS-Port.  Aside from being difficult to start with,
there is no standard and little agreement on how to do this, even supposing
that everyone has flat numbering of T1lines and channels therein...  Throw
in another address space (most recently, PPP over ATM) and it becomes next
to impossible...
	1) Guidelines in this area would help
	2)) 32 bits would help more
	3) A string would be even nicer

BillW
-
To unsubscribe, email [email-masked]' with
'unsubscribe ietf-radius' in the body of the message.

---

From: Bill Webb <[email-masked]>
Date: Mon, 01 Mar 1999 15:04:58 -0800

>         3) A string would be even nicer

Yes, having a NAS-Portname string Attribute would be a big win rather
than attempting to contort existing naming structures into 16 bits or
even 32-bits. 

One can then leave NAS-port for programs that require a integer value,
and use NAS-portname when attempting to reconcile accounting records
with syslog or with whatever the command line or SNMP reports for the
name of the port.

Another Bill W (Bill Webb this time).
Ascend Communications (but speaking on my own behalf).
-
To unsubscribe, email [email-masked]' with
'unsubscribe ietf-radius' in the body of the message.