Subject: FW: (radius) Re: Globally unique NAS-Identifier (was: Matching N AS-IP-Address to a ctual real-life NAS IP address)

From: "Nelson, David" <[email-masked]>
Date: Thu, 25 Feb 1999 12:55:34 -0500

Dale Reed writes...
  
> I think you are missing what he is asking, though.  He's not asking
> about the secret (key), he is asking about a what to define a primary
> key constraint in an RDBMS.

Well, I don't think I did misunderstand the topic.  Here's Alan's
original question:

	Under what circumstances can a RADIUS client put a 
	NAS-IP-Address attribute inside of a packet, which is
	different than the IP address from which the packet is
	sent?

I understand that the topic has wandered somewhat along the way.

>  For accounting purposes we use the following combination:
> 
> NAS-Identifier (either NAS-IP-Address or NAS-Identifier)
> Acct-Session-ID
> Acct-Status-Type
> 
> You can add in NAS-Port and User-Name if you need to make the key more
> dense, though.

Your suggestions are certainly relevant to featureful, robust RADIUS
server design and implementation.  I wonder, however, if they have
direct bearing on the RADIUS protocol definition, which is the fodder
of this WG.

Regards,

Dave

David B. Nelson                          Cabletron Systems, Inc.
Software Engineer V                      50 Minuteman Road
(978) 684-1330                           Andover, MA 01810

-
To unsubscribe, email [email-masked]' with
'unsubscribe ietf-radius' in the body of the message.

---

From: Carl Rigney <[email-masked]>
Date: Thu, 25 Feb 1999 11:22:52 -0800 (PST)

I agree that the RADIUS protocol doesn't care about what's used as a key into
the accounting database.  Once its delivered the accounting information; it no
longer cares what happens to it. :-)

--
Carl
-