Subject: RE: (radius) NAS-Port-Id and Framed-IP-Pool

From: "Mun, Mike" <[email-masked]>
Date: Wed, 3 Mar 1999 10:05:26 -0500

From AS server's point of view, I think Framed-IP-Pool should be an integer
value: 
0	NAS pool available
1	NAS pool only
If this attribute is not present, then NAS pool is not available.
Mike

	----------
	From:  Steven P. Crain [SMTP:[email-masked]]
	Sent:  Tuesday, March 02, 1999 3:40 PM
	To:  Nelson, David
	Cc:  'Dave Mitton'; [email-masked]'
	Subject:  RE: (radius) NAS-Port-Id and Framed-IP-Pool

	On Tue, 2 Mar 1999, Nelson, David wrote:

	> Of course, I've always been left a little unsatisfied by the "some

	> mechanism outside the scope of RADIUS" business.  It doesn't do
much to
	> promote interoperability.  However, since we have already cast the
die
	> in terms of the Filter-ID usage, I guess Framed-IP-Pool would be
OK on
	> that basis.

	Maybe we should call it Framed-IP-Pool-ID for consistency.

	-- 
	Steven P. Crain, Development
	http://www.shore.net/~scrain
	Shore.Net: Local Ties... World Class Connections

	-
	To unsubscribe, email [email-masked]' with
	'unsubscribe ietf-radius' in the body of the message.

---

From: Dave Mitton <[email-masked]>
Date: Wed, 03 Mar 1999 10:41:57 -0500

That's silly.

From the server's point of view, you should know if you configured an IP
pool on that NAS and provision the use of it accordingly.  If there is no
pool, then ignore it.

If you need some help in remembering such things, your server
implementation can certainly organize it's data internally.  Many of the
leading RADIUS servers now have internal "attributes" which are used to
trigger appropriate behaviors.  The NAS never sees them on the wire.

The semantics of Framed-IP-Address already allow for the NAS to assign an
address given the magic value of 255.255.255.254.  Your proposal is redundant.

Adding another attribute just allows the Server to select from multiple
potential pools.
I would even go so far as to say that it could be used in a DHCP request
from the NAS, to a DHCP server that uses "Class" arguments for address
selection.

	Dave.

At 10:05 AM 3/3/99 -0500, Mun, Mike wrote:
>Attachment Converted: "L:\Eudora\attachments\RE (radius) NAS-Port-Id and Fr1"
>
---------------------------------------------------------------
David Mitton			  		ESN: 248-4570
Consulting Engineer, Nortel Networks	978-916-4570 Direct
Carrier Packet Solutions, I&SP Netwks	978-916-4789 FAX
Billerica, MA 01821				[email-masked]
-
To unsubscribe, email [email-masked]' with
'unsubscribe ietf-radius' in the body of the message.