Subject: SPPI PIB-ACCESS clause

From: "Andreas Polyrakis" <[email-masked]>
Date: Tue, 6 Mar 2001 18:40:07 -0500

Hello,

I need some clarifications about the PIB-ACCESS clause:
I understand that "notify" and "install-notify" PRCs are sent to the
PDP through REQ messages, and "report-only" through RPT messages.

But what triggers an unsolicited RPT message (apart from a failure RPT, or
an RPT that reports changes to the hardware -  I talk about RPTs that report
normal
usage, such as accounting RPTs, mentioned in COPS-PR draft)? Can the PDP ask
for
an RPT for a specific PRC? the SPPI draft also mentions:
'PRCs having the "install" and/or "notify" characteristics may also
be included in reports generated by the PEP'. How can this happen?
Does this imply that the PDP has a mechanism to query the PIB and ask
for a specific PRI?

Thanks,
Andreas

---

From: "Rawlins, Diana" <[email-masked]>
Date: Wed, 07 Mar 2001 01:30:22 +0000

Andreas,

The accounting type RPTs framework is described in

http://search.ietf.org/internet-drafts/draft-ietf-rap-acct-fr-pib-00.txt

An unsolicited accounting type report is issued based
on a deterministic interval specified in the policy.

Accounting reports can also be triggered by the PDP
issuing an unsolicited decision with the resume policy
set with the attribute "send reports." FYI. A new version
of the draft has been submitted but is not yet posted
on the IETF site. 

For COPS-PR reports that are not of type accounting, 
my understanding is that the report clientSI may contain 
PRI's associated with specific error / warnings conditions.

-Diana

-----Original Message-----
From: Andreas Polyrakis [mailto:[email-masked]]
Sent: Tuesday, March 06, 2001 5:40 PM
To: [email-masked]
Subject: SPPI PIB-ACCESS clause

Hello,

Thanks,
Andreas