Subject: Re: COPS SSQ/SSC

From: [email-masked]
Date: Fri, 9 Mar 2001 09:25:17 -0600

(this is an old thread, I know; I just joined the list and 
 am interested in this)

To recap:
1. The PDP sends a set of policies P to the PEP.
2. The connection is lost.
3. At this point, the PEP does have a valid set "P".

Then, when the PEP gets a _new_ connection to the PDP,
is there a way for the PDP to know exactly what policies
are already in the PEP?

Since the PEP does have valid policies, there is no need
to download those policies "P" again.  But the PDP has to
know somehow that the set "P" is indeed in the PEP already.

The RFC2748 says:
...................................................................
3.5 Synchronize State Request (SSQ)  PDP -> PEP

   [...]
   The client performs state synchronization by re-issuing request
   queries of the specified client-type for the existing state in the
   PEP. When synchronization is complete, the PEP MUST issue a
   synchronize state complete message to the PDP.
....................................................................

It doesn't talk about the case that the PEP has valid
policies.   Does this mean that even in this case, everything
must be downloaded again?

Thanks,

--
Pedro Soria-Rodriguez

> Re: COPS SSQ/SSC
>      To: [email-masked] (Iliff Tina) 
>      Subject: Re: COPS SSQ/SSC 
>      From: Keith McCloghrie <[email-masked]> 
>      Date: Tue, 24 Oct 2000 12:49:57 -0700 (PDT) 
>      Cc: [email-masked] ([email-masked]'), [email-masked]
("Sunlin, Richard (c)") 
>      Delivery-date: Tue, 24 Oct 2000 22:59:53 +0300 
>      Envelope-to: [email-masked] 
>      In-Reply-To:
<[email-masked]> from "Iliff,
Tina" at Oct 24, 2000 02:51:42 PM 
>      Sender: [email-masked] 
> 
> A better solution is for the PDP to have a set of policies, M, that it
> uses for misconfigured interfaces.  So, when the PDP receives the
> unknown interface-type/role combination from the PEP, then a) the PDP
> sends the M set of policies to the PEP, so that the PEP can configure
> the relevant interfaces, and b) the PDP can inform the administrator
> such that the misconfiguration (either of the PDP or PEP) can be fixed.
> 
> Keith.

---

From: "Iliff, Tina" <[email-masked]>
Date: Fri, 09 Mar 2001 15:36:11 +0000

Pedro,

My responses to your questions are embedded within your e-mail preceded by
tli>>

Tina Iliff

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]
Sent: Friday, March 09, 2001 9:25 AM
To: [email-masked]
Subject: Re: COPS SSQ/SSC

To recap:

tli>>  The PDP can determine which set of policies the PEP has cached by
looking at the frwkPibIncarnation instance which the PEP includes in the REQ
NamedClientSI object.

The RFC2748 says:

   [...]

tli>> No, it is not necessary to push the policy set again as long as the
PDP is confident that the PEP has the correct policy.

Thanks,

--
Pedro Soria-Rodriguez

("Sunlin, Richard (c)")