Subject: RE: draft-jacquenet-ip-te-cops-01.txt

From: "Rawlins, Diana" <[email-masked]>
Date: Fri, 09 Mar 2001 01:07:17 +0000

Yacine,

The Client Type and Handle uniquely identify a request state at
a give PEP. In the outsourcing model such as COPS-RSVP a request
state exists for each signaled reservation. In the provisioning
model the request state is associated with an interface or aspect
of the PEP device. There can be multiple interfaces/aspects that
each have a request state. 

-Diana

-----Original Message-----
From: Yacine El Mghazli [mailto:[email-masked]]
Sent: Tuesday, March 06, 2001 9:55 AM
To: Iliff, Tina; 'JACQUENET Christian FTRD/DMI/CAE'
Cc: [email-masked]
Subject: Re: draft-jacquenet-ip-te-cops-01.txt

Thank you for your explanations & sorry for having misunderstood the draft.
But I am still wondering about a point :
If there are as many client-types as policy areas, what is the handle
function in the provisioning model ?
I tought it was used this way (to specify areas) in a unique COPS-PR
session, but it's not the case since there is a COPS client type per
provisioning area.

Yacine

----- Original Message -----
From: "Iliff, Tina" <[email-masked]>
To: "'JACQUENET Christian FTRD/DMI/CAE'"
<[email-masked]>; "'Yacine El Mghazli'"
<[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, March 06, 2001 3:33 PM
Subject: RE: draft-jacquenet-ip-te-cops-01.txt

> Yes, the distinct client-type will allow a PEP to have multiple
connections
> open with a PDP in order to receive various types of policy
simultaneously.
> This allows the PEP to "specify" exactly what it is after instead of just
> blindly sending a REQ and obtaining only QoS policy.
> The PEP may have connections open with multiple PDPs; however, these
> connections may not be of the same client-type.
>
> Tina Iliff
>
>
> -----Original Message-----
> From: JACQUENET Christian FTRD/DMI/CAE
> [mailto:[email-masked]]
> Sent: Tuesday, March 06, 2001 6:46 AM
> To: 'Yacine El Mghazli'
> Cc: [email-masked]
> Subject: RE: draft-jacquenet-ip-te-cops-01.txt
>
>
> Yacine,
>
> I'm not sure I understand your question, but, according to section 1 of
> draft-ietf-rap-pr-05.txt:
>
>    "In order to support a model that includes multiple PDPs
>    controlling non-overlapping areas of policy on a single PEP, the
>    client-type specified by the PEP to the PDP is unique for the area
>    of policy being managed. A single client-type for a given area of
>    policy (eg. QoS) will be used for all PIBs that exist in that
>    area.  The client should treat all the COPS-PR client-types it
>    supports as non-overlapping and independent namespaces where
>    instances MUST NOT be shared."
>
> >From this standpoint, draft-jacquenet-ip-te-cops-01.txt considers the
case
> of enforcing an IP TE policy (i.e. a specific area of policy, among QoS,
> security, routing, etc.), thus yielding the need for the definition of a
> specific client-type that should be treated by a PEP, amongst all the
> COPS-PR client-types that are currently or will be defined.
>
> Did I answer your question?
>
> Thank you for your comment.
>
> Cheers,
>
> Christian.
>
>
>
> -----Message d'origine-----
> De : Yacine El Mghazli [mailto:[email-masked]]
> Envoyé : mardi 6 mars 2001 11:46
> À : JACQUENET Christian FTRD/DMI/CAE
> Cc : [email-masked]
> Objet : Re: draft-jacquenet-ip-te-cops-01.txt
>
>
> Christian,
>
> Why do you use a new client type for provisioning purposes instead of the
> already existing COPS-PR one ?
> What prevent you from using the normal provisioning scheme ? I'm sure you
> have any good reason but I can't get it, I'm not a routing/TE expert !
> Thanx
> Yacine
>
> ----- Original Message -----
> From: "JACQUENET Christian FTRD/DMI/CAE"
> <[email-masked]>
> To: "'Andrew Smith (co-chair rap)'" <[email-masked]>; "'Mark Stevens
> (co-chair rap)'" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Monday, March 05, 2001 11:17 AM
> Subject: draft-jacquenet-ip-te-cops-01.txt
>
>
> > Dear all,
> >
> > FYI: A New Internet-Draft is available from the on-line Internet-Drafts
> > directories.
> >
> >
> > Title : A COPS client-type for IP traffic engineering
> > Author(s) : C. Jacquenet
> > Filename : draft-jacquenet-ip-te-cops-01.txt
> > Pages : 14
> > Date : 01-Mar-01
> >
> > This draft specifies a COPS (Common Open Policy Service, [2])client-
> > type designed for the enforcement of IP Traffic Engineering (IP TE)
> > policies within IP networks. The usage of this IP TE COPS client-type
> > is based upon the activation of the COPS protocol for policy
> > provisioning purposes (COPS-PR, [3]).
> >
> > A URL for this Internet-Draft is:
> > http://www.ietf.org/internet-drafts/draft-jacquenet-ip-te-cops-01.txt
> >
> > Depending on the current rap agenda for the Minneapolis meeting, would
it
> be
> > possible to get allocated a 10-minute slot for a presentation of this
> draft?
> >
> > Comments on this spec are warmly welcome.
> >
> > Cheers,
> >
> > Christian.
> >
> >
> >

---

From: "Yacine El Mghazli" <[email-masked]>
Date: Fri, 9 Mar 2001 11:04:12 +0100

Diana, Tina,

Where in the PR-05 draft is it explained that handles are linked to
interfaces/roles ?
Be sure I trust you but I'd like to read the spec in order to understand
properly COPS-PR.
If so, what about the start attribute in the Diffserv DataPath Element (QoS
area for example)? What is its function ?

Yacine

---

From: "Yacine El Mghazli" <[email-masked]>
Date: Fri, 9 Mar 2001 11:04:12 +0100

Diana, Tina,

Yacine