Subject: [Raw] Skeleton for a technologies document

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 20 May 2019 11:28:00 +0000

Great!

We need to agree on a skeleton that is generic for all technologies. Then the editor for each technology needs to produce his piece so I can wrap it all together. Each editor would be responsible for his technology and get the helps he finds relevant.
For now I see that we can achieve TSCH and Wi-Fi, but we are short on URLLC, cc’ing Edgard and Bikramjit for help.
Let me suggest the below, please suggest additions:

   2.  RAW-capable Technologies  . . . . . . . . . . . . . . . . . . . . .   3

     2.X.1.  Tech X . . . . . . . . . . . . . . . . . . . . . . . . .   4

       2.X.1.  Provenance and Documents  . . . . . . . . . . . . . .   4

              - Which SDO, position wrt Open standards
             - Existing IP over foo
              - TSN-like activities, past and present (introduce the likes of as OFDMA, URLLC and EHT)
              - DetNet-like arching art (introduce the likes of ISA100.11a or WiHART)

       2.X.2. General Characteristics . . . . . . . . . . . . . . . . . . .   4
              - bandwidth, beam forming
              - expected capabilities for safety and automation, e.g., loops per second
              - caveats, e.g., latency in the backhaul or interference
              - programming capabilities, is there a model for a flow, etc.

       2.X.3. Applicability to deterministic flows . . . . . . . . . . . . . . . . . . .   4
              - time synchronization
              - scheduling capabilities, discuss such things as Resource Units, time slots or resource blocks. Can we reserve periodic resources vs. ask each time, what precision can we get in latency control.
              - diversity scenarios, what’s available,
              - gap analysis, e.g. discuss multihop, or what’s missing how to do PAREO features.

All the best,

Pascal

From: Xavi Vilajosana Guillen <[email-masked]>
Sent: lundi 20 mai 2019 11:59
To: Charlie Perkins <[email-masked]>
Cc: Pascal Thubert (pthubert) <[email-masked]>; [email-masked]; Muhammad Shahwaiz Afaqui <[email-masked]>
Subject: Re: [Raw] technologies document

Pascal, all,

maybe we can also help with 6TiSCH and 802.11ax and upcoming 802.11be

please let us know how to proceed.

X

Missatge de Charlie Perkins <[email-masked]<mailto:[email-masked]>> del dia ds., 18 de maig 2019 a les 1:00:

Hello folks,

I can help with 802.15.4, although I am weak on numerous PHY layer details.

Regards,
Charlie P.

On 5/17/2019 3:44 PM, Grossman, Ethan A. wrote:
I can help with editing but I can’t commit to core technology text.
Ethan.

From: Raw <[email-masked]><mailto:[email-masked]> On Behalf Of Pascal Thubert (pthubert)
Sent: Friday, May 17, 2019 2:30 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Raw] technologies document

Dear all

We are missing activity to justify a BoF in Montreal... A good starting point – and a low hanging fruit - for us is to kick off the technology draft. Something inspired by https://tools.ietf.org/html/rfc8376<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_rfc8376&d=DwMFAg&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=k0kmef03JJi_WmayGA-A3wF562FPiIH0fO_KZQ34fAM&s=Eg2fCle_1uXJ-04aOl7PPbH9L5MBZcEDrAXg_R9Xbmw&e=> and possibly taking information off other docs such as https://tools.ietf.org/html/rfc7554<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_rfc7554&d=DwMFAg&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=k0kmef03JJi_WmayGA-A3wF562FPiIH0fO_KZQ34fAM&s=XcHvOngTavHuYitUzvMkBjbhirpoGG_ZidH_P51C_NA&e=>.

The idea of that draft would be to describe the characteristics of the technologies that RAW would deal with, in particular 802...11 EHT, 3GPP URLLC and 802.15.4 TSCH.

On top of the usual description, we’d need information such as the capability to schedule resources and typical rates, typically for a constant DetNet flow that can be expressed in frame size and period. The draft should also cover applicability to Use Uses such as presented in the use cases draft (https://tools.ietf.org/html/draft-bernardos-spawn-use-cases-00)

I can provide  a skeleton for the document, but need authors to commit to the work.

Who’s in?

Pascal

--
Raw mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/raw

--
Dr. Xavier Vilajosana
Wireless Networks Lab
Internet Interdisciplinary Institute (IN3)
Professor
(+34) 646 633 681
[email-masked]<mailto:[email-masked]>
http://xvilajosana.org
http://wine.rdi.uoc.edu
Parc Mediterrani de la Tecnologia
Av Carl Friedrich Gauss 5, B3 Building
08860 Castelldefels (Barcelona). Catalonia. Spain
[Universitat Oberta de Catalunya]  [https://ferranadelantado.files.wordpress.com/2014/05/wine_logo_small2-e1453363995864.png?w=330&h=123]

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 21 May 2019 14:55:49 +0000

Dear all:

I created a repo https://github.com/pthubert/raw-techs
Also published a skeleton as 00:

URL:            https://www.ietf.org/internet-drafts/draft-thubert-raw-technologies-00.txt

Status:         https://datatracker.ietf.org/doc/draft-thubert-raw-technologies/

Htmlized:       https://tools.ietf.org/html/draft-thubert-raw-technologies-00

Htmlized:       https://datatracker.ietf.org/doc/html/draft-thubert-raw-technologies

Now we need an editor and contributors for all techs

From the previous answers I would see:

Tech                    Editor                 Contributors
-------------------------------------------------------------
EHT                     Dave                   Jerome, Diego
TSCH                   Xavi                    Georgios, Charlie, Muhammad
URLLC                 Edgard                Bikramjit, Hesham

I can organize calls between authors on demand. The plan could be that each editor owns a file that is his section and I do merge before publishing.
I created several files in the repo for that purpose. But I’m open to other models as you prefer.

All the best,

Pascal

From: Raw <[email-masked]> On Behalf Of Pascal Thubert (pthubert)
Sent: lundi 20 mai 2019 13:28
To: Xavi Vilajosana Guillen <[email-masked]>; Charlie Perkins <[email-masked]>; Edgar Ramos <[email-masked]>; Bikramjit Singh B <[email-masked]>
Cc: [email-masked]; Muhammad Shahwaiz Afaqui <[email-masked]>
Subject: [Raw] Skeleton for a technologies document

Great!

All the best,

Pascal

From: Xavi Vilajosana Guillen <[email-masked]<mailto:[email-masked]>>
Sent: lundi 20 mai 2019 11:59
To: Charlie Perkins <[email-masked]<mailto:[email-masked]>>
Cc: Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Muhammad Shahwaiz Afaqui <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Raw] technologies document

Pascal, all,

X

Hello folks,

Regards,
Charlie P.

Dear all

Who’s in?

Pascal