Subject: [Raw] Montreal and Chartering

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 2 May 2019 16:12:43 +0000

Dear all:

It's probaly time to start preparing for a WG forming both in Montreal. The key element will be the proposed charter. It must justify a group but not attempt to boil the ocean.

Though the BoF in Prague went really well, there was an uncertainty in the end on what we should aim for I the charter, that Lou expressed in a question.

       Lou: You clarified what 6TiSCH does, can you clarify what PAW is to do?
       Pascal: We expect this group to complete the dot of the 6TiSCH architecture, which describes both stochastic and deterministic flows. But 6TiSCH WG was focused on stochastic flows, and we expected to inherit from the work of detnet for deterministic flows. As we thought about it we decided to disband 6TiSCH and start a new group to do the deterministic part since 6TiSCH was not the right group to do it.
       * Lou: would be good to clarify if this is going to be deterministic for 6TiSCH or for other type of radios.
       * Pascal: Not just for 6TiSCH. Another reason that 6TiSCH is not appropriate for this work is that we want to extend the work to other radio technologies. We are presenting here four different radio technologies that we are addressing.

Basically there is a duality: trying to adapt/extend DetNet and CCAMP to a generic scheduled wireless network in the one hand, and providing data models to program a deterministic track, which is an ask that we got at 6TISCH but does not generalize well to other radios. The difference is that on EHT and URLLC we do not program the physical resources (e.g., a resource block), but in all cases we ask for a guaranteed periodic resource to perform on hop, and then we assemble the hops with DetNet.

6TiSCH is special because we could configure down to the time slot, and use the time slot in/out as a G-MPLS switching resource.

Seems to me that we could separate the G-MPLS piece as an extension to what we'd do on all radios, that is program a periodic resource for a flow identified by a flow ID in the packet. A 6TiSCH-specific draft could then explain how the PCE can program the timeslots and use that to elide the flow ID, in which case this is only a variation of the generic model that we'd define, a sort of compression. We can even leave it off charter on the first round if the charter seems confused or too greedy otherwise.

What do you think?

Pascal

---

From: Xavi Vilajosana Guillen <[email-masked]>
Date: Fri, 3 May 2019 10:59:57 +0200

Hi Pascal,

I am in favour of going through the generic model (we could consider and
see how URLLC, EHT (11ax/be) flows are managed) and extend to 6TiSCH later
when having addressed the 2-hop gaming scenarios with EHT.

Our experience says that the charter should be focused and concise.

regards
Xavi

Missatge de Pascal Thubert (pthubert) <[email-masked]> del dia dj., 2
de maig 2019 a les 18:13:

> Dear all:
>
>
>
> It’s probaly time to start preparing for a WG forming both in Montreal.
> The key element will be the proposed charter. It must justify a group but
> not attempt to boil the ocean.
>
>
>
> Though the BoF in Prague went really well, there was an uncertainty in the
> end on what we should aim for I the charter, that Lou expressed in a
> question.
>
>
>
>
>
>        Pascal: We expect this group to complete the dot of the 6TiSCH
> architecture, which describes both stochastic and deterministic flows. But
> 6TiSCH WG was focused on stochastic flows, and we expected to inherit from
> the work of detnet for deterministic flows. As we thought about it we
> decided to disband 6TiSCH and start a new group to do the deterministic
> part since 6TiSCH was not the right group to do it.
>
>        * Lou: would be good to clarify if this is going to be
> deterministic for 6TiSCH or for other type of radios.
>
>        * Pascal: Not just for 6TiSCH. Another reason that 6TiSCH is not
> appropriate for this work is that we want to extend the work to other radio
> technologies. We are presenting here four different radio technologies that
> we are addressing.
>
>
>
>
>
> Basically there is a duality: trying to adapt/extend DetNet and CCAMP to a
> generic scheduled wireless network in the one hand, and providing data
> models to program a deterministic track, which is an ask that we got at
> 6TISCH but does not generalize well to other radios. The difference is that
> on EHT and URLLC we do not program the physical resources (e.g., a resource
> block), but in all cases we ask for a guaranteed periodic resource to
> perform on hop, and then we assemble the hops with DetNet.
>
>
>
> 6TiSCH is special because we could configure down to the time slot, and
> use the time slot in/out as a G-MPLS switching resource..
>
>
>
> Seems to me that we could separate the G-MPLS piece as an extension to
> what we’d do on all radios, that is program a periodic resource for a flow
> identified by a flow ID in the packet. A 6TiSCH-specific draft could then
> explain how the PCE can program the timeslots and use that to elide the
> flow ID, in which case this is only a variation of the generic model that
> we’d define, a sort of compression. We can even leave it off charter on the
> first round if the charter seems confused or too greedy otherwise.
>
>
>
> What do you think?
>
>
>
> Pascal
> --
> Raw mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/raw
>

-- 
Dr. Xavier Vilajosana
Wireless Networks Lab

*Internet Interdisciplinary Institute (IN3)Professor*
(+34) 646 633 681
[email-masked] <[email-masked]>
http://xvilajosana.org
http://wine.rdi.uoc.edu
Parc Mediterrani de la Tecnologia
Av Carl Friedrich Gauss 5, B3 Building
08860 Castelldefels (Barcelona). Catalonia. Spain