Subject: Re: [Raw] Call for adoption of draft-theoleyre-raw-oam-support-01

From: Fabrice Theoleyre <[email-masked]>
Date: Wed, 1 Apr 2020 10:59:51 +0200

Dear Janos, all, 

> I guess I'd start with:
> 3) Does the draft meet the criteria outlined in the WG charter (this is mostly a decision for the chairs, but we welcome feedback!)
> 
> Checking the RAW charter:
> "RAW is not chartered to work on a solution. If solution work is needed, the Working Group will coordinate with the IESG to determine where the work will be done. If RAW is chosen for the solution work, the Working Group will recharter."
> 
> The intended status of the draft is Standards Track. It includes conformance language, e.g.,:
> " The ping packets must be labeled in the same way as the data packets of the flow to monitor."
> " These metrics should be collected:”

Yes, this is something we have to address. 

> To me, the draft seems to be solution, hence, outside of the current RAW charter.

Actually, we have tried to explain the challenges created by implementing OAM with RAW networks. We tried to not detail a given solution. While we point to existing works for each of ”challenge”, we don’t recommend a specific one. 

Anyway, maintaining an informational status was our objective. If the draft is too ”solution oriented” in some parts, this is probably something we can address.
Let us know the incriminated parts.

Bets regards,
Fabrice

> 
> Thinking then on:
> 1) Is the RAW working group the correct WG for this work?
> Also in the RAW charter:
> " RAW extends the DetNet Working Group concepts"
> As I understand, RAW OAM should be an extension of DetNet OAM, not RAW OAM on its own. The draft does not mention or refer to DetNet OAM. Well, DetNet OAM has not been finished yet, but there are drafts for it:
> https://datatracker.ietf.org/doc/draft-ietf-detnet-mpls-oam/
> https://datatracker.ietf.org/doc/draft-mirsky-detnet-ip-oam/
> Perhaps the OAM work could be done in the DetNet WG. DetNet OAM could be extended for wireless in the DetNet WG. 
> 
> 
> So, I do not support the adoption of this draft.
> 
> Regards,
> Janos
> 
> 
> -----Original Message-----
> From: RAW <[email-masked]> On Behalf Of Rick Taylor
> Sent: Monday, March 30, 2020 12:14 PM
> To: [email-masked]
> Subject: [Raw] Call for adoption of draft-theoleyre-raw-oam-support-01
> 
> Hi All,
> 
> The authors of: draft-theoleyre-raw-oam-support-01 (have asked for a call for working group adoption of their draft.
> 
> The link to the draft is: https://datatracker.ietf.org/doc/draft-theoleyre-raw-oam-support/
> 
> This is your opportunity to express your opinion.
> 
> A decision will be made on/after 13th April.
> 
> Cheers,
> 
> Rick and Eve
> Co-chairs
> 
> -- 
> RAW mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/raw
> 
> -- 
> RAW mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/raw

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 1 Apr 2020 09:24:32 +0000

Dear all
> Yes, this is something we have to address.

Well that language can be found in informational as well; if it must it must, fact of life that can be observed and described in an informational. Publishing as informational for all I know does not preclude such language. Note that this is not using BCP 14.

> Actually, we have tried to explain the challenges created by implementing
> OAM with RAW networks. We tried to not detail a given solution. While we
> point to existing works for each of ”challenge”, we don’t recommend a specific
> one.
> 
> Anyway, maintaining an informational status was our objective. If the draft is
> too ”solution oriented” in some parts, this is probably something we can
> address.

God for me then... 
I'm happy that RAW works on this draft for now to ensure that the RAW angle is described in full.
It is up to the chairs and ADs to transfer or kindly ask for reviews from DetNet at any stage if that can help. 

Be safe!

Pascal
> > As I understand, RAW OAM should be an extension of DetNet OAM, not RAW
> OAM on its own. The draft does not mention or refer to DetNet OAM. Well,
> DetNet OAM has not been finished yet, but there are drafts for it:
> > Perhaps the OAM work could be done in the DetNet WG. DetNet OAM could
> be extended for wireless in the DetNet WG.
> >
> >
> > The authors of: draft-theoleyre-raw-oam-support-01 (have asked for a call
> for working group adoption of their draft.
> >

---

From: Janos Farkas <[email-masked]>
Date: Wed, 1 Apr 2020 20:40:46 +0000

Dear Fabrice and Pascal,

Perhaps, I have not elaborated my points too much.

I of course also see a lot of value in collecting the OAM requirements for RAW. It is just not obvious to me that this draft is a collection of RAW OAM requirements. For instance, the title is not "OAM Requirements" or alike.

A requirements document is listed among the RAW milestones.
OAM requirements, clearly phrased as OAM requirements, could be part of the RAW requirements document.
I understand this is an early draft. Given the comments, maybe updated text could be good input to RAW requirements document.

Best regards,
Janos

-----Original Message-----
From: Pascal Thubert (pthubert) <pthubert=[email-masked]> 
Sent: Wednesday, April 1, 2020 11:25 AM
To: Fabrice Theoleyre <[email-masked]>; Janos Farkas <[email-masked]>
Cc: [email-masked]; Rick Taylor <[email-masked]>
Subject: RE: [Raw] Call for adoption of draft-theoleyre-raw-oam-support-01

Dear all
> > The intended status of the draft is Standards Track. It includes 
> > conformance
> language, e.g.,:
> > " The ping packets must be labeled in the same way as the data 
> > packets of
> the flow to monitor."

> 
> > To me, the draft seems to be solution, hence, outside of the current 
> > RAW
> charter.
> 
> Actually, we have tried to explain the challenges created by 
> implementing OAM with RAW networks. We tried to not detail a given 
> solution. While we point to existing works for each of ”challenge”, we 
> don’t recommend a specific one.
> 
> Anyway, maintaining an informational status was our objective. If the 
> draft is too ”solution oriented” in some parts, this is probably 
> something we can address.

God for me then... 

Be safe!

Pascal
> OAM on its own. The draft does not mention or refer to DetNet OAM. 
> Well, DetNet OAM has not been finished yet, but there are drafts for it:
> > The link to the draft is: 
> > https://datatracker.ietf.org/doc/draft-theoleyre-raw-
> oam-support/
> >

---

From: Fabrice Theoleyre <[email-masked]>
Date: Thu, 2 Apr 2020 16:17:11 +0200

Dear Janos, 

I guess that focusing on the OAM requirements for RAW and more importantly on what makes it so specific is of interest. 

Merging OAM and general requirements in a single document may be an option, but I’m afraid of having something very big, and complicated to digest by everybody. 

Pedagogically, shouldn’t we split both documents? 
What overlapping parts do you envision between both of them? 

Best regards,
Fabrice

> Le 1 avr. 2020 à 22:40, Janos Farkas <[email-masked]> a écrit :
> 
> Dear Fabrice and Pascal,
> 
> From: Pascal Thubert (pthubert) <pthubert=[email-masked] <mailto:pthubert=[email-masked]>> 
> To: Fabrice Theoleyre <[email-masked] <mailto:[email-masked]>>; Janos Farkas <[email-masked] <mailto:[email-masked]>>
> Cc: [email-masked] <mailto:[email-masked]>; Rick Taylor <[email-masked] <mailto:[email-masked]>>
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/raw <https://www.ietf.org/mailman/listinfo/raw>

---

From: Janos Farkas <[email-masked]>
Date: Thu, 2 Apr 2020 14:47:03 +0000

Dear Fabrice,

My point is that we have “Requirements Document” in the charter. I haven’t seen draft for it yet.
Having an OAM requirements section int the Requirements Document is not less readable or referenceable than a separate draft. Actually, there is gain of saving separate intro, security considerations and so on.

Best regards,
Janos

From: Fabrice Theoleyre <[email-masked]>
Sent: Thursday, April 2, 2020 4:17 PM
To: Janos Farkas <[email-masked]>
Cc: Pascal Thubert (pthubert) <pthubert=[email-masked]>; [email-masked]; Rick Taylor <[email-masked]>
Subject: Re: [Raw] Call for adoption of draft-theoleyre-raw-oam-support-01

Dear Janos,

Best regards,
Fabrice

Le 1 avr. 2020 à 22:40, Janos Farkas <[email-masked]<mailto:[email-masked]>> a écrit :

Dear Fabrice and Pascal,

Best regards,
Janos

-----Original Message-----
From: Pascal Thubert (pthubert) <pthubert=[email-masked]<mailto:pthubert=[email-masked]>>
Sent: Wednesday, April 1, 2020 11:25 AM
To: Fabrice Theoleyre <[email-masked]<mailto:[email-masked]>>; Janos Farkas <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; Rick Taylor <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Raw] Call for adoption of draft-theoleyre-raw-oam-support-01

Dear all

God for me then...

Be safe!

Pascal

Thinking then on:
As I understand, RAW OAM should be an extension of DetNet OAM, not

https://datatracker.ietf.org/doc/draft-ietf-detnet-mpls-oam/
https://datatracker.ietf.org/doc/draft-mirsky-detnet-ip-oam/
Perhaps the OAM work could be done in the DetNet WG. DetNet OAM
could
be extended for wireless in the DetNet WG.

Regards,
Janos

-----Original Message-----
From: RAW <[email-masked]<mailto:[email-masked]>> On Behalf Of Rick Taylor
Sent: Monday, March 30, 2020 12:14 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Raw] Call for adoption of
draft-theoleyre-raw-oam-support-01

Hi All,

The authors of: draft-theoleyre-raw-oam-support-01 (have asked for a
call
for working group adoption of their draft.

Cheers,

Rick and Eve
Co-chairs

--
RAW mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/raw

--
RAW mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/raw

--
RAW mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/raw

---

From: "Grossman, Ethan A." <[email-masked]>
Date: Fri, 3 Apr 2020 00:21:33 +0000

Hi Fabrice, Pascal,

Do I understand correctly that the OAM requirements of RAW extend a lot further than for wired, due to having to maintain status of the various paths at very short time intervals (e.g. to make routing decisions on very short notice due to transient conditions) and this is part of what differentiates OAM for RAW from OAM for DetNet, and which might justify a separate document because it is inherently a potentially complex aspect of the proposed work of RAW, i.e. much more so than for DetNet/wired?

Thanks,
Ethan.

From: RAW <[email-masked]> On Behalf Of Janos Farkas
Sent: Thursday, April 2, 2020 7:47 AM
To: Fabrice Theoleyre <[email-masked]>
Cc: Pascal Thubert (pthubert) <pthubert=[email-masked]>; [email-masked]; Rick Taylor <[email-masked]>
Subject: Re: [Raw] Call for adoption of draft-theoleyre-raw-oam-support-01

Dear Fabrice,

Best regards,
Janos

From: Fabrice Theoleyre <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, April 2, 2020 4:17 PM
To: Janos Farkas <[email-masked]<mailto:[email-masked]>>
Cc: Pascal Thubert (pthubert) <pthubert=[email-masked]<mailto:pthubert=[email-masked]>>; [email-masked]<mailto:[email-masked]>; Rick Taylor <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Raw] Call for adoption of draft-theoleyre-raw-oam-support-01

Dear Janos,

Best regards,
Fabrice

Dear Fabrice and Pascal,

Best regards,
Janos

-----Original Message-----
From: Pascal Thubert (pthubert) <pthubert=[email-masked]<mailto:pthubert=[email-masked]>>
Sent: Wednesday, April 1, 2020 11:25 AM
To: Fabrice Theoleyre <[email-masked]<mailto:[email-masked]>>; Janos Farkas <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; Rick Taylor <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Raw] Call for adoption of draft-theoleyre-raw-oam-support-01

Dear all

God for me then...

Be safe!

Pascal

Thinking then on:
1) Is the RAW working group the correct WG for this work?
Also in the RAW charter:
" RAW extends the DetNet Working Group concepts"
As I understand, RAW OAM should be an extension of DetNet OAM, not
RAW
OAM on its own. The draft does not mention or refer to DetNet OAM.
Well, DetNet OAM has not been finished yet, but there are drafts for it:
https://datatracker.ietf.org/doc/draft-ietf-detnet-mpls-oam/<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Ddetnet-2Dmpls-2Doam_&d=DwMGaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=9RwbHc_nGQP6aOosUN1klCqT4BogSuXO_iNxnwRiXSI&s=HqbsGSrrFbnjuwycdAaSVeGH03C7CLD8vyI-TaPTX48&e=>
https://datatracker.ietf.org/doc/draft-mirsky-detnet-ip-oam/<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dmirsky-2Ddetnet-2Dip-2Doam_&d=DwMGaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=9RwbHc_nGQP6aOosUN1klCqT4BogSuXO_iNxnwRiXSI&s=OIu2lQRwkUH9EzpCg_eVrN-_y5vhosBf-_HlcvBgDkQ&e=>
Perhaps the OAM work could be done in the DetNet WG. DetNet OAM
could
be extended for wireless in the DetNet WG.

Regards,
Janos

-----Original Message-----
From: RAW <[email-masked]<mailto:[email-masked]>> On Behalf Of Rick Taylor
Sent: Monday, March 30, 2020 12:14 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Raw] Call for adoption of

Hi All,

The link to the draft is:
https://datatracker.ietf.org/doc/draft-theoleyre-raw-<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dtheoleyre-2Draw-2D&d=DwMGaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=9RwbHc_nGQP6aOosUN1klCqT4BogSuXO_iNxnwRiXSI&s=CucUNwCLlx8kqQHtOd6icsSlvmZ2wy3AgiQ7fTXenfQ&e=>
oam-support/

Cheers,

Rick and Eve
Co-chairs

--
RAW mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/raw<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_raw&d=DwMGaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=9RwbHc_nGQP6aOosUN1klCqT4BogSuXO_iNxnwRiXSI&s=38fo6Ye57mlnj2i9WOdswkMBJWE1rs9pq_SqVXpIR58&e=>

--
RAW mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/raw<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_raw&d=DwMGaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=9RwbHc_nGQP6aOosUN1klCqT4BogSuXO_iNxnwRiXSI&s=38fo6Ye57mlnj2i9WOdswkMBJWE1rs9pq_SqVXpIR58&e=>

--
RAW mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/raw<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_raw&d=DwMGaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=9RwbHc_nGQP6aOosUN1klCqT4BogSuXO_iNxnwRiXSI&s=38fo6Ye57mlnj2i9WOdswkMBJWE1rs9pq_SqVXpIR58&e=>

---

From: Fabrice Theoleyre <[email-masked]>
Date: Fri, 3 Apr 2020 09:22:36 +0200

Hi Ethan, 

Yes, wireless networks are lossy by nature. Some technologies using the unlicensed band may even be subject to external interference. Last but not least energy and bandwidth are limited resources for many scenarios/technologies. This creates to my mind specific challenges for wireless. 

Thus, the objective was to emphasize these aspects in the document. 

Best regards,
Fabrice

> Le 3 avr. 2020 à 02:21, Grossman, Ethan A. <[email-masked]> a écrit :
> 
> Hi Fabrice, Pascal,
>  
> From: RAW <[email-masked] <mailto:[email-masked]>> On Behalf Of Janos Farkas
> To: Fabrice Theoleyre <[email-masked] <mailto:[email-masked]>>
> Cc: Pascal Thubert (pthubert) <pthubert=[email-masked] <mailto:pthubert=[email-masked]>>; [email-masked] <mailto:[email-masked]>; Rick Taylor <[email-masked] <mailto:[email-masked]>>
> From: Fabrice Theoleyre <[email-masked] <mailto:[email-masked]>> 
> To: Janos Farkas <[email-masked] <mailto:[email-masked]>>
> Cc: Pascal Thubert (pthubert) <pthubert=[email-masked] <mailto:pthubert=[email-masked]>>; [email-masked] <mailto:[email-masked]>; Rick Taylor <[email-masked] <mailto:[email-masked]>>
> Le 1 avr. 2020 à 22:40, Janos Farkas <[email-masked] <mailto:[email-masked]>> a écrit :
>  
> Dear Fabrice and Pascal,
> 
> https://datatracker.ietf.org/doc/draft-ietf-detnet-mpls-oam/ <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Ddetnet-2Dmpls-2Doam_&d=DwMGaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=9RwbHc_nGQP6aOosUN1klCqT4BogSuXO_iNxnwRiXSI&s=HqbsGSrrFbnjuwycdAaSVeGH03C7CLD8vyI-TaPTX48&e=>
> https://datatracker.ietf.org/doc/draft-mirsky-detnet-ip-oam/ <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dmirsky-2Ddetnet-2Dip-2Doam_&d=DwMGaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=9RwbHc_nGQP6aOosUN1klCqT4BogSuXO_iNxnwRiXSI&s=OIu2lQRwkUH9EzpCg_eVrN-_y5vhosBf-_HlcvBgDkQ&e=>
> From: RAW <[email-masked] <mailto:[email-masked]>> On Behalf Of Rick Taylor
> To: [email-masked] <mailto:[email-masked]>
> https://datatracker.ietf.org/doc/draft-theoleyre-raw- <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dtheoleyre-2Draw-2D&d=DwMGaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=9RwbHc_nGQP6aOosUN1klCqT4BogSuXO_iNxnwRiXSI&s=CucUNwCLlx8kqQHtOd6icsSlvmZ2wy3AgiQ7fTXenfQ&e=>
> oam-support/
> 
> 
> https://www.ietf.org/mailman/listinfo/raw <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_raw&d=DwMGaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=9RwbHc_nGQP6aOosUN1klCqT4BogSuXO_iNxnwRiXSI&s=38fo6Ye57mlnj2i9WOdswkMBJWE1rs9pq_SqVXpIR58&e=>
> 
> --
> RAW mailing list
> https://www.ietf.org/mailman/listinfo/raw <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_raw&d=DwMGaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=9RwbHc_nGQP6aOosUN1klCqT4BogSuXO_iNxnwRiXSI&s=38fo6Ye57mlnj2i9WOdswkMBJWE1rs9pq_SqVXpIR58&e=>
> 
> --
> RAW mailing list
> https://www.ietf.org/mailman/listinfo/raw <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_raw&d=DwMGaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=9RwbHc_nGQP6aOosUN1klCqT4BogSuXO_iNxnwRiXSI&s=38fo6Ye57mlnj2i9WOdswkMBJWE1rs9pq_SqVXpIR58&e=>

---

From: "Georgios Z. Papadopoulos" <[email-masked]>
Date: Fri, 3 Apr 2020 10:41:49 +0200

Hello Ethan,

I might replace routing decisions in your example with forwarding decisions.
The routing decisions will be for long period of time while forwarding will be rather on very short notice as you mention.

My 2 cents,
Georgios

> On Apr 3, 2020, at 02:21, Grossman, Ethan A. <[email-masked]> wrote:
> 
> Hi Fabrice, Pascal,
>

---

From: "Grossman, Ethan A." <[email-masked]>
Date: Fri, 3 Apr 2020 20:55:20 +0000

Yes, forwarding decisions, not routing, thank you.
Ethan.

From: Georgios Z. Papadopoulos <[email-masked]>
Sent: Friday, April 3, 2020 1:42 AM
To: Grossman, Ethan A. <[email-masked]>
Cc: Janos Farkas <Janos.Farkas=[email-masked]>; Fabrice Theoleyre <[email-masked]>; Pascal Thubert (pthubert) <pthubert=[email-masked]>; [email-masked]; Rick Taylor <[email-masked]>
Subject: Re: [Raw] Call for adoption of draft-theoleyre-raw-oam-support-01

Hello Ethan,

My 2 cents,
Georgios

On Apr 3, 2020, at 02:21, Grossman, Ethan A. <[email-masked]<mailto:[email-masked]>> wrote:

Hi Fabrice, Pascal,

Thanks,
Ethan.

From: RAW <[email-masked]<mailto:[email-masked]>> On Behalf Of Janos Farkas
Sent: Thursday, April 2, 2020 7:47 AM
To: Fabrice Theoleyre <[email-masked]<mailto:[email-masked]>>
Cc: Pascal Thubert (pthubert) <pthubert=[email-masked]<mailto:pthubert=[email-masked]>>; [email-masked]<mailto:[email-masked]>; Rick Taylor <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Raw] Call for adoption of draft-theoleyre-raw-oam-support-01

Dear Fabrice,

Best regards,
Janos

Dear Janos,

Best regards,
Fabrice

Dear Fabrice and Pascal,

Best regards,
Janos

-----Original Message-----
From: Pascal Thubert (pthubert) <pthubert=[email-masked]<mailto:pthubert=[email-masked]>>
Sent: Wednesday, April 1, 2020 11:25 AM
To: Fabrice Theoleyre <[email-masked]<mailto:[email-masked]>>; Janos Farkas <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; Rick Taylor <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Raw] Call for adoption of draft-theoleyre-raw-oam-support-01

Dear all

God for me then...

Be safe!

Pascal

Thinking then on:

Regards,
Janos

-----Original Message-----
From: RAW <[email-masked]<mailto:[email-masked]>> On Behalf Of Rick Taylor
Sent: Monday, March 30, 2020 12:14 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Raw] Call for adoption of

Hi All,

Cheers,

Rick and Eve
Co-chairs

--
RAW mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/raw<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_raw&d=DwMFaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=gFLTtx6zQQTtxa3273EedKwfkz7tsEHGsRn8hH_bWwU&s=N65uuQweIQrCJ1V-MHqFm7kCGiPVh0Arwsh-cGlB990&e=>

---

From: Lou Berger <[email-masked]>
Date: Tue, 7 Apr 2020 15:40:05 -0400

Hi,

     I read this document and generally like what I see. We actually 
don't have a document of this type for DetNet net as a whole. (Actually, 
most the concepts I read are really independent of wireless and are 
generally applicable to almost any network.) My suggestion is revise 
this document and break out what is generally applicable to any DetNet 
and what is specific to a wireless DetNet.  Once this is done, it should 
be apparent if there are really two documents here, one for DetNet and 
one for RAW, or just one for RAW.

To be clear, my view is that this document is not ready for adoption.

 From a content perspective you might want to check out 
https://tools.ietf.org/html/rfc5860 and reuse some text from there.

Cheers,

Lou

---

From: Fabrice Theoleyre <[email-masked]>
Date: Wed, 8 Apr 2020 09:09:26 +0200

Hi Lou, 

Yes, this is something we are currently doing: making a clear distinction between what is specific to wireless, from what is common with "generic detnet".
We also read the rfc 5860, and it was indeed a source of inspiration. 

The current document is definitely not ready for adoption, but the objective was here to ask the opinion of everybody to improve the quality of the draft, and to fit the RAW objectives. 

Cheers,
Fabrice

> Le 7 avr. 2020 à 21:40, Lou Berger <[email-masked]> a écrit :
> 
> Hi,
> 
>     I read this document and generally like what I see. We actually don't have a document of this type for DetNet net as a whole. (Actually, most the concepts I read are really independent of wireless and are generally applicable to almost any network.) My suggestion is revise this document and break out what is generally applicable to any DetNet and what is specific to a wireless DetNet.  Once this is done, it should be apparent if there are really two documents here, one for DetNet and one for RAW, or just one for RAW.
> 
> From a content perspective you might want to check out https://tools.ietf.org/html/rfc5860 and reuse some text from there.
> 
> Cheers,
> 
> Lou
>

---

From: Lou Berger <[email-masked]>
Date: Wed, 8 Apr 2020 14:59:39 -0400

Fabrice

Thanks for the response and I look forward to seeing the update!

Lou