Subject: Re: [Raw] WG Last Call for LDACS

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 21 Apr 2021 13:25:06 +0000

Dear Nils, Thomas and Corinna:

Please find my WGLC review on the RAW LDACS document. It is a great read, very informative, and I support its publication.

I believe it is almost ready for the publication request, with the few nits below:

--------

"VDLM2"please expand on first use. A reference that discusses VHF for aircraft communication could be useful.

-----------

"
						LDACS SHALL provide
   a data link for IP network-based aircraft guidance.
"
"
                ATM communication SHALL transition from analogue
   VHF voice and VDLM2 communication to
"
"								LDACS SHALL enable IPv6
   based air- ground communication related to the aviation safety and
   regularity of flight."
Etc...  : Please do not use BCP 14 (remove all uppercased SHALL, MAY, REQUIRED, etc...) in this document
10.3 are verbatim from the IWA2018 then you can keep the uppercase but there should be quotes.
Reason 1) This is not a standard track work, and 2) the mandate expressed by the uppercase is enforced in other specs not this. 
Note that if the SHALLs in 

Also: A reference to support the claim about IPv6 would be welcome.

-----------
ATC  Air-Traffic Control
...
ATS  Air Traffic Services

Should you use "Air-Traffic" or "Air Traffic"?

-----------

"  communications is " : plural or singular?

-----------

"other users MAY encounter communication problems and MAY be
   supported, if REQUIRED": quite unclear what the "other users" are and what "supported" means here. I expect other types of communication?

-----------

"There is currently no "IPv6 over LDACS" specification": maybe the IETF should work on this? At 6lo? 

-----------

"This work is conducted by ICAO
   Communication Panel working group WG-I.": Is that related to Fred's work on AERO https://tools.ietf.org/html/draft-templin-intarea-6706bis-39? If so a link to Fred's spec is welcome

-------------

"Air Traffic Services (including ATS-B3)": This is the first use of ATS, maybe the place to indicate the acronym which appears later without an expansion. See also GBAS, FANS.

---------------

" AOC is a generic term referring to the business
   communication of airlines. ": this could have been said earlier since AOC is used throughout the spec, not to mean French Wine ;)

----------------

"5.2.5.  LDACS Navigation" this whole section seems related to the GBAS discussion earlier. Is it possible to regroup or at least X ref?

---------------

" Aircraft thus transmit": Plural "Aircrafts"?

---------------

Section 8.2: This is probably where RAW would be discussed a bit more, positioning what RAW can do and why it's a good complement.

---------------

Sections 9.X: it would be nice to expand the acronyms in the titles so the unaccustomed reader does not need to look it up.

------

Section 9.2: It would be nice to discuss scheduling capabilities. Is there a way to obtain a recurrent access to data channel, e.g. to control an AS in a drone?

------ 

" to the ground IPS network": IPS ? Missing from acronym list, not expanded on first use. Same goes for STS

--------
"(1) the AS, (2) the GS, (3) the GS, and (4) the Network Operator.": Did you intend GSC?

--------

"identification such as MAC addresses": We are going away from a model where MAC is used as ID, see MADINAS. Suggestion to remove this text.

----------

You all keep safe;

Pascal

From: RAW <[email-masked]> On Behalf Of Schooler, Eve M
Sent: mercredi 31 mars 2021 6:15
To: [email-masked]
Cc: Schooler, Eve M <[email-masked]>; Rick Taylor <[email-masked]>
Subject: Re: [Raw] WG Last Call for LDACS

Just a friendly reminder to all....

From: Rick Taylor <mailto:[email-masked]> 
Sent: Monday, March 8, 2021 9:34 AM
To: mailto:[email-masked]
Subject: [Raw] WG Last Call for LDACS

Hi All,

As discussed at the IETF-110 meeting, the authors of LDACS consider the draft to be complete and ready for Last Call.

To this end, the chairs are starting an 8 week Last Call for this document, ending 19th April.

Please take the time to read and review the draft, it is owned by the WG, and it is our responsibility to ensure that we are happy with it before it is submitted to the IESG for publication.

The draft is here: https://datatracker.ietf.org/doc/draft-ietf-raw-ldacs/ 

Cheers,

Rick & Eve,
RAW co-chairs

---

From: "Dr. Corinna Schmitt" <[email-masked]>
Date: Wed, 21 Apr 2021 15:27:46 +0200

Dear Pascal,

thanks for the review. We will address it next days and upload a new
version.

Regards,

Corinna

Am 21.04.21 um 15:25 schrieb Pascal Thubert (pthubert):
> Please find my WGLC review on the RAW LDACS document. It is a great
> read, very informative, and I support its publication.
>
> "                                                               LDACS
> SHALL enable IPv6
> Reason 1) This is not a standard track work, and 2) the mandate
> expressed by the uppercase is enforced in other specs not this.
>    supported, if REQUIRED": quite unclear what the "other users" are
> and what "supported" means here. I expect other types of communication?
>
> -----------
>
>    Communication Panel working group WG-I.": Is that related to Fred's
> work on AERO
> https://tools.ietf.org/html/draft-templin-intarea-6706bis-39? If so a
> link to Fred's spec is welcome
>
>
> -------------
>
> "Air Traffic Services (including ATS-B3)": This is the first use of
> ATS, maybe the place to indicate the acronym which appears later
> without an expansion. See also GBAS, FANS.
>
> ---------------
>
>
>    communication of airlines. ": this could have been said earlier
> since AOC is used throughout the spec, not to mean French Wine ;)
>
> ----------------
>
> "5.2.5.  LDACS Navigation" this whole section seems related to the
> GBAS discussion earlier. Is it possible to regroup or at least X ref?
>
> ---------------
>
> Section 8.2: This is probably where RAW would be discussed a bit more,
> positioning what RAW can do and why it's a good complement.
>
> ---------------
>
> Sections 9.X: it would be nice to expand the acronyms in the titles so
> the unaccustomed reader does not need to look it up.
>
> ------
>
> Section 9.2: It would be nice to discuss scheduling capabilities. Is
> there a way to obtain a recurrent access to data channel, e.g. to
> control an AS in a drone?
>
> ------
>
> "identification such as MAC addresses": We are going away from a model
> where MAC is used as ID, see MADINAS. Suggestion to remove this text.
>
> ----------
>
>
> You all keep safe;
>
> Pascal
>
>
>
> As discussed at the IETF-110 meeting, the authors of LDACS consider
> the draft to be complete and ready for Last Call.
>
> Please take the time to read and review the draft, it is owned by the
> WG, and it is our responsibility to ensure that we are happy with it
> before it is submitted to the IESG for publication.
>
> -- 
> RAW mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/raw

-- 
******************************************************

PD Dr. rer. nat. Corinna Schmitt
Head of Secure IoT

Research Institute CODE
Universität der Bundeswehr München

Werner-Heisenberg-Weg 39
85577 Neubiberg, Germany

Email: [email-masked]
https://www.unibw.de/code
https://www.corinna-schmitt.de