Subject: RE: [rddp] Stream Inititation (8.1)

From: "THALER,PAT (A-Roseville,ex1)" <[email-masked]>
Date: Thu, 26 Sep 2002 14:33:00 -0600

Caitlin,

The statement is accurate but perhaps misleading taken alone. "After" was not meant to mean "immediately after". It can be "sometime after". The next sentences should clarify that meaning: "The ULP is responsible for transitioning the LLP Stream into RDMA enabled mode. Once in RDMA enabled mode, an implementation MUST send only RDMA Messages across the transport Stream until the RDMAP Stream is torn down."  

The intent is that you can bring up a connection with RDMAP off, negotiate over the connection and then transition to RDMAP on.

Pat

-----Original Message-----
From: Caitlin Bestler [mailto:[email-masked]]
Sent: Tuesday, September 24, 2002 4:07 PM
To: [email-masked]
Subject: [rddp] Stream Inititation (8.1)

In section 8.1 the RDMAP draft specifies that the ULP peers
must agree on the send credits, rdma read credits, permitted
modes and configure the RDMAP/DDP layers as agreed before
RDMA mode is enabled.

This matches prior proposals.

It also states that that "RDMAP Stream initialization occurs
after the LLP Stream has been created (e.g. for DDP/MPA over
TCP the first TCP Segment after the SYN, SYN/ACK exchange)"

Wouldn't that make it impossible to negotiate connection
specific resource levels? There would still be protocol
specific, but negotiating connection specific would require
communicating *before* the connection was established.

Establishing a pair of connections between two NATted nodes
without protocol specific support in the firewall is
difficult to impossible.

In order to be truly transparent to all NAT boxes, doesn't
RDMAP have to be negotiated in a manner that allows it to
function over a single LLP connection without resorting to
UDP exchanges or multiple connections?

Is there a specific reason for not allowing a single TCP
segment exchange to establish stream-specific parameters?

This is less of a concern for SCTP, because the ULP could
easily use a different stream to negotiate RDMAP parameters
on the other streams.

Caitlin Bestler
http://asomi.com/CaitlinBestler/
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: Caitlin Bestler <[email-masked]>
Date: Thu, 26 Sep 2002 16:03:58 -0500

On 9/26/02, THALER,PAT (A-Roseville,ex1) wrote:

>Caitlin,
>
>The statement is accurate but perhaps misleading taken
>alone. "After" was not meant to mean "immediately after".
>It can be "sometime after". The next sentences should
>clarify that meaning: "The ULP is responsible for
>transitioning the LLP Stream into RDMA enabled mode. Once
>in RDMA enabled mode, an implementation MUST send only
>RDMA Messages across the transport Stream until the RDMAP
>Stream is torn down."  
>
>The intent is that you can bring up a connection with
>RDMAP off, negotiate over the connection and then
>transition to RDMAP on.
>
>Pat
>

What should be specified as to any anacked portion of
outbound stream at the time of enabling RMDA?

a) It's not allowed. At the time of transition all
previously sent bytes must be fully acked. The next
TCP segment received is assumed to be in RDMA mode.

b) The transition is understood to take place after all
previously transmitted bytes. Co-ordinating this with the
peer is the ULP's responsibility. The first segment after n
bytes (as specified by the local ULP) will be assumed to be
in RDMA mode.

I would assume option A, but that also should be specified.

Caitlin Bestler