Subject: RE: [rddp] Stream Inititation (8.1)

From: [email-masked]
Date: Thu, 26 Sep 2002 17:22:47 -0400

Caitlin,

I believe the answer should be a version of b) - the ULP
is responsible for determining the point in the stream
at which the transition takes place and making sure
both sides of the connection expect/perform the
transition at that point.  ACKed vs. Un-ACKed seems
like an issue for an implementation that doesn't
grok the concept of "DDP was enabled at this point
in the stream" when doing (re)transmits - a ULP dealing
with such a <expletive deleted> implementation may
need to resort to measures as extreme as a).

Thanks,
--David
---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 249-6449            FAX: +1 (508) 497-8018
[email-masked]       Mobile: +1 (978) 394-7754
---------------------------------------------------

> -----Original Message-----
> From: Caitlin Bestler [mailto:[email-masked]]
> Sent: Thursday, September 26, 2002 5:04 PM
> To: THALER,PAT (A-Roseville,ex1); [email-masked]
> Subject: RE: [rddp] Stream Inititation (8.1)
> 
> 
> On 9/26/02, THALER,PAT (A-Roseville,ex1) wrote:
> 
> >Caitlin,
> >
> >The statement is accurate but perhaps misleading taken
> >alone. "After" was not meant to mean "immediately after".
> >It can be "sometime after". The next sentences should
> >clarify that meaning: "The ULP is responsible for
> >transitioning the LLP Stream into RDMA enabled mode. Once
> >in RDMA enabled mode, an implementation MUST send only
> >RDMA Messages across the transport Stream until the RDMAP
> >Stream is torn down."  
> >
> >The intent is that you can bring up a connection with
> >RDMAP off, negotiate over the connection and then
> >transition to RDMAP on.
> >
> >Pat
> >
> 
> What should be specified as to any anacked portion of
> outbound stream at the time of enabling RMDA?
> 
> a) It's not allowed. At the time of transition all
> previously sent bytes must be fully acked. The next
> TCP segment received is assumed to be in RDMA mode.
> 
> b) The transition is understood to take place after all
> previously transmitted bytes. Co-ordinating this with the
> peer is the ULP's responsibility. The first segment after n
> bytes (as specified by the local ULP) will be assumed to be
> in RDMA mode.
> 
> I would assume option A, but that also should be specified.
> 
> 
> 
> Caitlin Bestler
> http://asomi.com/CaitlinBestler/
> _______________________________________________
> rddp mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/rddp
> 
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: Caitlin Bestler <[email-masked]>
Date: Thu, 26 Sep 2002 16:56:31 -0500

>need to resort to measures as extreme as a).

I agree that b) is the cleaner specification. But we should
give anyone who has silicon in progress a chance to yelp in
pain once before we lock it in. Option a), while inelegant,
can be lived with and if in fact will be required with
actual silicon is best specified upfront.

Caitlin Bestler