Subject: RE: [rddp] CRC-32 Requirement

From: "Julian Satran" <[email-masked]>
Date: Fri, 20 Sep 2002 08:06:15 +0300

Amir,

1. Adler checksum is far weaker than any CRC32 and it is not worth even 
seriously suggesting and there are numerous reference you may want to 
consult before making a statement
2. SCTP uses CRC32C

Julo

"Amir Shalit" <[email-masked]>
Sent by: [email-masked]
20/09/02 04:06

        To:     <[email-masked]>, <[email-masked]>
        cc: 
        Subject:        RE: [rddp] CRC-32 Requirement

DDP draft makes the following requirement:

"LLP MUST provide a strong digest (at least equivalent to CRC32-C) 
to cover at least the DDP Segment. It is believed that some 
of the existing data integrity digests are not sufficient and 
that direct memory transfer semantics require a stronger digest 
than, for example, a simple checksum."

SCTP requires Adler-32 checksum which is "almost as strong as" CRC-32.
I suggest to change the wording to allow an LLP with Adler-32 digest
such as SCTP.

Amir

_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: "Amir Shalit" <[email-masked]>
Date: Fri, 20 Sep 2002 09:06:18 -0700

Julian,

I actually prefer CRC32C. I was under the assumption that SCTP only allows
Adler-32 (RFC2960 6.8) since that's
not the case I'd like to withdraw my comment.

Thanks!

Amir
  -----Original Message-----
  From: Julian Satran [mailto:[email-masked]]
  Sent: Thursday, September 19, 2002 10:06 PM
  To: Amir Shalit
  Cc: [email-masked]; [email-masked]; [email-masked]
  Subject: RE: [rddp] CRC-32 Requirement

  Amir,

  Julo

  Amir