Subject: [rddp] Another Possible Argument for IFT over MPA

From: "Williams, Jim" <[email-masked]>
Date: Thu, 31 Oct 2002 12:15:55 -0500

I did not include this argument in the 
draft because I am unsure of its validity.
I would hope, though, to get some feedback
from this group as to whether this makes
sense or not.

The argument is based on how best to deal
with out of order received packets.  The
primary reason for out of order received
packets is that often packets are dropped
due to congestion and must be retransmitted.
The receiver will see a gap in the received
stream of data, which will be filled in
later when the dropped packet is retransmitted.

MPA proposes to address this problem by
providing a more efficient mechanism for 
dealing with these out of order packets.
It does so by adding complexity at the
application layer (above the transport),
and requiring implementations wishing
to exploit this feature to merge the
TCP, MPA, and DDP layers.

ECN addresses the same problem in a very
different way.  It allows routers to control
congestion without the need to drop packets.
Theoretically, if ECN is widely deployed
and used, dropped packets could become
sufficiently rare that it would not be
important for end points to handle them
efficiently.

ECN seems like a much
simpler, cleaner, and preferable way
to address this problem.  Given the choice,
it would make sense that this is the
direction in which the internet architecture
should be driven.

What I am not clear on is what is the rate
of adoption of ECN within the internet
switching infrastructure, and to what
extent can we realistically expect this
to drive down the packet drop rate for
endpoints that support ECN.

Feedback from anyone knowledgeable about
ECN and about internet architectural
direction in general would be quite
valuable.

Thanks, Jim Williams

Drafts under discussion:

  http://www.ietf.org/internet-drafts/draft-williams-iwarp-ift-00.txt

  http://www.ietf.org/internet-drafts/draft-culley-iwarp-mpa-00.txt

_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: "Williams, Jim" <[email-masked]>
Date: Thu, 31 Oct 2002 12:54:57 -0500

> -----Original Message-----
> From: Joe Touch [mailto:[email-masked]]
> 
> [...]
>
> A secondary reason is that IP does not guarantee in-order delivery.

True.  But I am assuming that it is quite rare
in practice that IP actually delivers out of order.  Is
this correct?

> [...]
> 
> Down != 0. Even ECN drops packets.

True again.  But if dropped packets are sufficiently
rare, the endpoint can handle them inefficiently
(but correctly) without significantly affecting
overall performance.  Hence my concern about
how rare they will actually be.
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp