Subject: Re: [rddp] WG Last Call: Problem Statement and Architecture

From: "Talpey, Thomas" <[email-masked]>
Date: Thu, 27 Mar 2003 15:41:01 -0500

A reminder, and notice that there is one issue in the
Architecture document which will be addressed in the
final version.

The issue is around the change made in the current
document to add a ddp_post_recv() function. From a
pure architecture standpoint this has been deemed
unnecessary, and the previous form of ddp_recv()
will be restored, along with some new explanatory
text. In effect, this returns to the ddp_recv() formal
function returning a message_t, rather than a
necessarily pre-registered recv_message_t.

The difference is subtle but important. It is not
necessary to make the requirement of preregistration
for receives in the architecture, therefore the simplicity
argument prevails.

Any comments or concerns on the reversion to the
prior ddp_recv() behavior should be sent to the list as
soon as possible. There are currently no additional
outstanding comments or changes on either document.

Thanks,
Tom.

At 10:24 AM 3/5/2003, [email-masked] wrote:
>This message announces an informal Working Group
>Last Call on the RDDP problem statement and architecture
>drafts that are intended to become informational RFCs:
>
>- RDMA over IP Problem Statement,
>	draft-ietf-rddp-problem-statement-01.txt
>- The Architecture of Direct Data Placement (DDP) And 
>	Remote Direct Memory Access (RDMA) On Internet
>	Protocols, draft-ietf-rddp-arch-01.txt
>
>Due to the timing of the IETF meetings in San Francisco,
>this WG Last Call will run slightly longer than typical -
>it will end at 9am Eastern Time on Monday, March 31st,
>giving everyone a full week after the IETF meetings
>to review and comment on these drafts.
>
>Editorial comments should be sent directly to the
>draft editor: Thomas Talpey [[email-masked]].
>Technical comments and requests for changes must be
>sent to the RDDP mailing list [[email-masked]] for
>discussion.
>
>Thanks,
>--David [RDDP WG chair]
>
>----------------------------------------------------
>David L. Black, Senior Technologist
>EMC Corporation, 176 South St., Hopkinton, MA  01748
>+1 (508) 293-7953             FAX: +1 (508) 293-7786
>[email-masked]        Mobile: +1 (978) 394-7754
>----------------------------------------------------
>_______________________________________________
>rddp mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/rddp

_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: Caitlin Bestler <[email-masked]>
Date: Thu, 27 Mar 2003 15:05:26 -0600

>outstanding comments or changes on either document.

The iWARP suite relies upon the ULP to provide flow control.
It has no end-to-end flow control of its own.

Requiring receive buffers to be pre-registered, or even
pre-allocated, is a serious issue. It almost always makes
sense. However it is definitely not required for
interoperability, and there are some applications where it
can be shown that use of system buffering for untagged
messages would be superior to the traditional RDMA local
interface (as inherited from VIA and IB).

What I would suggest is that the requirement simply be that
the ULP must *authorize* each reception. The local interface
MUST allow the ULP to supply the buffer, and MAY require the
ULP to do so. The ULP MAY be allowed to pre-post a receive
authorization without supplying a pre-committed buffer.

This approach would keep the pre-posting of receive
operations, without requiring that a pre-registered
buffer be supplied.

Caitlin Bestler
http://asomi.com/CaitlinBestler/
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp