Subject: RE: [rddp] CRC mandatory?

From: "Larsen, Roy K" <[email-masked]>
Date: Mon, 5 May 2003 15:05:08 -0700

Amen!  Well said Jim.

Roy

-----Original Message-----
From: Williams, Jim [mailto:[email-masked]]
Sent: Monday, May 05, 2003 2:44 PM
To: [email-masked]
Subject: RE: [rddp] CRC mandatory?

I don't have a major problem with mandatory
CRCs, even if my reasons are a bit different.
But I do want to push back on some of the arguments,
though, to see if they hold up.

Jeff Hilland wrote:
> Caitlin brings out an excellent point below.  
> How is it that CRC32C is acceptable overhead for SCTP,
> but it is onerous for MPA?  

Dwight Barron wrote:
> Why shouldn't this place the burden of proof
> on those who oppose mandatory CRCs?

The Internet has grown from a laboritory curiosity
to a world wide phenominon based on using 16 bit
checksums.  SCTP, however, is not far beyond the
labority curiosity stage at the present time.
Is the world clamoring that TCP be replaced by
SCTP because TCP is corrupting too much data?
If so, SCTP should quickly become widely deployed,
and RDDP should simply ride this transition, and
use SCTP.

On the other hand, is TCP fine for its current
uses, but RDDP if fundamentally different and
requires a higher level of data integrity?
This seems like a difficult case to make given
the wide spread use of NFS and CIFS over TCP.
Is silent data corruption over RDDP worse than
silent data corruption over NFS or CIFS?
Is there a push to add more data integrity to
NFS?  If not, then this seems to add credibility
to the case that TCP as is provides sufficient
data integrity in many cases.

Sould RDDP to take the position that TCP is 
so deficient in data integrity that to NOT
use a CRC is irresponsible and therefore 
the CRC must be mandated?  Are there any
other protocols layered on TCP that
are a precedent for this?   The CRC for
iSCSI is optional.  Given that RDDP
proposes something new, I would submit
that the burden or proof would be on those
supporting mandatory CRC.

Because SCTP uses a CRC, it is suggested
that that proves a CRC is not too onerous
to add to a protocol layered on TCP.
This seems a stretch in a couple respects.
One being that two data checks are more
expensive than one, and not justified if
the first (TCP checksum) is sufficient.
Second, the jury is still out on SCTP
in a number of respects.  And RDDP is 
arguable targetted towards performance
critical applications more so than
SCTP.

_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: "John A. Thodiyil" <[email-masked]>
Date: Mon, 5 May 2003 15:20:06 -0700

I couldn't agree more!. CRC should be optional
in my opinion too.
-John

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Larsen, Roy K
Sent: Monday, May 05, 2003 3:05 PM
To: 'Williams, Jim'; [email-masked]
Subject: RE: [rddp] CRC mandatory?

Amen!  Well said Jim.

Roy