Subject: RE: [rddp] Marker Consensus Proposal

From: "Jim Pinkerton" <[email-masked]>
Date: Thu, 1 May 2003 13:48:27 -0700

After lengthy discussion, I have to agree that this seems to strike the
right balance between flexibility and allowing the receiver to maintain
the ability to optimize.

Jim

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Friday, April 25, 2003 9:41 AM
To: [email-masked]
Subject: [rddp] Marker Consensus Proposal

WG Chair hat firmly in place ...

Looking back on the discussion of markers, I'm going to attempt
to propose a way forward and hope the we can get WG rough consensus
for it.  The core of the proposal is what I originally posted a
couple of weeks ago:

	Make marker usage OPTIONAL,
	but put control of this option entirely in the hands of
	the receiver - senders MUST implement both markers and
not-markers,
	receivers MUST implement one OR the other, and each receiver
	gets to pick which one is used as the benefits of markers are
	primarily on the receiver side.

With the following additions:
- When markers are used, the marker interval MUST be 512 bytes.
- This proposed rough consensus assumes that we will be forced
	to do some sort of setup announcement as part of the
	"proof" requirement, which will provide a place to
	transmit options (and a version number).  Details of
	exactly how this works so that each receiver gets to
	pick what is sent to it are TBD.

This is not going to be the "perfect" answer for everyone, but
it's clear to me that WG rough consensus will not be obtained
for the positions at the end of the spectrum, namely:

- 512 byte markers MUST be used at all times
- Markers are completely optional

Further discussion/advocacy of those positions is probably
not productive.

I believe the above proposal is acceptable for the important
classes of implementations, and is technically sound.

Further comment to the list, please.

Thanks,
--David

----------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: John Hufferd <[email-masked]>
Date: Thu, 1 May 2003 16:46:14 -0700

I also agree with this.

.
.
John L. Hufferd
Senior Technical Staff Member (STSM)
IBM/System Group, San Jose CA
Main Office: (408) 256-0403, Tie: 276-0403, eFax: (408) 904-4688
Home Office: (408) 997-6136, Cell: (408) 499-9702
Internet Address: [email-masked]

"Jim Pinkerton" <[email-masked]>
Sent by: [email-masked]
05/01/2003 01:48 PM

        To:     <[email-masked]>, <[email-masked]>
        cc: 
        Subject:        RE: [rddp] Marker Consensus Proposal

Jim

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Friday, April 25, 2003 9:41 AM
To: [email-masked]
Subject: [rddp] Marker Consensus Proposal

                 Make marker usage OPTIONAL,
                 but put control of this option entirely in the hands of
                 the receiver - senders MUST implement both markers and
not-markers,
                 receivers MUST implement one OR the other, and each 
receiver
                 gets to pick which one is used as the benefits of markers 
are
                 primarily on the receiver side.

Thanks,
--David

---

From: "Barron, Dwight" <[email-masked]>
Date: Fri, 2 May 2003 08:59:16 -0500

I also agree this is a reasonable compromise. It allows each vendor to implement the design they think best matches market needs while establishing a solid interoperability requirement for all implementations. However, I had previously posted a concern that this compromise still might not meet the needs of the not-markers camp and I don't recall seeing any comments one way or the other. Explicit feedback would be appreciated. 

Regards,
Dwight 

> From: Jim Pinkerton [mailto:[email-masked]]
> Sent: Thursday, May 01, 2003 3:48 PM
> To: [email-masked]; [email-masked]

---

From: "Williams, Jim" <[email-masked]>
Date: Fri, 2 May 2003 10:47:37 -0400

> From: Barron, Dwight [mailto:[email-masked]]
> Sent: Friday, May 02, 2003 9:59 AM
> To: Jim Pinkerton; [email-masked]; [email-masked]
> I also agree this is a reasonable compromise. It allows each 
> vendor to implement the design they think best matches market 
> needs while establishing a solid interoperability requirement 
> for all implementations. However, I had previously posted a 
> concern that this compromise still might not meet the needs 
> of the not-markers camp and I don't recall seeing any 
> comments one way or the other. Explicit feedback would be 
> appreciated. 
> 
> Regards,
> Dwight 

I don't presume to speak for any "camp", not even the Emulex camp.
But, personally, I would strongly support this consensus proposal.
I believe it achieves the objective of allowing implementation 
and deployment experience to sort out value of markers.

 - Jim Williams

---

From: "Uri Elzur" <[email-masked]>
Date: Fri, 2 May 2003 10:56:38 -0700

David

In order to allow the group to make forward progress, I'd support your
call below. It allows for more efficient implementations to exist and to
interoperate with other implementations. It also narrows down the number
of options the implementer need to worry about, obviously good news.

Our challenge going forward is to make sure we do not burden high speed
implementations with a lengthy prologue. 

Uri

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Friday, April 25, 2003 9:41 AM
To: [email-masked]
Subject: [rddp] Marker Consensus Proposal

Looking back on the discussion of markers, I'm going to attempt to
propose a way forward and hope the we can get WG rough consensus for it.
The core of the proposal is what I originally posted a couple of weeks
ago:

This is not going to be the "perfect" answer for everyone, but it's
clear to me that WG rough consensus will not be obtained for the
positions at the end of the spectrum, namely:

I believe the above proposal is acceptable for the important classes of
implementations, and is technically sound.

Thanks,
--David

---

From: "Hilland, Jeff" <[email-masked]>
Date: Mon, 5 May 2003 14:27:07 -0500

I would agree that "receiver's choice" is the a reasonable compromise.
Regards,
Jeff

-----Original Message-----
From: Uri Elzur [mailto:[email-masked]] 
Sent: Friday, May 02, 2003 12:57 PM
To: [email-masked]; [email-masked]
Subject: RE: [rddp] Marker Consensus Proposal

David

Uri

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Friday, April 25, 2003 9:41 AM
To: [email-masked]
Subject: [rddp] Marker Consensus Proposal

Thanks,
--David