Subject: RE: [rddp] Re: Unreliable Transports (was re CRC mandatory? )

From: "Barron, Dwight" <[email-masked]>
Date: Wed, 7 May 2003 11:50:41 -0500

I agree with Caitlin and believe the discussions of CRC have been in the context of RDDP when mapped to a reliable, connected transport. In fact, I believe the WG has specifically stated that MPA is tied to TCP. That said, I don't necessarily draw the conclusion that an unreliable protocol mapping of RDDP would toss the CRC. Error detection at the receiver is still valuable, even if retransmission is not desired, as some receiver  schemas might want to toss known bad data and synthesize a replacement.

Regards,
Dwight

> -----Original Message-----
> From: Caitlin Bestler [mailto:[email-masked]]
> Sent: Wednesday, May 07, 2003 10:15 AM
> To: Stephen Bailey
> Cc: [email-masked]
> Subject: [rddp] Re: Unreliable Transports (was re CRC mandatory? )
> 
> 
> On 5/7/03, Stephen Bailey wrote:
> 
> >I think you've gone too far if you say CRC protection is a
> >specific instance of a general principle we should apply. 
> >CRC protection is CRC protection.  The general principle
> >is to leave as much flexibility to the implementations
> >while still providing a useful service.  Saying that RDDP
> >MUST run on a sequenced, reliable, CRC protected transport
> >seems ridiculous.
> 
> Agreed.
> 
> To be more precise, RDDP should have uniform expectations
> for sequenced/reliable transports.
> 
> It has been my assumption all along that RDDP maps very
> well to unreliable transports, but that the use of an
> unreliable transport is something that the ULP would
> request to meet specific requirements.
> 
> The specific issue that will have to be dealt with when
> we are ready to address unreliable transports is how the
> set of DDP Segments that form an atomic made it / lost it
> decision are identified. When we discussed this briefly
> on the old yahoo groups you seemed to favor having the
> receiving ULP make such determinations, I favored 
> explicitly labeling the RDMA Writes and Send that
> formed a cohesive accept it/drop it unit.
> 
> But I think we both agree that unreliable RDDP is a
> specialized application that can be dealt with after the
> reliable version has been fully dealt with. [And even if
> we don't, David would probably agree for us more vehemently,
> ;-) ].
> 
> Caitlin Bestler
> http://asomi.com/CaitlinBestler/
> _______________________________________________
> rddp mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/rddp
> 
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: Stephen Bailey <[email-masked]>
Date: Wed, 07 May 2003 14:24:02 -0400

> I agree with Caitlin and believe the discussions of CRC have been in the
> context of RDDP when mapped to a reliable, connected transport.

Oh.  Perhaps that wasn't clear (I didn't see `reliable, connected and
sequenced' anywhere juxtaposed with `uniform transport assumptions'),
or maybe I'm just a bullethead.

As long as everybody else is really just talking about to CRC or not
CRC, I'm less concerned :-).

Thanks,
  Steph