Subject: [rddp] CRC - partial rough consensus

From: [email-masked]
Date: Thu, 8 May 2003 17:24:44 -0400

The CRC discussion does not seem to be finished, but
I'd like to try to nail down some of the progress that
has been made.  I believe that there is RDDP WG rough
consensus for:

(A) CRC support MUST be implemented.

I'm going to refrain from calling consensus on
"OPTIONAL vs. MANDATORY to use" at this time (although I
think the discussion has focused on the key issue of the
level of service a ULP using RDDP over TCP should expect).

Nonetheless, *if* CRC usage is optional I believe that
there is WG rough consensus for:

(B) CRC usage is all-or-nothing on header and data.
	There is no requirement for CRC on header but
	not on data or CRC on data but not on header.

NB: This does not imply that there is a single CRC
	vs. split header and data CRCs, as there are some
	additional issues bearing on this.

(C) CRC usage is bidirectional.  Either CRCs are used
	in both directions on a connection, or in neither.
	There is no requirement for CRC usage in one
	direction and not the other.

(D) CRC omission requires consent of both ends of the
	connection.  If either end of the connection
	specifies that CRCs are to be used, then they
	MUST be used [in both directions (C)].  This entails
	some sort of mechanism to enforce CRC usage when
	the two ends of the connection start out with
	different preferences (or break the connection
	if the different preference have created a
	situation from which it is impossible to continue).

I'm also going to refrain from calling consensus on whether
the CRC field is present if CRC is not used - that seems
like an issue that ought to be taken up after the
requirements are settled.

Objections to the above four items of rough consensus should
be posted to the list.

Thanks,
--David

----------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: "Somesh Gupta" <[email-masked]>
Date: Thu, 8 May 2003 14:59:14 -0700

David,

I am not quite sure about the range of apps RDMA is
intended for, but Caitlin mentioned accessing web content.

It seems possible that if streaming media is one of
the apps, it may be acceptable to not have CRC on data,
while requiring CRC on the header??

Somesh

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> [email-masked]
> Sent: Thursday, May 08, 2003 2:25 PM
> To: [email-masked]
> Subject: [rddp] CRC - partial rough consensus
> 
>

---

From: Caitlin Bestler <[email-masked]>
Date: Thu, 8 May 2003 17:06:41 -0500

>while requiring CRC on the header??

Streaming Media could indeed use RDMA, but would definitely
prefer an unreliable or  partially reliable transport.
Randall's proposed PR-SCTP would serve as an excellent
transport. DCP would also work. Discussions on whether
RDMA inherently requires flow control (and hence not UDP)
can be dealt with when we are through with reliable
services. In that context omission of payload protection
may be appropriate, or in the flip direction use of FEC
might be just as valid of an option.

Caitlin Bestler
http://asomi.com/CaitlinBestler/
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: Caitlin Bestler <[email-masked]>
Date: Thu, 8 May 2003 17:10:25 -0500

>   direction and not the other.

I have no objection to this, but I am not certain as
to the benefit of it. Philosophically, I don't see why
my decision to require error protection on buffers sent
to my memory should be binding on my peer. The only real
benefit I can see is reducing two option bits to one.

But realistically, the specialized deployments and
applications where voiding the CRC would make sense are
likely to be symmetrical anyway.

Caitlin Bestler