Subject: RE: [rddp] silent dropping of TCP segment

From: "Culley, Paul" <[email-masked]>
Date: Thu, 25 Mar 2004 11:13:23 -0600

The use of "committed" does not imply that a segment is acknowledged,
only that this is the one that will be kept (a future segment with the
same sequence numbers will not be passed to MPA).

Any implementation that intends to drop segments based on CRC errors,
must be sufficiently integrated with TCP to insure that such segments
are not acknowledged; and thus will be re-transmitted.

I don't think that just deleting the MUST is sufficient, since there are
other implications, (and I'm not sure I remember them all).  I'm open to
suggestions...

Paul R. Culley
HP Fellow
281-514-5543

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Barry Reinhold
> Sent: Thursday, March 25, 2004 10:22 AM
> To: RDDP
> Subject: [rddp] silent dropping of TCP segment
> 
> 
> MPA clause 9, error semantics, states that an MPA aware TCP 
> implementation may silently drop a TCP segment when MPA 
> detects a CRC error. The goal of this TCP segment dropping 
> would be to avoid forcing the teardown of the stream by 
> having TCP retransmit the segment.
> 
> However, clause 5.1.2 on page 11 requires that 
> 
> "The TCP layer MUST have committed to keeping each segment 
> before it can be passed to the MPA." 
> 
> I assume "committed" means that TCP ACKs the segment. Thus 
> the segment is ACKed before it is delivered to MPA. If this 
> is the proper understanding I don't see how "MPA" can 
> silently drop a segment, since by the time it can detect a 
> CRC error TCP has already committed to it.
> 
> It is not clear to me why there is a "MUST" in clause 5.1.2. 
> It would seem desirable to allow MPA some control over when 
> the ACK is to be generated.
> 
> I would like to see the "MUST" removed from clause 5.1.2. 
> 
> Barry Reinhold
> Lamprey Networks
> [email-masked]
> (603) 868-8411
>  
> 
> 
> 
> 
> _______________________________________________
> rddp mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/rddp
> 

_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: Caitlin Bestler <[email-masked]>
Date: Thu, 25 Mar 2004 19:30:49 +0200

> other implications, (and I'm not sure I remember them all).  I'm open 

The way I've interpreted those clauses is that the TCP Layer
should only present a segment for placement that it has
*decided* to ack, and (as you state) will not be accepting
a further retransmission of.

The MPA driven "drop" essentially *reverses* that decision.

You could quibble about whether a decision that can be
overridden by MPA qualifies as "committed" or not. But
I believe the concept is fairly simply, it's just a matter of
agreeing on the right terms, or agreeing that the words
that are already there are compatible with what was meant.