Subject: [rddp] RE: iwarp-tech Conformance Question

From: "Carrier, John" <[email-masked]>
Date: Sat, 13 Nov 2004 06:17:42 -0800

Hi Barry,

my understanding is that CRCs are required unless both sides set the CRC bit to '0'.  If the reply frame from the responder has the C bit set to zero after the request frame had it set to one, then CRCs are required.  The responder may not be using them on receive, but it has to accept them from the initiator and it has to generate them on transmit 

--jc

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Barry Reinhold
> Sent: Friday, November 12, 2004 2:43 PM
> To: RDDP
> Cc: [email-masked]
> Subject: iwarp-tech Conformance Question
> 
> 
> Working on an interoperability issue related to section 
> 3.6.1.1 (CRC bit
> paragraph) of MPA, which states:
> 
> This bit (CRC bit) declares an endpoint's preferred CRC 
> usage. When this
> field is '0' in the "MPA Request Frame" and the "MPA Reply 
> Frame", CRCs
> MUST not be checked and need not be generated by either endpoint. When
> this bit is '1' in either the "MPA Request Frame" or "MPA 
> Reply Frame",
> CRCs MUST be generated and checked by both endpoints.
> 
> The question:
> 
> If an MPA request frame has set the CRC bit to 1, can the MPA replay
> frame's CRC bit be set to 0 without violating the draft.
> 
> >From a strict reading of the draft there does not seem to be a
> requirement that a "1" in the request results in a "1" in the reply,
> only that both devices must use CRCs.
> 
> So is the meaning of a "0" in the reply frame "I'm not using 
> CRCs, or is
> it I didn't want to use CRCs". Further if the requester sees 
> a 0 in the
> reply frame after setting the CRC bit to 1 in the request frame should
> it reset the connection?
> 
> Barry Reinhold
> Lamprey Networks
> [email-masked]
> (603) 868-8411
>  
> 
> 
> 
> 

_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: "Culley, Paul" <[email-masked]>
Date: Sun, 14 Nov 2004 18:46:28 -0600

If the requestor has set his to 1, then it does not matter what the
reply frame has in it, CRCs must be generated by both ends, and to be
compliant, must also be checked by both ends.  I suppose that a
non-compliant implementation could not check, or could tear down in this
case, but then it is not an IETF RNIC.

Paul R. Culley
HP Fellow
281-514-5543

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Carrier, John
> Sent: Saturday, November 13, 2004 8:18 AM
> To: Barry Reinhold
> Cc: [email-masked]; RDDP
> Subject: [rddp] RE: iwarp-tech Conformance Question
> 
> Hi Barry,
> 
> my understanding is that CRCs are required unless both sides 
> set the CRC bit to '0'.  If the reply frame from the 
> responder has the C bit set to zero after the request frame 
> had it set to one, then CRCs are required.  The responder may 
> not be using them on receive, but it has to accept them from 
> the initiator and it has to generate them on transmit 
> 
> --jc
> 
> > This bit (CRC bit) declares an endpoint's preferred CRC usage. When 
> > this field is '0' in the "MPA Request Frame" and the "MPA Reply 
> > Frame", CRCs MUST not be checked and need not be generated 
> by either 
> > endpoint. When this bit is '1' in either the "MPA Request Frame" or 
> > "MPA Reply Frame", CRCs MUST be generated and checked by both 
> > endpoints.
> > 
> > The question:
> > 
> > So is the meaning of a "0" in the reply frame "I'm not 
> using CRCs, or 
> > is it I didn't want to use CRCs". Further if the requester 
> sees a 0 in 
> > the reply frame after setting the CRC bit to 1 in the request frame 
> > should it reset the connection?
> > 
> > Barry Reinhold
> > Lamprey Networks
> > [email-masked]
> > (603) 868-8411
> >  
> > 
> > 
> > 
> > 
>