Subject: Re: [rddp] [Ips] STORM proposed charter - 31 May 2009 version

From: "David Harrington" <[email-masked]>
Date: Tue, 2 Jun 2009 10:19:24 -0400

Hi,

I am satisfied with the text of the charter.
The milestones look aggressive to me, but you have a better feel for
the amount of work involved. 

Thanks for the update,
David Harrington
[email-masked]
[email-masked]
[email-masked]

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of [email-masked]
> Sent: Sunday, May 31, 2009 4:03 PM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: [Ips] STORM proposed charter - 31 May 2009 version
> Importance: High
> 
> What I believe is the final draft of the proposed charter
> for the STORM WG is attached; I've done a bunch of editing
> and added the info about T10 and T11 doc access.  This is
> about to go out for wider review.
> 
> Also, a reminder that STORM discussion will stop cc:'ing
> other mailing lists soon.  If you're interested in STORM
> work, please subscribe to the [email-masked] mailing list:
> https://www.ietf.org/mailman/listinfo/storm
> 
> Finally - this is a near-final reminder that the [email-masked]
> mailing list will be closing soon - all discussion of RDDP
> protocols will move to the [email-masked] mailing list.
> 
> Thanks,
> --David
> ----------------------------------------------------
> David L. Black, Distinguished Engineer
> EMC Corporation, 176 South St., Hopkinton, MA  01748
> +1 (508) 293-7953             FAX: +1 (508) 293-7786
> [email-masked]        Mobile: +1 (978) 394-7754
> ----------------------------------------------------
>

---

From: arkady kanevsky <[email-masked]>
Date: Tue, 2 Jun 2009 17:25:30 -0400

David,The description of RDDP MPA bullet is too narrow.
(5) RDDP MPA: Good support for MPI applications requires a small
update to MPA startup functionality to allow either end
of the connection to initiate.

This bullet should also cover ORD/IRD negotiation as part of
connection setup. Also current RDDP connection setup is part of MPA
spec which is primarily for TCP stream markers. This bullet should provide
RDDP connection setup for both TCP and SCTP and for any message based
protocol.

How about:
(5) RDDP Connection Setup: Good support for MPI applications requires a
small
update to MPA startup functionality to allow either end
of the connection to initiate. Add RDMA Read credits to RDDP Connection
        Setup. Make RDDP connection setup to be applicable for any message
based
        protocols, including but not limited to TCP with MPA markers and
SCTP.

I hope it is not too late to beef up this bullet.
Thanks,
Arkady

On Sun, May 31, 2009 at 4:03 PM, <[email-masked]> wrote:

> _______________________________________________
> rddp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rddp
>
>

-- 
Cheers,
Arkady Kanevsky

---

From: <[email-masked]>
Date: Mon, 15 Jun 2009 14:45:43 -0400

Arkady,
 
I'll beef up the bullet, but probably not with that
degree of specifics.  Thanks for pointing this out,
and I apologize for the delay in responding.

Thanks,
--David

________________________________

	From: arkady kanevsky [mailto:[email-masked]] 
	Sent: Tuesday, June 02, 2009 5:26 PM
	To: Black, David
	Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
	Subject: Re: [rddp] STORM proposed charter - 31 May 2009 version

	David, 
	The description of RDDP MPA bullet is too narrow.
	(5) RDDP MPA: Good support for MPI applications requires a small
	update to MPA startup functionality to allow either end
	of the connection to initiate.

	This bullet should also cover ORD/IRD negotiation as part of
	connection setup. Also current RDDP connection setup is part of
MPA
	spec which is primarily for TCP stream markers. This bullet
should provide
	RDDP connection setup for both TCP and SCTP and for any message
based
	protocol.

	How about:
	(5) RDDP Connection Setup: Good support for MPI applications
requires a small
	update to MPA startup functionality to allow either end
	of the connection to initiate. Add RDMA Read credits to RDDP
Connection
	        Setup. Make RDDP connection setup to be applicable for
any message based
	        protocols, including but not limited to TCP with MPA
markers and SCTP.

		What I believe is the final draft of the proposed
charter
		for the STORM WG is attached; I've done a bunch of
editing
		and added the info about T10 and T11 doc access.  This
is
		about to go out for wider review.
		
		Also, a reminder that STORM discussion will stop cc:'ing
		other mailing lists soon.  If you're interested in STORM
		work, please subscribe to the [email-masked] mailing
list:
		https://www.ietf.org/mailman/listinfo/storm
		
		Finally - this is a near-final reminder that the
[email-masked]
		mailing list will be closing soon - all discussion of
RDDP
		protocols will move to the [email-masked] mailing list.
		
		Thanks,
		--David

	-- 
	Cheers,
	Arkady Kanevsky

---

From: <[email-masked]>
Date: Mon, 15 Jun 2009 14:53:23 -0400

And here's what I just did to that bullet ...

(5) RDDP Connection Setup: Good support for MPI applications requires a
small update to MPA startup functionality to allow either end of the
connection to initiate. In addition, a couple of minor changes to RDDP
connection setup (based on implementation experience) are needed to
generalize it for effective use with protocols that are not based on IP.

I'm about to send the result to Lars for wider review ...

Thanks,
--David

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of [email-masked]
	Sent: Monday, June 15, 2009 2:46 PM
	To: [email-masked]
	Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
	Subject: Re: [rddp] STORM proposed charter - 31 May 2009 version

	Arkady,

	Thanks,
	--David

		Sent: Tuesday, June 02, 2009 5:26 PM
		To: Black, David
		Cc: [email-masked]; [email-masked]; [email-masked];
[email-masked]
		Subject: Re: [rddp] STORM proposed charter - 31 May 2009
version

		David, 
		The description of RDDP MPA bullet is too narrow.
		(5) RDDP MPA: Good support for MPI applications requires
a small
		update to MPA startup functionality to allow either end
		of the connection to initiate.

		This bullet should also cover ORD/IRD negotiation as
part of
		connection setup. Also current RDDP connection setup is
part of MPA
		spec which is primarily for TCP stream markers. This
bullet should provide
		RDDP connection setup for both TCP and SCTP and for any
message based
		protocol.

		How about:
		(5) RDDP Connection Setup: Good support for MPI
applications requires a small
		update to MPA startup functionality to allow either end
		of the connection to initiate. Add RDMA Read credits to
RDDP Connection
		        Setup. Make RDDP connection setup to be
applicable for any message based
		        protocols, including but not limited to TCP with
MPA markers and SCTP.

		On Sun, May 31, 2009 at 4:03 PM, <[email-masked]>
wrote:

			What I believe is the final draft of the
proposed charter
			for the STORM WG is attached; I've done a bunch
of editing
			and added the info about T10 and T11 doc access.
This is
			about to go out for wider review.
			
			Also, a reminder that STORM discussion will stop
cc:'ing
			other mailing lists soon.  If you're interested
in STORM
			work, please subscribe to the [email-masked]
mailing list:
			https://www.ietf.org/mailman/listinfo/storm
			
			Finally - this is a near-final reminder that the
[email-masked]
			mailing list will be closing soon - all
discussion of RDDP
			protocols will move to the [email-masked]
mailing list.
			
			Thanks,
			--David
	
----------------------------------------------------
			David L. Black, Distinguished Engineer
			EMC Corporation, 176 South St., Hopkinton, MA
01748
			+1 (508) 293-7953             FAX: +1 (508)
293-7786
			[email-masked]        Mobile: +1 (978)
394-7754

		-- 
		Cheers,
		Arkady Kanevsky

---

From: "Pat Thaler" <[email-masked]>
Date: Mon, 15 Jun 2009 12:17:05 -0700

Did you mean "are not based on TCP" rather than "are not based on IP"?
Arkady was asking about connection setup for SCTP which the former fits but not the latter.

Regards,
Pat

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, June 15, 2009 11:53 AM
To: [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Ips] [rddp] STORM proposed charter - 31 May 2009 version

(5) RDDP Connection Setup: Good support for MPI applications requires a small update to MPA startup functionality to allow either end of the connection to initiate. In addition, a couple of minor changes to RDDP connection setup (based on implementation experience) are needed to generalize it for effective use with protocols that are not based on IP.

Thanks,
--David

From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]

Arkady,

Thanks,
--David

David,

How about:
(5) RDDP Connection Setup: Good support for MPI applications requires a small
update to MPA startup functionality to allow either end
of the connection to initiate. Add RDMA Read credits to RDDP Connection
        Setup. Make RDDP connection setup to be applicable for any message based
        protocols, including but not limited to TCP with MPA markers and SCTP.

On Sun, May 31, 2009 at 4:03 PM, <[email-masked]<mailto:[email-masked]>> wrote:

Also, a reminder that STORM discussion will stop cc:'ing
other mailing lists soon.  If you're interested in STORM
work, please subscribe to the [email-masked]<mailto:[email-masked]> mailing list:
https://www.ietf.org/mailman/listinfo/storm

Finally - this is a near-final reminder that the [email-masked]<mailto:[email-masked]>
mailing list will be closing soon - all discussion of RDDP
protocols will move to the [email-masked]<mailto:[email-masked]> mailing list.

Thanks,
--David
[email-masked]<mailto:[email-masked]>        Mobile: +1 (978) 394-7754

_______________________________________________
rddp mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rddp

--
Cheers,
Arkady Kanevsky

---

From: <[email-masked]>
Date: Mon, 15 Jun 2009 15:50:23 -0400

Hmm .. I read:
 
"but not limited to TCP with MPA markers and SCTP" as being motivated
by non-IP uses, e.g., InfiniBand and FC.  Arkady?

Thanks,
--David

	From: Pat Thaler [mailto:[email-masked]] 
	Sent: Monday, June 15, 2009 3:17 PM
	To: Black, David; [email-masked]
	Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
	Subject: RE: [rddp] STORM proposed charter - 31 May 2009 version

	Did you mean "are not based on TCP" rather than "are not based
on IP"?
	Arkady was asking about connection setup for SCTP which the
former fits but not the latter.
	 
	Regards,
	Pat

	Subject: Re: [Ips] [rddp] STORM proposed charter - 31 May 2009
version

	(5) RDDP Connection Setup: Good support for MPI applications
requires a small update to MPA startup functionality to allow either end
of the connection to initiate. In addition, a couple of minor changes to
RDDP connection setup (based on implementation experience) are needed to
generalize it for effective use with protocols that are not based on IP.

	Thanks,
	--David

		From: [email-masked]
[mailto:[email-masked]] On Behalf Of [email-masked]
		Sent: Monday, June 15, 2009 2:46 PM
		To: [email-masked]
		Cc: [email-masked]; [email-masked]; [email-masked];
[email-masked]
		Subject: Re: [rddp] STORM proposed charter - 31 May 2009
version

		Arkady,

		Thanks,
		--David

			From: arkady kanevsky
[mailto:[email-masked]] 
			Sent: Tuesday, June 02, 2009 5:26 PM
			To: Black, David
			Cc: [email-masked]; [email-masked]; [email-masked];
[email-masked]
			Subject: Re: [rddp] STORM proposed charter - 31
May 2009 version

			David, 
			The description of RDDP MPA bullet is too
narrow.
			(5) RDDP MPA: Good support for MPI applications
requires a small
			update to MPA startup functionality to allow
either end
			of the connection to initiate.

			This bullet should also cover ORD/IRD
negotiation as part of
			connection setup. Also current RDDP connection
setup is part of MPA
			spec which is primarily for TCP stream markers.
This bullet should provide
			RDDP connection setup for both TCP and SCTP and
for any message based
			protocol.

			How about:
			(5) RDDP Connection Setup: Good support for MPI
applications requires a small
			update to MPA startup functionality to allow
either end
			of the connection to initiate. Add RDMA Read
credits to RDDP Connection
			        Setup. Make RDDP connection setup to be
applicable for any message based
			        protocols, including but not limited to
TCP with MPA markers and SCTP.

			I hope it is not too late to beef up this
bullet.
			Thanks,
			Arkady

			On Sun, May 31, 2009 at 4:03 PM,
<[email-masked]> wrote:

				What I believe is the final draft of the
proposed charter
				for the STORM WG is attached; I've done
a bunch of editing
				and added the info about T10 and T11 doc
access.  This is
				about to go out for wider review.
				
				Also, a reminder that STORM discussion
will stop cc:'ing
				other mailing lists soon.  If you're
interested in STORM
				work, please subscribe to the
[email-masked] mailing list:

				Finally - this is a near-final reminder
that the [email-masked]
				mailing list will be closing soon - all
discussion of RDDP
				protocols will move to the
[email-masked] mailing list.
				
				Thanks,
				--David
	
----------------------------------------------------
				David L. Black, Distinguished Engineer
				EMC Corporation, 176 South St.,
Hopkinton, MA  01748
				+1 (508) 293-7953             FAX: +1
(508) 293-7786
				[email-masked]        Mobile: +1
(978) 394-7754

	

			-- 
			Cheers,
			Arkady Kanevsky

---

From: arkady kanevsky <[email-masked]>
Date: Mon, 15 Jun 2009 16:32:44 -0400

David,
I was not proposing to extend it beyond IP based protocols.
Specifically I am trying to ensure that new spec can support
TCP/MPA and SCTP. Other protocols that are not IP based
or not even Ethernet based, in my view, are outside the scope of IETF.

In essense, it is RDMA connection setup on top of message
based protocol. So It be done on top of TCP/MPA, or SCTP or
maybe some other message based protocols that use IP.
Thanks,
Arkady

On Mon, Jun 15, 2009 at 2:45 PM, <[email-masked]> wrote:

>  ------------------------------
> *From:* arkady kanevsky [mailto:[email-masked]]
> *Sent:* Tuesday, June 02, 2009 5:26 PM
> *To:* Black, David
> *Cc:* [email-masked]; [email-masked]; [email-masked]; [email-masked]
> *Subject:* Re: [rddp] STORM proposed charter - 31 May 2009 version
>
>   David, The description of RDDP MPA bullet is too narrow.

-- 
Cheers,
Arkady Kanevsky

---

From: <[email-masked]>
Date: Mon, 15 Jun 2009 16:38:02 -0400

Ok, I'll fix it.

Thanks,
--David

	From: arkady kanevsky [mailto:[email-masked]] 
	Sent: Monday, June 15, 2009 4:33 PM
	To: Black, David
	Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
	Subject: Re: [rddp] STORM proposed charter - 31 May 2009 version

	David,
	I was not proposing to extend it beyond IP based protocols.
	Specifically I am trying to ensure that new spec can support
	TCP/MPA and SCTP. Other protocols that are not IP based
	or not even Ethernet based, in my view, are outside the scope of
IETF.

		Arkady,

		Thanks,
		--David

			From: arkady kanevsky

			David, 

			How about:

				

				
				Thanks,
				--David

	

			-- 
			Cheers,
			Arkady Kanevsky

	-- 
	Cheers,
	Arkady Kanevsky