Subject: [regext] Add an attribute for extension, draft-gould-eppext-verificationcode-03

From: 周贵卿 <[email-masked]>
Date: Wed, 11 May 2016 18:57:58 +0800 (GMT+08:00)

James,

As described in the draft-gould-eppext-verificationcode-03, CNNIC use this model provides verification service as VSP.
In the implementation, I found the schema defined the EPP info command with date attribute extension. So  I think about it may useful to add an optional attribute of “crDate” to the verificationCodeType, and it represent the date of Verification Code generated, it could be define like below:
<complexType name="verificationCodeType">
  <simpleContent>
    <extension base="verificationCode:verificationCodeValueType">
      <attribute name="type" type="token" use="required"/>
      <attribute name="crDate" type="dateTime" use="optional"/>
    </extension>
  </simpleContent> 
</complexType>

Although this attribute is not used currently, but may be used in future, because a Verification Code may have a expiration for the policy modification or improvement. In other words, for example: a label “abc”‘s Verification Code  which is requested by registrar a years ago may not valid now, because ”abc“ may be not a valid word now for some reason. 
    That is a assumption, but in practice, that is really occurred. I suggest add this attribute, for product and technical point, this attribute may be used by some registry, registry can estimate whether a Verification Code is valid  for create a new domain, for example,  180 days after generated, registrar need request a new Verification Code to conform latest policy.
    
Thank you for kindly attention and Looking forward to your reply, 
--
GuiQing Zhou
CNNIC

---

From: "Gould, James" <[email-masked]>
Date: Fri, 20 May 2016 13:42:19 +0000

Thank you for your proposal.  I certainly do not want to describe or imply any policy around verification code expiry, but I don’t see an issue with the inclusion of an optional creation date attribute in the verification code to simply capture when the verification code was created.  If an optional crDate attribute was supported with the verificationCodeType element on transform commands, then it would also be needed in the infoVerificationCodeType element to be able to include it in the extension to the info response.  Are there any objections with the inclusion of an optional crDate attribute?

Thanks,

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

VerisignInc.com<http://VerisignInc.com>

On May 11, 2016, at 6:57 AM, 周贵卿 <[email-masked]<mailto:[email-masked]>> wrote:

James,

Thank you for kindly attention and Looking forward to your reply,
--
GuiQing Zhou
CNNIC
_______________________________________________
regext mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/regext