Subject: [regext] Comment on draft-brown-epp-fees-07 regarding default domain:period in domain:check reply

From: Patrick Mevzek <[email-masked]>
Date: Tue, 05 Jul 2016 17:00:54 +0200

Dear colleagues,

A question/comment on §5.1.1 of the fee specification:
   o  An OPTIONAL <fee:period> element, which contains the same unit
      that appeared in the <fee:currency> element of the command.  If
      the value of the preceding <fee:command> element is "restore",
      this element MUST NOT be included.  Otherwise it MUST be
included.
      If no <fee:period> appeared in command (and the command is not
      "restore") then this element MUST have a value of 1 year.

</quote>

Why is 1 year hardcoded there ?

Some registries, for some periods and/or some domains, may offer only
registrations for some given amount of years, and not necessarily 1.
I've already seen registries using 2 years as default and minimum
values (hence 2 to 10), and other registries offering some specific
values such as only 2, 5 or 10 for example.

In short, why hardcoding 1 year here instead of saying that in this
case the registries should reply with its default value (the same one
that will be used during a domain:create or other commands without a
domain:period), which can be any number based on local policies
(and may be different depending on the commands, it can be 2 years for
create, but 1 for transfers) ?

-- 
Patrick Mevzek

---

From: Tongfeng Zhang <[email-masked]>
Date: Thu, 7 Jul 2016 16:51:47 +0000

In addition to Patrick's comments, I also have comments on the statement of  "<fee:period> *must* be included in all commands other than restore".

If a registry decided to charge on "delete" and "update" commands, I don't see the period info applicable to these commands. It might be better to specify the list of commands (create, renew, transfer) that must have period element.

Thanks,
Tongfeng Zhang

-----Original Message-----
From: regext [mailto:[email-masked]] On Behalf Of Patrick Mevzek
Sent: Tuesday, July 05, 2016 11:01 AM
To: [email-masked]
Subject: [regext] Comment on draft-brown-epp-fees-07 regarding default domain:period in domain:check reply

Dear colleagues,

      this element MUST NOT be included.  Otherwise it MUST be included.

</quote>

Some registries, for some periods and/or some domains, may offer only registrations for some given amount of years, and not necessarily 1.
I've already seen registries using 2 years as default and minimum values (hence 2 to 10), and other registries offering some specific values such as only 2, 5 or 10 for example.

In short, why hardcoding 1 year here instead of saying that in this case the registries should reply with its default value (the same one that will be used during a domain:create or other commands without a domain:period), which can be any number based on local policies (and may be different depending on the commands, it can be 2 years for create, but 1 for transfers) ?

--
Patrick Mevzek

_______________________________________________
regext mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/regext