Subject: [regext] draft-ietf-eppext-keyrelay

From: Ulrich Wisser <[email-masked]>
Date: Thu, 28 Jul 2016 11:46:12 +0000

Hi all,

BCP 79 only requires the IPR declaration and some information on the
licensing policy.
No concrete license fees or policy is required. In it's IPR Verisign has
agreed to apply one of the following options

   - a) No License Required for Implementers
   - b) Royalty-Free, Reasonable and Non-Discriminatory License to All
   Implementers
   - c) Reasonable and Non-Discriminatory License to All Implementers with
   Possible Royalty/Fee

So maybe the WG can decide if that is enough information. I believe if we
indicate that the WG is
content with the information provided by Verisign, the IESG will forward
the document.

/Ulrich
-- 
Ulrich Wisser
[email-masked]

---

From: Rik Ribbers <[email-masked]>
Date: Thu, 28 Jul 2016 12:29:34 +0000

All,

Thx Ulrich for bringing this to the mailing list. I have sent a lengthy email to WG-chairs and ADs on this issue but this mail sums it up quite easily. This is my understanding:

I have re-read BCP-79 on the train home from IETF and I have to agree with Scott that the IPR-disclosure on the keyrelay draft is conform BCP-79, as licence details are not mandatory.

On 28 Jul 2016, at 13:46, Ulrich Wisser <[email-masked]<mailto:[email-masked]>> wrote:

 I believe if we indicate that the WG is
content with the information provided by Verisign, the IESG will forward the document

As far as I see it the IPR-disclosure is conform BCP-79 and should not be blocking publication. The WG has not discussed the IPR-disclosure at all in public, so implementers will have to consider this IPR disclosure themselves before implementing this (My company had legal advice in this specific case).  Of coarse I agree that an updated IPR-disclosure with licensing details makes it easier for implementers to make an informed decision but it is not necessary. So I am content with the information provided by Verisign.

I would love to hear from others, especially the WG-chairs an ADs what they think on this matter.

Gr,
Rik