Subject: Re: [regext] Using RDAP as a Domain Availability Service

From: "Gould, James" <[email-masked]>
Date: Fri, 16 Dec 2016 17:22:25 +0000

That is one of my concerns, RDAP is a lookup protocol and not the SRS and should only return data that exists with no reasons why it does not exist other than scenarios like authorization issues or when data can be found elsewhere by reference.  We have not defined the use cases and it should not be assumed that because RDAP provides registration data that it should also support availability logic like the SRS.  Can we clearly define the use case of this undefined service?  I view this as a separate service from the SRS and RDAP to meet the undefined needs of a yet to be defined set of users.

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

VerisignInc.com<http://verisigninc.com/>

From: regext <[email-masked]> on behalf of Francisco Obispo <[email-masked]>
Date: Friday, December 16, 2016 at 11:54 AM
To: Andrew Newton <[email-masked]>
Cc: Registration Protocols Extensions <[email-masked]>
Subject: [EXTERNAL] Re: [regext] Using RDAP as a Domain Availability Service

I don’t like having to implement an RDAP client that would have to send two queries.

One to get the domain information, and if the resource does not exist, then another query to see if it’s available.

Checking for a reason on why the domain name is not available could or could not be expensive, but this should not be a reason to disallow it at the ‘presentation’ layer of the protocol.

In my opinion, we should have some OPTIONAL fields in the original negative response to signal whether the name is available or not, and if not, a way to provide a reason. If this is mandated or not by registry policy / contract, it should be a different issue.

regards

Francisco Obispo
CTO - Registry Operations
____________________________

[niregistry]<http://www.uniregistry.com/>

2161 San Joaquin Hills Road
Newport Beach, CA 92660

Office +1 949 706 2300 x4202
[email-masked]

On 16 Dec 2016, at 3:34, Andrew Newton wrote:

This topic keeps appearing over and over again, so Marcos and I
decided to address it.
As it turns out, there's not much needed to achieve this. This draft
suggests two new query parameters and re-uses the current RDAP domain
query. In other words, its a very small addition to RDAP.

-andy

A new version of I-D, draft-newton-regext-rdap-domain-availability-00.txt
has been successfully submitted by Andrew Lee Newton and posted to the
IETF repository.

Name: draft-newton-regext-rdap-domain-availability
Revision: 00
Title: Using RDAP as a Domain Availability Service
Document date: 2016-12-16
Group: Individual Submission
Pages: 6
URL:
https://www.ietf.org/internet-drafts/draft-newton-regext-rdap-domain-availability-00.txt
Status:
https://datatracker.ietf.org/doc/draft-newton-regext-rdap-domain-availability/
Htmlized:
https://tools.ietf.org/html/draft-newton-regext-rdap-domain-availability-00

Abstract:
This document describes a minimal profile of RDAP which can be used
to check the availability of domain names available for registration.

_______________________________________________
regext mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/regext

---

From: "Francisco Obispo" <[email-masked]>
Date: Fri, 16 Dec 2016 14:37:38 -0800

Hi James,

From what I’ve seen, the expectation is that RDAP will substitute port 43 WHOIS.

We (uniregistry) currently do availability checks when the domain is not registered AND we also provide a very specific reason on why a domain is not available.

Customers also want to know if a specific domain is under a specific policy that might change in the near future, for instance when we launched out TLDs we had a large set that was held back for a period of time (A.K.A. names collision), and just showing as “object does not exist” did not provide information on why and whether the name would be available in the future. We had to become very explicit when our support queue was growing very large from customers asking for a specific reason and/or dates when they could register the names.

For us, RDAP has to cover both use cases. Whether a registry is obligated to provide an availability check or reason why the object is not available, should be mandated by policy and not in anyway by limitations of the protocol.

Best regards,

—
Francisco Obispo
Uniregistry Inc.

---

From: Keith Gaughan <[email-masked]>
Date: Wed, 21 Dec 2016 16:11:54 +0000

On 16/12/16 22:37, Francisco Obispo wrote:

> For us, RDAP has to cover both use cases. Whether a registry is
> obligated to provide an availability check or reason why the object is
> not available, should be mandated by policy and not in anyway by
> limitations of the protocol.

It might serve a registry's purposes, but if falls far short of the
needs of registrars, especially given we need to do fast bulk checks of
domain, which RDAP doesn't allow for, but both EPP and a protocol along
the lines of the Nominet DAC protocol do, along with providing a way to
send back extra relevant information concerning the domains queried.

k.

-- 
Keith Gaughan, Development Lead; PGP/GPG key ID: D5FC9D23
Blacknight Internet Solutions Ltd. <http://blacknight.host/>
12A Barrowside Business Park, Carlow, R93 X265, Ireland
Registered in Ireland, Company No.: 370845