Subject: Re: [regext] RDAP lookup queries for reserved or unassignable domains

From: "Gould, James" <[email-masked]>
Date: Wed, 7 Dec 2016 17:12:31 +0000

Andrew,

Yes, RDDS is aware of the data but not of all the business rules that is needed to support the SRS.  RDDS is a lookup protocol and just because there is one or some implementations out there that have included additional logic does not mean that it is a standard that “we” need to conform to.  We need to keep the SRS logic in the SRS and leave RDDS to strictly a lookup protocol.  

-- 
 
JG
 
James F. Gould
Distinguished Engineer
Verisign
[email-masked]

On 12/7/16, 12:04 PM, "regext on behalf of Andrew Sullivan" <[email-masked] on behalf of [email-masked]> wrote:

    On Wed, Dec 07, 2016 at 03:30:24PM +0000, Gould, James wrote:
    > It sounds like you’re attempting to morph RDDS into the SRS.
    
    Nope.
    
    >RDDS is a lookup service and the SRS is an OLTP system.  A lookup
    > service either has the data or it doesn’t.  Extra business logic
    > associated with availability (variant blocking, relationship
    > blocking, reserved domains, etc.) should be left to the appropriate
    > channel which is the SRS and not RDDS.
    
    Also nope.  The idea that the Registration Data Directory Service
    doesn't have knowledge about the Registration Data such that the
    repository policies are a secret from the RDDS strikes me as at least
    unintuitive.  Moreover, since one RDDS service (whois) already
    actually has mechanisms for communicating such information today at
    least in some implementations, we have running code that we need to
    conform to.
    
    Best regards,
    
    A
    -- 
    Andrew Sullivan
    [email-masked]
    
    _______________________________________________
    regext mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/regext

---

From: Mario Loffredo <[email-masked]>
Date: Wed, 7 Dec 2016 18:17:21 +0100

> Yes, RDDS is aware of the data but not of all the business rules that is needed to support the SRS.  RDDS is a lookup protocol and just because there is one or some implementations out there that h…
Dear all,

I was not suggesting anything with my question.
I was only asking myself and you about which HTTP response code had to 
be used in this particular case.
I was not sure about the meaning of the statement "Clients ... use the 
HEAD method to determine existence of data on the server" in RFC 7480.
The last answers of James and John makes clear to me that there is no 
relation between the absence of domain data in RDAP and domain 
availability in EPP and
that the empty response is correct.

Thank you all,
Mario

-- 
Dr. Mario Loffredo
Servizi Internet e Sviluppo Tecnologico
Unità Sistemi e Servizi Registro .it
CNR - Istituto di Informatica e Telematica
via G. Moruzzi 1, I-56124 PISA, Italy
E-Mail: [email-masked]
Phone: +39 050 3153497
Web: http://www.iit.cnr.it/mario.loffredo

---

From: Rubens Kuhl <[email-masked]>
Date: Wed, 7 Dec 2016 15:18:32 -0200

> Em 7 de dez de 2016, à(s) 15:12:000, Gould, James <[email-masked]> escreveu:
> 
> Andrew,
> 

This will be even more applicable if/when the domain value chain implements transactional integrity, where if a lookup for a domain said the price for domain was X$, that EPP client can safely request a transaction that will be billed for that amount. 

Rubens