Subject: [regext] Proposed Changes to Milestones

From: "James Galvin" <[email-masked]>
Date: Fri, 19 May 2017 09:40:42 -0400

During the last IETF meeting we had a request to adopt another document. 
  As part of that discussion our AD expressed concern about the number 
of documents currently on our list and the number of milestones 
currently on our list.

The Chairs took an action to review both of these and we now have a 
proposal for consideration by the working group.

To see the list of current milestones review this link:

https://datatracker.ietf.org/group/regext/about/

To see the list of current documents review this link:

https://datatracker.ietf.org/group/regext/documents/

The Chairs have contacted the authors of all documents and asked for 
their feedback regarding the status of their document, reviewed the 
current proposed milestone dates, and propose the following.  These are 
shown as they are listed in the current milestones.

draft-ietf-regext-launchphase
   WGLC finished. Waiting for shepherd write-up adjustments before 
submitting to IESG.
   Action: Change milestone date to June 2017.

draft-ietf-regext-tmch-func-spec
   Status changed to Informational. Changed to Parked document.
   Action: Delete from milestone list.

draft-ietf-regext-epp-rdap-status-mapping
   RFC 8056
   Action: Set Status Resolved on milestone list.

draft-ietf-regext-epp-fees
   Recent version submitted. Active discussion.
   Action: Change milestone date to July 2017.

draft-ietf-regext-reseller
draft-ietf-regext-reseller-ext
   These drafts have been replaced by draft-ietf-regext-org and 
draft-ietf-regext-org-ext.
   Active discussion.
   Action: Accept new documents, replace on milestones, Change milestone 
date to Nov 2017.

draft-gould-eppext-verificationcode
   No reaction from authors.
   Action: Replace to draft-ietf-regext-verificationcode on milestone 
list
   Change milestone date to June 2018.

draft-xie-eppext-nv-mapping
   (current milestone listing but document is really 
draft-ietf-regext-nv-mappgin)
   Informational document, waiting for 
draft-ietf-regext-verificationcode
   Action: Change to parked document. Delete from milestone list.

draft-gould-change-poll (change to draft-ietf-regext-change-poll)
   Needs more reviewers and implementation.
   Action: Change milestone date to Nov 2017.

draft-gould-allocation-token (change to 
draft-ietf-regext-allocation-token)
   Needs implementation status section and review.
   Action: Change milestone date to Nov 2017.

draft-ietf-regext-bundling-registration
   New version submitted for STRICT bundling.
draft-ietf-eppext-idnmap
draft-gould-idn-table
draft-cira-regext-idn
   These documents have discussion but no consensus. All these documents 
relate.
   Some want all IDN to be included in bundling discussion.
   Action: Discuss.  Chairs do not have a proposal for a milestone date 
of these documents.  We need input from the working group.

draft-ietf-regext-dnsoperator-to-rrr-protocol
   Wants to move to WGLC, but had little review on mailing list.
   Action: Change milestone date to Jan 2018.

Other WG documents not on milestone list:

draft-ietf-regext-validate
   Adopted. To be pursued after draft-ietf-regext-epp-fees.
   Action: Add to milestone list with date May 2018.

draft-hollenbeck-regext-rdap-object-tag
   Scott requested WG adoption.
   Action: Formal WG adoption request on mailing list before adding to 
milestones and after revising existing milestone list.

Specific questions to the working group:

1. Do you agree with the proposed dates for milestones?  If not, please 
suggest other dates and indicate why you believe your date should be 
preferred.  If you agree, please show your support on the list.

2. Do you agree with the documents selected to be parked or dropped?  If 
not, please suggest a milestone date and indicate why you believe the 
working group should keep this document on its milestone list.  If you 
agree, please show your support on the list.

3. Please suggest how you believe the working group should handle the 
bundling and IDN drafts?  Should they be kept together?  Should they be 
separated?  Why or why not?  Please also suggest a milestone date if you 
believe we should keep one or more of these documents active.

Antoin and Jim

---

From: Roger D Carney <[email-masked]>
Date: Fri, 19 May 2017 15:01:03 +0000

Good Morning,

Thanks Jim/Antoin for working through all of these documents.

I think these updates look good, except for a question on the reseller documents. As I mentioned on list back in March, I thought in Seoul we decided to review and comment but to not dedicate WG effort to these drafts?

As far as the bundling and idn drafts, I have not followed these with too much intensity so I will defer to others on these documents.

Thanks

Roger

-----Original Message-----
From: regext [mailto:[email-masked]] On Behalf Of James Galvin
Sent: Friday, May 19, 2017 8:41 AM
To: Registration Protocols Extensions <[email-masked]>
Subject: [regext] Proposed Changes to Milestones

  As part of that discussion our AD expressed concern about the number of documents currently on our list and the number of milestones currently on our list.

The Chairs took an action to review both of these and we now have a proposal for consideration by the working group.

The Chairs have contacted the authors of all documents and asked for their feedback regarding the status of their document, reviewed the current proposed milestone dates, and propose the following.  These are shown as they are listed in the current milestones.

   WGLC finished. Waiting for shepherd write-up adjustments before submitting to IESG.

   RFC 8056

   These drafts have been replaced by draft-ietf-regext-org and draft-ietf-regext-org-ext.

   Active discussion.

   Action: Accept new documents, replace on milestones, Change milestone date to Nov 2017.

   Action: Replace to draft-ietf-regext-verificationcode on milestone list

draft-ietf-eppext-idnmap

draft-gould-idn-table

draft-cira-regext-idn

   These documents have discussion but no consensus. All these documents relate.

   Action: Discuss.  Chairs do not have a proposal for a milestone date of these documents.  We need input from the working group.

   Action: Formal WG adoption request on mailing list before adding to milestones and after revising existing milestone list.

Antoin and Jim

_______________________________________________

regext mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/regext

---

From: Antoin Verschuren <[email-masked]>
Date: Mon, 22 May 2017 12:11:41 +0200

Thank you for your support Roger,
I answered your reseller drafts question in another message.

We would like to get more support for our proposed changes.
But as a matter of process, we intend to make these changes to the milestones beginning next week if there are no clear objections, so we can start planning for design team progress on our milestone drafts.

If we cannot get enough consensus on the bundling and IDN drafts because there is no clear technical solution, demand or traction yet, a pragmatic proposal could also be to delete them from our milestones for now, and we can always add them again later. But at least we will know what we are working on now, and we could adopt new documents that do have traction.
We’re interested on your thoughts.

- --
Antoin Verschuren

Tweevoren 6, 5672 SB Nuenen, NL
M: +31 6 37682392

Op 19 mei 2017, om 17:01 heeft Roger D Carney <[email-masked]> het volgende geschreven:

> [email-masked]
> [email-masked]

---

From: "Jiankang Yao" <[email-masked]>
Date: Mon, 22 May 2017 22:59:19 +0800 (GMT+08:00)

Dear Antoin Verschuren,

   Some comments are inline below.

   Thanks.

发件人:"Antoin Verschuren" <[email-masked]>
发送时间:2017-05-22 18:11:41 (星期一)
收件人: "Registration Protocols Extensions" <[email-masked]>
抄送:
主题: Re: [regext] Proposed Changes to Milestones

>If we cannot get enough consensus on the bundling and IDN drafts because there is no clear technical solution, demand or traction yet,

For strict bundling registration, there is  clear technical solution, demand or traction , especially for those registries who sell Chinese Domain Names. The mechanisms described in draft-ietf-regext-bundling-registration have been adopted by many registries such as CNNIC, TWNIC, HKIRC and DotASIA. The proposed mechanisms have been used since 2003.

If someone tries to combine both relax bundling and strict bundling together, I agree that there are no easy solution.

But for separated documents, the strict bundling document(draft-ietf-regext-bundling-registration ) is clear and enough to be pushed forward.

>a pragmatic proposal could also be to delete them from our milestones for now,

I do not agree with it here.

I suggest to keep the  strict bundling registration document and move it forward. This document is very useful for those who plan to use  strict bundling registration.

>We’re interested on your thoughts.

Pls see above.

Thanks a lot.

Jiankang Yao

Good Morning,

 

Thanks
Roger

-----Original Message-----
From: regext [mailto:[email-masked]] On Behalf Of James Galvin
Sent: Friday, May 19, 2017 8:41 AM
To: Registration Protocols Extensions <[email-masked]>
Subject: [regext] Proposed Changes to Milestones

 

 

 

 

 

 

 

 

Antoin and Jim

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 22 May 2017 15:35:35 +0000

> Sent: Friday, May 19, 2017 9:41 AM
> Subject: [EXTERNAL] [regext] Proposed Changes to Milestones
>
>   As part of that discussion our AD expressed concern about the number of
> documents currently on our list and the number of milestones currently on
> our list.
>
> The Chairs have contacted the authors of all documents and asked for their
> feedback regarding the status of their document, reviewed the current
> proposed milestone dates, and propose the following.  These are shown as
> they are listed in the current milestones.

[snip]

>    Needs more reviewers and implementation.

Implementation isn't a requirement for WG adoption or publications as a Proposed Standard. As long as "needs ... implementation" means "nice to note if it exists", OK.

> agree, please show your support on the list.

Yes, I agree with the proposed changes.

> believe we should keep one or more of these documents active.

I would really like to hear more from the people who need these drafts before I form an opinion.

Scott

---

From: Antoin Verschuren <[email-masked]>
Date: Tue, 23 May 2017 10:58:22 +0200

> I support the proposed changes. One minor note:

Thank you Scott,

> Implementation isn't a requirement for WG adoption or publications as a Proposed Standard. As long as "needs ... implementation" means "nice to note if it exists", OK.

You’re right, but this was the comment made by the authors on what they still wanted to do before the document was ready for WGLC to set a date in our milestones.
The document is already adopted by the WG, but it could do with more review and implementation experience beyond Verisign according to the authors.

regards,

- --
Antoin Verschuren

---

From: "Gould, James" <[email-masked]>
Date: Tue, 23 May 2017 12:13:33 +0000

To support Antoin, I’m asking for those in the working group to review and provide feedback publically or privately on draft-ietf-regext-change-poll, and to let the authors know of any existing implementations or planned implementations of draft-ietf-regext-change-poll for inclusion in an Implementation Status section.  If would be useful for registrars to weigh in on the importance of registries to implement this extension to proactively inform them of server-side changes (e.g., modifying the statuses of objects based on court orders or based on server policy, deleting unlinked objects).  This extension can handle many use cases, so hopefully more registries implement it and more and more use cases are covered by it.  

Thanks,     
  
—
 
JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

VerisignInc.com <http://verisigninc.com/> 

On 5/23/17, 4:58 AM, "regext on behalf of Antoin Verschuren" <[email-masked] on behalf of [email-masked]> wrote:

    
    Thank you Scott,

    
    regards,

    - --
    Antoin Verschuren