Subject: Re: [renum] I-D Action:draft-boot-brdp-framework-00.txt

From: Brian E Carpenter <[email-masked]>
Date: Sun, 20 Feb 2011 10:37:20 +1300

Hi,

I had a quick look at this interesting proposal. As far as the RENUM
BOF goes, I think it is just a point of information as we really don't
expect to discuss solutions in Prague. But it's a very interesting
approach to the problem. A couple of general questions:

How does this relate to the techniques in draft-v6ops-multihoming-without-nat66?

Will it work OK with NPTv6 (draft-mrw-nat66, which is not about NAT66)?

Is there any prototype code?

Regards
   Brian Carpenter

On 2011-02-01 01:30, [email-masked] wrote:
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 	Title           : BRDP Framework
> 	Author(s)       : T. Boot, A. Holtzer
> 	Filename        : draft-boot-brdp-framework-00.txt
> 	Pages           : 24
> 	Date            : 2011-01-31
> 
> This document describes the Border Router Discovery Protocol (BRDP)
> framework.  This framework enables multi-homing for small to medium
> sites, using Provider Aggregatable IPv6 addresses.  It describes a
> mechanism for automated IP address configuration and renumbering, a
> mechanism for optimized source address selection and a new paradigm
> for packet forwarding.  The BRDP framework prevents ingress filtering
> problems with multi-homed sites and supports load-balancing for
> multi-path transport protocols.  This work also prevents routing
> scalability problems in the provider network and Internet Default
> Free Zone because small to medium multi-homed size sites would not
> need to request Provider Independent address blocks.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-boot-brdp-framework-00.txt

---

From: Teco Boot <[email-masked]>
Date: Mon, 21 Feb 2011 13:30:44 +0100

Hi Brian,

> How does this relate to the techniques in draft-v6ops-multihoming-without-nat66?
This work also includes scenarios and problem statement. It is highly related. BRDP is defined for multi-hop edge networks, particularly MANETs. So the scenario's do differ somewhat.

Source address selection and next-hop selection is addressed by BRDP. I assume DNS server selection is addressed by MIF.

I think requirements for policy enforcement can be implemented in the BRDP Framework. I'll wait on what Fred Baker brings in. 

On solutions, IMHO BRDP differs from other proposals. It suggests a cooperation between hosts and routers. Hosts may select any address it has configured, routers direct sent packets to gateways that corresponds to the source address. Routers provide hints for address and next-hop selection. This enables powerful tools like MPTCP, for all scenario's in draft-v6ops-multihoming-without-nat66.
Maybe add the BRDP approach in this document?
[Fred has also ideas, with similar approach. Not written down yet. Correct?]

> Will it work OK with NPTv6 (draft-mrw-nat66, which is not about NAT66)?
It is OK when Border Routers uses NPTv6.
BRDP suggests a prefix per border router. This brings MPTCP, guidance for DNS server selection etc. But needs modified routers, and evolutionary updated hosts for full functionality.
NPTv6 is based on GSE, so same family as ILNP. I'll include NPTv6 in a next version.

> Is there any prototype code?
In simulation. 
Intentions to have running code, for the MANET case.

Thanks, Teco
  
> _______________________________________________
> renum mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/renum