Subject: Re: [renum] Reminder: reviews requested: draft-carpenter-6renum-static-problem-01.txt

From: Brian E Carpenter <[email-masked]>
Date: Thu, 02 Feb 2012 08:58:21 +1300

There have been no more comments on this draft. Now the authors
need to decide whether this means that the document is perfect
and ready for WG adoption, or that nobody thinks it discusses
an important problem in renumbering.

Please comment...

Regards
   Brian

On 2012-01-04 15:17, Brian E Carpenter wrote:
> Hi,
> 
> This has been updated following the comments received so far. Now
> we are requesting reviews from the WG. Additional authors with personal
> expertise would be welcome too.
> 
>    Brian and Sheng.
> 
> 
> -------- Original Message --------
> Subject: I-D Action: draft-carpenter-6renum-static-problem-01.txt
> Date: Mon, 05 Dec 2011 14:46:52 -0800
> From: [email-masked]
> Reply-To: [email-masked]
> To: [email-masked]
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 	Title           : Problem Statement for Renumbering IPv6 Hosts with Static Addresses
> 	Author(s)       : Brian Carpenter
>                           Sheng Jiang
> 	Filename        : draft-carpenter-6renum-static-problem-01.txt
> 	Pages           : 10
> 	Date            : 2011-12-05
> 
>    This document analyses the problems of updating the IPv6 addresses of
>    hosts in enterprise networks that for operational reasons require
>    static addresses.
> 
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-carpenter-6renum-static-problem-01.txt
> 
> 
> 
>

---

From: "Leo Liu(bing)" <[email-masked]>
Date: Tue, 07 Feb 2012 03:34:41 +0000

Hi, Brian

I read the draft, and I think the section2 analysis is comprehensive, I only have some general comments:

1. Static & Manual. Static doesn't mean manual configuration, but manual configuration may always be static. As I understood, none of the static instances in section2 is caused by situations that only support manual configuration? So I'm wondering if there are situations that manual configuration is needed because of lack of proper automatic configuration protocol or operational issues. Manually configuring 128bit IPv6 address would be a nightmare for the administrators, so I believe the requirement of avoiding manual configuration in IPv6 is much stronger than in IPv4.

2. Some of the static configuration may be very hard to be avoided, say, the router/firewall. So maybe we need to differentiate the problem statement that some of them are solvable while others are not?

Overall, I support this document, I think it's an unevadable issue in renumbering that at least we should document it.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Brian E Carpenter
> Sent: Thursday, February 02, 2012 3:58 AM
> To: [email-masked]
> Subject: Re: [renum] Reminder: reviews requested:
> draft-carpenter-6renum-static-problem-01.txt
> 
> _______________________________________________
> renum mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/renum