Subject: Re: [renum] Working Group Last Call: draft-ietf-6renum-static-problem-01.txt

From: RJ Atkinson <[email-masked]>
Date: Wed, 19 Sep 2012 08:43:34 -0400

Hi,

	While I am not a subscriber to this WG list,
I have a few comments on draft-ietf-6renum-static-problem-01.
I have tried to organise the comments by Section.

Section 2.2, 1st Paragraph:
	For about a decade now, most network-capable printers 
	have silently and automatically enabled SLP without 
	requiring any user interaction.  Such printers often
	use a factory-default algorithm to generate a printer
	name, unless a user has explicitly configured a 
	printer name.
	
	Hosts that are SLP-aware, automatically discover such 
	printers and can use them, without requiring the printer 
	to have a preconfigured fixed IP address.  Many deployed 
	hosts have supported SLP for the past decade.

	So, the statement that "It is also unusual to enable 
	the Service Location Protocol for the same purpose..."
	is not correct in the deployed world.  It was correct
	in the 1990s.  It has not been correct for about a
	decade, however.

Section 2.2, Last Paragraph:
	The DNS Service Discovery (DNS-SD) technology
	described in draft-cheshire-dnsext-dns-sd-11.txt
	is directly relevant and should be both mentioned
	and referenced in this paragraph.  mDNS is great,
	but for the problems of Section 2.2, mDNS really
	works much more effectively in combination with
	DNS-SD.  The RFC Editor web site indicates that
	both DNS-SD and mDNS are IN-QUEUE for publication
	on the IETF standards track.

	Also, since around 2005/2006, many printers have
	shipped with mDNS/DNS-SD silently and automatically
	enabled (in addition to SLP).  Further, many Windows
	PCs, all Apple Macs, and many UNIX systems have
	silently enabled mDNS/DNS-SD support for printing.
	(NOTE: I'm told that when one installs "iTunes" onto 
	MS Windows, the installer silently installs mDNS/DNS-SD 
	support also, since mDNS/DNS-SD is how iTunes finds 
        "shared libraries" of digital content.)  So the last 
        paragraph also needs to be edited to clarify that the 
	mDNS/DNS-SD combination is now widely supported and 
	widely deployed for a range of services, including 
	location of network printers.

Otherwise the I-D seems fine to me.

Yours,

Ran

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 19 Sep 2012 14:41:39 +0100

Hi Ran,

Thanks for the comments. We are in WG Last Call until Sept. 28 so
we will roll all the comments up at that time.

See my small comments in line below.

Regards
   Brian

> 	in the 1990s.  It has not been correct for about a

Opinions on the extent of deployment seem to differ, judging by
some recent comments on the homenet WG list. I recently had occasion
to install an HP printer and it was necessary to install some proprietary
discovery software on the (Windows) hosts as well; so at least in that case
there was no SLP by default. But we can certainly remove "unusual"
and say something like "It is not universal to enable...".

> 	location of network printers.

Again, this has come up recently in homenet, and whether mDNS
or "genuine" DNS is the way to go is a hot topic. The issue with
mDNS is that it only works on a bridged network, as I understand
it, which is an issue in many enterprise networks (our scope
for 6renum).

> _______________________________________________
> renum mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/renum
>