Subject: [rfc-i] updates to bibxml

From: "HANSEN, TONY L" <[email-masked]>
Date: Sun, 18 Dec 2016 02:46:04 +0000

I made two changes to the bibxml library, a change to bibxml7/bibxml-doi and a new bibxml8/bibxml-iana.

The bibxml7 (aka bibxml-doi) library was done using a program that does a real-time lookup of the DOI library. It now takes an argument of anchor=TEXT. When you add this, the <reference> anchor element will use the text you provide. (Only A-Za-z0-9_ is allowed in the anchor.)

https://xml2rfc.tools.ietf.org/public/rfc/bibxml-doi/reference.DOI.10.1145/1355734.1355746.xml?anchor=TEXT

generates

<reference anchor="TEXT"> …

I’ve also just added bibxml8 (aka bibxml-iana) that generates a <reference> to an IANA registry.

https://xml2rfc.tools.ietf.org/public/rfc/bibxml-iana/reference.IANA.service-names-port-numbers.xml

generates

<reference anchor="SERVICE-NAMES-PORT-NUMBERS" target="http://www.iana.org/assignments/service-names-port-numbers"><front><title>Service Name and Transport Protocol Port Number Registry</title><author surname="Internet Assigned Numbers Authority (IANA)"><organization/></author></front></reference>

If you prefer a different anchor value, you can also use the anchor=TEXT argument, generating

<reference anchor="TEXT" …

Hope you like these additions.

Comments welcome.

                Tony Hansen
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: "Andrew G. Malis" <[email-masked]>
Date: Sun, 18 Dec 2016 09:53:51 -0500

Tony,

Very nice, thanks!

Cheers,
Andy

On Sat, Dec 17, 2016 at 9:46 PM, HANSEN, TONY L <[email-masked]> wrote:

> The bibxml7 (aka bibxml-doi) library was done using a program that does a
> real-time lookup of the DOI library. It now takes an argument of
> anchor=TEXT. When you add this, the <reference> anchor element will use the
> text you provide. (Only A-Za-z0-9_ is allowed in the anchor.)
>
>
>
> https://xml2rfc.tools.ietf.org/public/rfc/bibxml-doi/
> reference.DOI.10.1145/1355734.1355746.xml?anchor=TEXT
>
>
>
> generates
>
>
>
> https://xml2rfc.tools.ietf.org/public/rfc/bibxml-iana/
> reference.IANA.service-names-port-numbers.xml
>
>
>
> generates
>
>
>
> <reference anchor="SERVICE-NAMES-PORT-NUMBERS" target="
> http://www.iana.org/assignments/service-names-port-numbers"><front><title>Service
> Name and Transport Protocol Port Number Registry</title><author
> surname="Internet Assigned Numbers Authority (IANA)"><organization/></
> author></front></reference>
>
>
>

---

From: Alice Russo <[email-masked]>
Date: Mon, 19 Dec 2016 15:49:55 -0800

Thanks very much for these, Tony.

For bibxml8, would you please change to simply "IANA" as follows? This would be in keeping with how references to IANA registries typically appear in RFCs. (Also, using the organization element is preferred when the author is an org.)

OLD
<author surname="Internet Assigned Numbers Authority (IANA)"><organization/></author>

NEW
<author><organization>IANA</organization></author>

Thank you.

Alice Russo
RFC Production Center

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Tue, 20 Dec 2016 05:01:31 +0000

Sure, this change has been made.

	Tony

On 12/19/16, 6:49 PM, "Alice Russo" <[email-masked]> wrote:

    
    OLD
    
    NEW
    
    Thank you.
    
    Alice Russo
    RFC Production Center