Subject: [rfc-i] Rendering of xml2rfc v3 fragments

From: Marc Petit-Huguenin <[email-masked]>
Date: Sun, 8 Jan 2017 16:42:53 -0800

Is there any plan for the various renderers for the xml2rfc v3 (text, html, pdf) to be able to generate output for xml fragments, as opposed to a whole document?

I see some use cases for that, for example to insert normative text into a source program.

Thanks.

-- 
Marc Petit-Huguenin
Email: [email-masked]
Blog: https://marc.petit-huguenin.org
Profile: https://www.linkedin.com/in/petithug

_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Tue, 24 Jan 2017 05:43:44 -0800

> I see some use cases for that, for example to insert normative text into a source program.

Did not receive any answer on that, but I have another question about the xml2rfc v3 program:  

Will there a way to smoothly integrate a new renderer, like a plugin?  I am trying to add a new writer in xml2rfc v2, and that means modifications in the code that require to ship the whole code, instead of just the code for the new output format.  Having the possibility of plugins with xml2rfc v3 would make that easier.

Thanks.