Subject: Re: [rfc-i] [IAB] Fwd: Call for Comment: <draft-iab-rfc-preservation-03> (Digital Preservation Considerations for the RFC Series)

From: Donald Eastlake <[email-masked]>
Date: Wed, 1 Feb 2017 14:26:32 -0500

I agree with John Levine.

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

On Tue, Jan 31, 2017 at 6:02 PM, Heather Flanagan (RFC Series Editor)
<[email-masked]> wrote:
> On 1/26/17 8:06 PM, John Levine wrote:
>>> Abstract
>>>
>>>   The RFC Editor is both the publisher and the archivist for the RFC
>>>   Series.  This document applies specifically to the archivist role of
>>>   the RFC Editor.  It provides guidance on when and how to preserve
>>>   RFCs, and the tools required to view or re-create RFCs as necessary.
>>>   This document also highlights where gaps are in the current process,
>>>   and where compromises are suggested to balance cost with ideal best
>>>   practice.
>> I'm generally in agreement with the advice in this draft, except for
>> the parts about paper.
>>
>> We know that good quality paper with black ink is stable for
>> centuries, because we have books from the 1700s and earlier in
>> libraries that we can still read.  I also know a surprising number of
>> people doing retrocomputing who retype source code from old printouts
>> from the 1960s.  After 50 years, the electronic media are missing or
>> unreadable, but the printouts are still OK.
>>
>> So I would suggest printing out the XML and perhaps one of the
>> formatted versions (so they can see what the XML is supposed to say)
>> of RFCs on good paper and filing them away.  I think we can assume
>> that OCR in the future will be at least as good as it is now, so as
>> long as the printouts use a reasonable typeface, it'll be possible to
>> scan them in if need be.  It doesn't have to be in real time; a
>> printathon once or twice a year should be plenty.
>>
>
> Thank you for the feedback, John. Paper can indeed be a very stable
> material for archival purposes. For digital-born documents, I think it's
> insufficient for the purpose of archiving all the information intended
> to be captured with a digital document and leaving it readable for the
> future. Yes, information can be printed out that describes the metadata
> for the document. The XML is human readable, in that it is not encrypted
> or compiled in any way that a standard text reader and printer couldn't
> handle. However, all that readable-but-not-user-friendly paper takes up
> space and requires its own expertise to store and maintain in a properly
> archival fashion. The RFC Editor does not have that experience, nor the
> proper space, to store an ever growing body of work. We could of course
> work on that, buying the correct paper and ink, reprinting all the RFCs,
> and finding suitable climate (both humidity and temperature, with
> appropriate fire suppression) controlled storage to house the material.
> But that seems like a waste of resources when there are actual
> archivists who can and will handle our material properly, in its digital
> form.
>
> That said, of the archivists I've approached about the Series, the only
> paper of interest is the original set that has unique, hand-written
> annotations in the margins. All the newer documents are only interesting
> in their digital form. The content is still interesting, but it takes up
> much less physical space, and they have the processes in house for
> handling the issues of bit rot. They also expect to support the
> readability of the material (since we are using common publication
> formats) far into the future.
>
>
> Thanks,
> Heather
>
>
>
> _______________________________________________
> rfc-interest mailing list
> [email-masked]
> https://www.rfc-editor.org/mailman/listinfo/rfc-interest
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: David Barak <[email-masked]>
Date: Wed, 1 Feb 2017 21:37:12 +0000 (UTC)

I used to be a collections management historian for the HABS/HAER project, and that role was about ensuring archival stability of records.  The only media which were deemed stable at the time were paper (500 years) ink-on-vellum (200 years), black& white photographs (150 years) and color transparencies (75 years).  No other medium was deemed stable for more than about 20years.  I would advocate for using stable paper as the primary archival means of retaining the content for the long term - records can be re-digitized via new technology in a straightforward manner, but digital access can be easily lost in unrecoverable manners.
Creating stable paper records is neither difficult nor expensive, and the actual volume of all of the RFCs is not large relative to other paper collections. David Barak 
Need Geek Rock? Try The Franchise: 
http://www.cdbaby.com/all/thefranchise 

    On Wednesday, February 1, 2017 11:27 AM, Donald Eastlake <[email-masked]> wrote:

Thanks,
Donald

_______________________________________________
Architecture-discuss mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/architecture-discuss

---

From: Larry Masinter <[email-masked]>
Date: Fri, 3 Feb 2017 18:56:34 +0000

RFC 7995 calls for use of PDF/A-3, which was designed for long-term preservation.
“PDF for Long-term Preservation, Use of ISO-32000-1, With Embedded Files”
With the XML embedded.

I’m not an archivist but I played one,  viz http://larrymasinter.net/0603-archiving.pdf
http://www.digitalpreservation.gov/formats/intro/intro.shtml

Larry