Subject: [rfc-i] xml2rfc schema for draft version

From: Phillip Hallam-Baker <[email-masked]>
Date: Thu, 13 Jul 2017 10:22:56 -0400

I would like the xml2rfc schema to separate the declaration of the document
name and version number for drafts.

The reason I have always made this division in my tools is that I can't be
bothered to track version numbers. Updating them is a chore, I always have
to check to see whether I did it. That is something that must be done by a
machine, not the user.

So today's hack is going to be implementing that for Markdown and Word
input streams. I realized I already have most of the code.

This would require some change to SeriesInfo.
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Julian Reschke <[email-masked]>
Date: Thu, 13 Jul 2017 16:37:42 +0200

On 2017-07-13 16:22, Phillip Hallam-Baker wrote:
> I would like the xml2rfc schema to separate the declaration of the 
> document name and version number for drafts.
> 
> The reason I have always made this division in my tools is that I can't 
> be bothered to track version numbers. Updating them is a chore, I always 
> have to check to see whether I did it. That is something that must be 
> done by a machine, not the user.
> 

This should be discussed on xml2rfc or xml2rfc-dev.

(FWIW, we tried not to change things that aren't broken, and I don't 
believe that the current format is broken enough to justify a change)

Best regards, Julian

---

From: Martin Thomson <[email-masked]>
Date: Fri, 14 Jul 2017 16:13:24 +1000

On 14 July 2017 at 00:22, Phillip Hallam-Baker <[email-masked]> wrote:
> [...] I can't be

I have no problem with status quo.  Think of the entire name as a
version identifier.  That you need a new name each time you submit is
a feature.  (I have tooling that manages a default value for the new
name, it's not that difficult.)
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest