Subject: [rfc-i] Link to current list of IAB members

From: Phillip Hallam-Baker <[email-masked]>
Date: Wed, 12 Jul 2017 18:15:06 -0400

If people would like the IAB boilerplate to be done correctly, it would be
nice if there was a preset link to the current list of members somewhere so
that I can put that in the tool.

Otherwise, I think you would want to modify the xml2rfc schema to include
the info.
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: "Heather Flanagan (RFC Series Editor)" <[email-masked]>
Date: Wed, 12 Jul 2017 16:14:04 -0700

On 7/12/17 3:15 PM, Phillip Hallam-Baker wrote:
> If people would like the IAB boilerplate to be done correctly, it would
> be nice if there was a preset link to the current list of members
> somewhere so that I can put that in the tool.
> 
> Otherwise, I think you would want to modify the xml2rfc schema to
> include the info.
> 

Are you thinking something like a processing instruction?

--Heather

---

From: Martin Thomson <[email-masked]>
Date: Thu, 13 Jul 2017 09:37:04 +1000

> Are you thinking something like a processing instruction?

XInclude would work if someone were to host a file with that list.
Given how often the IAB publishes something, it might be
over-optimizing though.
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Wed, 12 Jul 2017 20:16:34 -0400

> Are you thinking something like a processing instruction?

​Oh please no. Processing instructions are bogus.

I was thinking a <contributor> element would be the most general way to
express the information. Which I will actually need for OASIS docs anyway.​
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Wed, 12 Jul 2017 20:19:02 -0400

> Given how often the IAB publishes something, it might be
​IAB changes much less frequently than I recompile code.

XInclude to a document containing a list of <contributor> elements would
work.

Or we could use <author> and define contributor as a role. That would
require least change to the schema.

BTW, I have the schema converted to XSD if anyone needs it.​