Subject: [rfc-i] Full author names in rfc-index.xml?

From: "Eggert, Lars" <[email-masked]>
Date: Tue, 25 Jul 2017 13:49:36 +0000

Hi,

rfc-index.xml traditionally has only included first name initials. Since the datatracker has had full author names for a while now, would it be possible to include those in rfc-index.xml? Gives more complete information for tools that operate on rfc-index.xml.

Lars
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Julian Reschke <[email-masked]>
Date: Tue, 25 Jul 2017 16:23:09 +0200

> rfc-index.xml traditionally has only included first name initials. Since the datatracker has had full author names for a while now, would it be possible to include those in rfc-index.xml? Gives mor…

FWIW, it should contain sufficient information to produce citations - 
this includes separating last names from initials as well.

Best regards, Julian

PS: feels like 10 years ago that I started asking for this...

---

From: "Eggert, Lars" <[email-masked]>
Date: Tue, 25 Jul 2017 14:31:30 +0000

On 2017-7-25, at 16:23, Julian Reschke <[email-masked]> wrote:
> FWIW, it should contain sufficient information to produce citations - this includes separating last names from initials as well.

Agreed.

Lars

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 26 Jul 2017 08:35:26 +1200

>> FWIW, it should contain sufficient information to produce citations - this includes separating last names from initials as well.

And it needs to handle all cases: Jordi Palet Martinez a.k.a. J. Palet for example,
preferences such as family name coming first in some languages, and certainly more
obscure special cases too.

   Brian

---

From: "Eggert, Lars" <[email-masked]>
Date: Wed, 26 Jul 2017 06:18:02 +0000

Since the data tracker (in my understanding) handles this, the ask is simply use use the information there to populate the RFC index. (I think it is auto-generated based on data tracker info anyway now.)

-- 
Sent from a mobile device; please excuse typos.
+49 151 120 55791

> On Jul 25, 2017, at 22:35, Brian E Carpenter <[email-masked]> wrote:
>