Subject: [rfc-i] Some RFC editing questions

From: Toerless Eckert <[email-masked]>
Date: Wed, 27 Sep 2017 18:15:14 +0200

Redirect to better place welcome if this iss the wrong list for these questions...

Q1: Is there some recommended XML formatter for IETF draft XML (trying to unify draft
from multiple authors that used various XML formattings).

Q2: Is there a way to rsync the XML sources of RFCs (not of drafts) ?

Thanks!
    Toerless
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 27 Sep 2017 18:25:00 +0200

> from multiple authors that used various XML formattings).

Don’t do that if the sources are under version control (which they should be in 2017).

xmllint ––format is the canonical formatter for XML.

But preferably don’t do that.

(The tendency of XML to deteriorate its source formatting is one of the reasons collaborative editing works so much better in markdown.  Sure, there is still a tendency to reformat paragraphs in markdown source, but it seems easier for markdown to just not do it.)

> Q2: Is there a way to rsync the XML sources of RFCs (not of drafts) ?

I don’t think these are available.
(Of course, people like Julian and me have a stash of these from the AUTH48 stage.
But at least my stash is not nearly complete.)
Note that, when I last looked, the actual publishing pipeline went from RFCXML to nroff (where a few final tweaks are made) to txt.
So there may not be a piece of XML that describes an RFC, even if that RFC was generated from XML.

Henrik now has a tool to up-convert from .txt to .xml.

Grüße, Carsten

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 27 Sep 2017 19:15:13 +0200

On Wed, Sep 27, 2017 at 06:25:00PM +0200, Carsten Bormann wrote:
> Don???t do that if the sources are under version control (which they should be in 2017).

The sources are in a git. I would just like to clean the formatting of the XML source.
Obviously this would be a separate commit so that one isn't mixing textual changes
with XML formatting changes in a single commit.

> xmllint ??????format is the canonical formatter for XML.
> 
> But preferably don???t do that.
> 

What do you mean with markdown ? Using an editor that already produces some standard format XML output ?

> I don???t think these are available.

Ok., that explains why my seearches went nowhere. So i have to stick using the
latest draft versions XML to copy& paste stuff. I was primarily trying to
find some good SVG examples in RFCs to see if it makes sense to upgrade
myself out of ascii art.

> Henrik now has a tool to up-convert from .txt to .xml.

Nice. URL ?

---

From: Julian Reschke <[email-masked]>
Date: Wed, 27 Sep 2017 19:27:55 +0200

> with XML formatting changes in a single commit.

Carsten's poibt being that this can be problematic if multiple people 
edit, and do not agree on the formatting.

> What do you mean with markdown ? Using an editor that already produces some standard format XML output ?

No. See <https://github.com/cabo/kramdown-rfc2629>.

> latest draft versions XML to copy& paste stuff. I was primarily trying to

Is there a specific RFC for which you need the XML? You can always ask 
the RFC Editor for a copy.

> find some good SVG examples in RFCs to see if it makes sense to upgrade

We don't have RFCs with SVG art yet.

>> Henrik now has a tool to up-convert from .txt to .xml.

<https://pypi.python.org/pypi/id2xml>

Best regards, Julian

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 27 Sep 2017 19:29:32 +0200

> On Sep 27, 2017, at 19:15, Toerless Eckert <[email-masked]> wrote:
> 

Yes, but that commit will destroy git-blame capability.
(If you have never used this — it is extremely useful to find out who made a change when and in which context.)
A reformatting commit essentially cuts off your history.

> What do you mean with markdown ? Using an editor that already produces some standard format XML output ?

Not editing XML, but markdown.

http://rfc.space

> find some good SVG examples in RFCs to see if it makes sense to upgrade

There is no SVG in current RFCs that I know of.

(Well, except for the SVG *source* in RFC 7992.)

>> Henrik now has a tool to up-convert from .txt to .xml.

https://xml2rfc.tools.ietf.org/

(I need to get my experimental RFCXML to markdown converter fixed and up there as well…)

Grüße, Carsten

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 27 Sep 2017 19:49:34 +0200

On Wed, Sep 27, 2017 at 07:27:55PM +0200, Julian Reschke wrote:
> Carsten's poibt being that this can be problematic if multiple
> people edit, and do not agree on the formatting.

Ok.

> No. See <https://github.com/cabo/kramdown-rfc2629>.

*sigh* ok. Looks nice, but i am not sure if i want to learn yet another
markup language right now. Or persuade collaborators of it. I wrote
my own markup converter at the end of the 80th to create framemaker output
and lived through a lot of wiki markups, so i am a bit disillusioned about
ever more variations that won't survive at least a decade.  Let me know
when kramdown is older than a decade and i may give it a try.

> We don't have RFCs with SVG art yet.

Ah, too bad. But the toolchains support it now, eg: one could include
SVG into an XML draft and get it published and the eg: PDF/HDML would
include it ?

E.g.: if the toolchain is ready, i guess i would start giving SVG
a try in so far as creating picture slides for meeting presentations
with SVG, and then later putting them into drafts. WOuld be a big
step forward from all tht throwaway PPT work these days for meetings.

> <https://pypi.python.org/pypi/id2xml>

Thanks & cheers
    Toerless

-- 
---
[email-masked]

---

From: Julian Reschke <[email-masked]>
Date: Wed, 27 Sep 2017 19:57:08 +0200

> when kramdown is older than a decade and i may give it a try.

I prefer XML as well.

> SVG into an XML draft and get it published and the eg: PDF/HDML would

The official tool chain: not yet.

Alternative ones, yes, see 
<https://www.greenbytes.de/tech/webdav/rfc2629xslt/v3test.html#n-svg> 
and <https://www.greenbytes.de/tech/webdav/rfc2629xslt/rfc2629xslt.html>.

> ...

Best regards, Julian

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Thu, 28 Sep 2017 17:28:37 +0000

On 9/27/17, 1:15 PM, "rfc-interest on behalf of Toerless Eckert" <[email-masked] on behalf of [email-masked]> wrote:

    
    Nice. URL ?

It’s installable using pip, or you can use the online form at http://xml2rfc.tools.ietf.org (look for the 2nd form on that page).

	Tony Hansen