Subject: Re: [rfc-i] Errata Reference Format

From: Martin Thomson <[email-masked]>
Date: Mon, 25 Sep 2017 11:32:03 +1000

Hi Heather:

There is no way to go from a search:
  e.g., https://www.rfc-editor.org/errata_search.php?rfc=7919

To a specific erratum:
  e.g., https://www.rfc-editor.org/errata/eid4908

Could I request that the erratum ID be turned into a link?

The format I get is a little odd:

small: Found 1 record.
huge: Status: Reported (1)
large: RFC 7919, "Negotiated Finite Field Diffie-Hellman Ephemeral
Parameters for Transport Layer Security (TLS)", August 2016
small: Source of RFC: tls (sec)
small: Errata ID: 4908
medium: Status: Reported
medium: Type: Technical
small: Reported By: Martin Thomson
small: Date Reported: 2017-01-16

I don't know why "Status: Reported (1)" appears so prominently.  It
could be removed.  And the metadata is inconsistently formatted.  I'd
suggest:

small: Found 1 record.
large:Errata ID: 4908 <- link
medium: RFC 7919, "Negotiated Finite Field Diffie-Hellman Ephemeral
Parameters for Transport Layer Security (TLS)", August 2016
small: Source of RFC: tls (sec) <- keep the existing links
small: Status: Reported <- bold
small: Type: Technical <- bold
small: Reported By: Martin Thomson
small: Date Reported: 2017-01-16

At the same time, I'd request that you change the stylesheet to
include pre { overflow-x: auto;  } rather than pre { overflow: scroll;
overflow-y: hidden; }

On Fri, May 5, 2017 at 9:33 AM, Heather Flanagan (RFC Series Editor)
<[email-masked]> wrote:
> On 3/11/17 5:55 AM, Julian Reschke wrote:
>> <https://tools.ietf.org/html/draft-flanagan-7322bis-00#section-4.8.6.5>:
>>
>>> 4.8.6.5.  Referencing Errata
>>>
>>>    The following format is required when a reference to an erratum
>>>    report is necessary:
>>>
>>>    [ErrNumber]  RFC Errata, Erratum ID number, RFC number, <URI>.
>>>
>>>    [Err1912]  RFC Errata, Erratum ID 1912, RFC 2978, xxx.
>>
>> In V3, we'd format that as:
>>
>>> <reference anchor="Err1912" quoteTitle="false" target="xxx">
>>>   <front>
>>>     <title>Errata ID 1912</title>
>>>     <author><organization>RFC Errata</organization></author>
>>>   </front>
>>>   <seriesInfo name="RFC" value="2978"/>
>>> </reference>
>>
>> Observations:
>>
>> 1) That makes it look like this references actually RFC 2978, so the
>> seriesInfo element is very misleading.
>>
>> 2) No date is specified.
>>
>> Proposal:
>>
>> <reference anchor="Err1912" quoteTitle="false"
>> target="https://www.rfc-editor.org/errata_search.php?eid=1912">
>>   <front>
>>     <title>RFC 2978 Erratum 1912</title>
>>     <author><organization>RFC Errata</organization></author>
>>   </front>
>>   <seriesInfo name="RFC Errata" value="1912"/>
>>   <date year="2009" month="October"/>
>> </reference>
>>
>> Giving:
>>
>> [Err1912]  RFC Errata, RFC 2978 Erratum 1912, RFC Errata 1912, October
>>            2009, <https://www.rfc-editor.or/errata_search.php?eid=1912>
>>
>> a) This make seriesInfo actually meaningful.
>>
>> b) The URI of course should be aligned with what the future format is;
>> for instance <https://www.rfc-editor.org/errata/1912>.
>>
>> c)
>> <https://greenbytes.de/tech/webdav/rfc7991.html#element.reference.attribute.quoteTitle>
>> allows us to have an unquoted title, but I'd like to question whether we
>> *really* need a special case here.
>>
>> Best regards, Julian
>>
>
> Hello all,
>
> The effort to make better, stable errata URLs is done. The format of the
> URL is:
>
> https://www.rfc-editor.org/errata/eid####
>
> (e.g., https://www.rfc-editor.org/errata/eid4920)
>
> Note that for the concatenated records (the "Full Records" in a search
> on the RFC Editor website) those remain URL search strings.
>
> I will be adjusting the Style Guide, and the RPC will manage the
> references as needed for documents in our queue.
>
> Please let me know if you have any questions!
> Heather
> _______________________________________________
> rfc-interest mailing list
> [email-masked]
> https://www.rfc-editor.org/mailman/listinfo/rfc-interest
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: "Heather Flanagan (RFC Series Editor)" <[email-masked]>
Date: Mon, 25 Sep 2017 06:56:36 -0700

Hi Martin,

Ack. I'll take this to the RPC and we'll see what we can do.

-Heather

---

From: Julian Reschke <[email-masked]>
Date: Fri, 29 Sep 2017 09:55:22 +0200

On 2017-09-25 03:32, Martin Thomson wrote:
> ...

+1 on making the HTML/CSS better.

However, +1000 for making this really machine-readable, and providing 
the information suitable for CORS requests, so HTML versions of RFCs can 
dynamically pull it in.

Best regards, Julian