Subject: [rfc-i] Authoring I-D/RFCs in AsciiDoc

From: Ronald Tse <[email-masked]>
Date: Sat, 25 Nov 2017 16:26:22 +0000

Warm greetings to everyone on the rfc-interest list!

We’ve recently made a tool that allows writing Internet-Drafts using AsciiDoc called “asciidoctor-rfc” [1], as an alternative to Kramdown / MMark or manual RFC XML. AsciiDoc is a widely-adopted textual format. Similar to Markdown, it is simple to write and easy to understand, but its major benefit is for being a structured format that directly converts into DocBook XML.

The tool, “asciidoctor-rfc” supports generating both v3 and v2 RFC XML through the “AsciiRFC” syntax [2].

We have attempted to expose as many v3 (and v2) features as possible through native AsciiDoc syntax. I do know the v3 xml2rfc tool is under development (originally scheduled for Oct?), and we are excited to try it out using RFC XML files generated with asciidoctor-rfc.

Here are some examples created through this asciidoctor-rfc:
* A large number of v2/v3 examples, including the IETF templates, at [3]
* draft-oscca-cfrg-sm3-02 (source: [4], text: [5])
* draft-ribose-cfrg-sm4-03 (source: [6], text: [7])

We are very interested in your (and RFC Editors!) feedback. Please let us know how this could work better for you — we look forward hearing from all interested parties. Thank you in advance!

Links:

[1] https://github.com/riboseinc/asciidoctor-rfc
[2] https://tools.ietf.org/html/draft-ribose-asciirfc-01
[3] https://github.com/riboseinc/asciidoctor-rfc/tree/master/spec/examples
[4] https://github.com/riboseinc/rfc-crypto-sm3
[5] https://tools.ietf.org/html/draft-oscca-cfrg-sm3-02
[6] https://github.com/riboseinc/rfc-crypto-sm3
[7] https://tools.ietf.org/html/draft-ribose-cfrg-sm4-03

Kind regards,
Ronald

_____________________________________

Ronald Tse
Ribose Inc.

_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Julian Reschke <[email-masked]>
Date: Mon, 27 Nov 2017 12:24:49 +0100

On 2017-11-25 17:26, Ronald Tse wrote:
> We’ve recently made a tool that allows writing Internet-Drafts using 
> AsciiDoc called “asciidoctor-rfc” [1], as an alternative to Kramdown / 
> MMark or manual RFC XML. AsciiDoc is a widely-adopted textual format. 
> Similar to Markdown, it is simple to write and easy to understand, but 
> its major benefit is for being a structured format that directly 
> converts into DocBook XML.
> 
> We have attempted to expose as many v3 (and v2) features as possible 
> through native AsciiDoc syntax. I do know the v3 xml2rfc tool is under 
> development (originally scheduled for Oct?), and we are excited to try 
> it out using RFC XML files generated with asciidoctor-rfc.
> ...

You may want to try it with rfc2629.xslt, which already supports a broad 
range of V3 features...: 
<https://www.greenbytes.de/tech/webdav/rfc2629xslt/rfc2629xslt.html#v3>

Best regards, Julian

---

From: Ronald Tse <[email-masked]>
Date: Mon, 27 Nov 2017 14:40:05 +0000

Thank you very much Julian, we will try to include this in our test suite to test for v2/v3 compatibility :-P

Kind regards,
Ron

Ronald Tse
Ribose Inc.

On Nov 27, 2017, at 7:24 PM, Julian Reschke <[email-masked]<mailto:[email-masked]>> wrote:

You may want to try it with rfc2629.xslt, which already supports a broad range of V3 features...: <https://www.greenbytes.de/tech/webdav/rfc2629xslt/rfc2629xslt.html#v3>

Best regards, Julian