Subject: [rfc-i] Reminder: RFC++ BoF

From: "Heather Flanagan (RFC Series Editor)" <[email-masked]>
Date: Mon, 16 Jul 2018 08:18:27 -0400

Hello all,

A reminder that the RFC++ BoF is this evening from 18:10-19:40 in the 
Laurier room.

BoF description: https://trac.tools.ietf.org/bof/trac/
Mailing list: https://www.ietf.org/mailman/listinfo/rfcplusplus
Mailing list archive: https://mailarchive.ietf.org/arch/browse/rfcplusplus/

If you are unable to attend and have opinions, please join the 
rfcplusplus list and add your thoughts.

Thanks!
Heather
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Adam Roach <[email-masked]>
Date: Mon, 16 Jul 2018 08:36:19 -0400

On 7/16/18 08:18, Heather Flanagan (RFC Series Editor) wrote:
> Mailing list archive: 
> https://mailarchive.ietf.org/arch/browse/rfcplusplus/
>

Also, if you are not in Montreal but are available during the BoF (18:10 
- 19:40 EDT, UTC-4), there are several provisions for participating 
remotely. See https://www.ietf.org/how/meetings/102/remote/ for details.

/a

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 16 Jul 2018 09:31:35 -0400

Looking at how full Laurier is for 6man, folks may want to move quickly 
to the room for rfc++ tonight.  It is not that big a room.

Yours,
Joel

---

From: Lucy Lynch <[email-masked]>
Date: Mon, 16 Jul 2018 13:35:49 +0000 (UTC)

On Mon, 16 Jul 2018, Joel M. Halpern wrote:

> Looking at how full Laurier is for 6man, folks may want to move quickly to 
> the room for rfc++ tonight.  It is not that big a room.

A heads up to AMS may allow for a room move...

>> If you are unable to attend and have opinions, please join the rfcplusplus 
>> list and add your thoughts.
>> 
>> Thanks!
>> Heather

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 17 Jul 2018 01:48:01 +1200

It's been a while since I had to sit on the floor in an IETF session ;-)

Regards
   Brian

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 16 Jul 2018 10:09:34 -0400

> It's been a while since I had to sit on the floor in an IETF session ;-)

Fortunately, I can’t come because somebody put a side meeting on top that I can’t miss.

I don’t know whether there is a venue to discuss this BOF beforehand.
Maybe somebody can take my thinking to the microphone this evening.

(1) We have a problem with people out there understanding what an RFC is.
    (Mostly because it takes a long time for people to become familiar with the rules that apply.)

(2) We don’t like that, so we change the rules and create more confusion.

(3) Profit.

I have a missing link between 2 and 3.

And I’m sure we’ll do (2) more than once, because of unintended consequences.
In effect turning a very stable, incredibly valuable resource, the RFC series, into a mess.

Don’t do that.

Grüße, Carsten

---

From: "Eggert, Lars" <[email-masked]>
Date: Mon, 16 Jul 2018 14:45:13 +0000

> In effect turning a very stable, incredibly valuable resource, the RFC series, into a mess.

Since I can't be there either: +100

People have articulated a bunch of very minor problems with the current state of affairs. Even if I did agree that all of them were real, and even if they could all be addressed with one fix, the risks of increasing the confusion in the broader community is not worth the change.

(And I don't agree with most of the articulated problems, and I don't think even a small number of fixes can address most of them in a meaningful way.)

Lars

---

From: Harald Alvestrand <[email-masked]>
Date: Mon, 16 Jul 2018 16:48:39 -0400

Note: After reading the agenda, all referenced drafts (0) and the
meeting slides, I still have no idea what problem the BOF has been
scheduled to solve.

I know it's "the RFC problem", but don't know what this problem consists of.

That's not a good state to be in.

-- 
Surveillance is pervasive. Go Dark.

---

From: Ted Lemon <[email-masked]>
Date: Mon, 16 Jul 2018 18:04:01 -0400

Just rest assured that the answer to the great question of life, the RFCs,
and everything, is 42.

---

From: Loa Andersson <[email-masked]>
Date: Mon, 16 Jul 2018 18:08:55 -0400

Oopps! Suddenly I have one thing I feel good about. I’m no longer alone in the wilderness. 

/Loa

Sent from my iPhone

> On 16 Jul 2018, at 16:48, Harald Alvestrand <[email-masked]> wrote:
>

---

From: Martin J. Dürst <[email-masked]>
Date: Tue, 17 Jul 2018 10:53:13 +0900

> Just rest assured that the answer to the great question of life, the RFCs,

We're already done then, aren't we: https://tools.ietf.org/html/rfc42.

Regards,   Martin.

P.S.: Sorry, I just couldn't resist.

---

From: Ted Lemon <[email-masked]>
Date: Mon, 16 Jul 2018 21:55:29 -0400

The trick is that the answer is easy.   It's the question that's hard.

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 17 Jul 2018 16:17:25 -0600

> (1) We have a problem with people out there understanding what an RFC is.

That's easy - an RFC is request for comments:

https://github.com/rust-lang/rfcs

Peter

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 18 Jul 2018 13:11:29 +1200

> https://github.com/rust-lang/rfcs

And: 

https://tools.ietf.org/html/draft-carpenter-request-for-comments-00#section-4

Not that much different in philosophy.

   Brian

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 17 Jul 2018 22:06:16 -0400

> https://tools.ietf.org/html/draft-carpenter-request-for-comments-00#section-4

Wow, I didn’t know somebody took the time to write this up (thank you!).

If this fount of wisdom is already documented, why on earth did we have a BOF?

(And, since I wasn’t there at the BOF and haven’t heard a report):
Was there any significant damage?

Grüße, Carsten

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 20 Jul 2018 15:12:53 +1200

On 18/07/2018 14:06, Carsten Bormann wrote:

(for some reason, delivered late Thursday)

> If this fount of wisdom is already documented, why on earth did we have a BOF?

I won't comment on that.
 
> Was there any significant damage?

The minutes:
https://datatracker.ietf.org/meeting/102/materials/minutes-102-rfcplusplus-00

I understand that the problem analysis should be carried forward by the RFC Series Editor. So no immediate actions.

    Brian